[PATCH] gnu: go-github-com-hodgesds-perf-utils: Skip more tests on arm.

  • Done
  • quality assurance status badge
Details
One participant
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 2 weeks ago
(address . guix-patches@gnu.org)
a8064844bcc0484dcb8b7d32262d740bc29d7afc.1740766328.git.mail@cbaines.net
I see these failing when built on Honeycomb build machines:

=== RUN TestDataTLB
utils_test.go:234: no such file or directory
--- FAIL: TestDataTLB (0.00s)
=== RUN TestInstructionTLB
utils_test.go:246: no such file or directory
--- FAIL: TestInstructionTLB (0.00s)

It could be something with the system configuration but just disable the tests
for now. This is working towards getting the prometheus-node-exporter package
building again on aarch64-linux.

Note that there's even more test failures when trying to build with qemu
binfmt emulation.

* gnu/packages/golang-xyz.scm (go-github-com-hodgesds-perf-utils)[arguments]:
Skip a couple more tests on arm.

Change-Id: Ib5bc41679d825a1a727e240e7fffeb336f82db6d
---
gnu/packages/golang-xyz.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 67957caae0..0b7858e4fe 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -7509,7 +7509,11 @@ (define-public go-github-com-hodgesds-perf-utils
"TestNodeCache"
"TestProfiler"
"TestSoftwareProfiler"
- "TestTraceFSMount")
+ "TestTraceFSMount"
+ #$@(if (target-arm?)
+ '("TestDataTLB"
+ "TestInstructionTLB")
+ '()))
"|"))))
(native-inputs
(list go-github-com-stretchr-testify))

base-commit: a76708a872e65230931f3c5c3b079d0a39d5cb84
--
2.48.1
Christopher Baines wrote 1 weeks ago
(address . 76652-done@debbugs.gnu.org)
87ikoqw5fk.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (24 lines)
> I see these failing when built on Honeycomb build machines:
>
> === RUN TestDataTLB
> utils_test.go:234: no such file or directory
> --- FAIL: TestDataTLB (0.00s)
> === RUN TestInstructionTLB
> utils_test.go:246: no such file or directory
> --- FAIL: TestInstructionTLB (0.00s)
>
> It could be something with the system configuration but just disable the tests
> for now. This is working towards getting the prometheus-node-exporter package
> building again on aarch64-linux.
>
> Note that there's even more test failures when trying to build with qemu
> binfmt emulation.
>
> * gnu/packages/golang-xyz.scm (go-github-com-hodgesds-perf-utils)[arguments]:
> Skip a couple more tests on arm.
>
> Change-Id: Ib5bc41679d825a1a727e240e7fffeb336f82db6d
> ---
> gnu/packages/golang-xyz.scm | 6 +++++-
> 1 file changed, 5 insertions(+), 1 deletion(-)

I was hoping to wait for QA, but gnome-team has landed so I'm just going
to push this 🤞 as c8f537ac0517f45393c8bf68fc0259f185324cc5.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmfFvX9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfQnw/9FHuC4VakqvFOEIVW/8d0VJ3+nqpjo2X5
Vm5cGVLjWeOy9ccYc6fS1yHzTZ7OITLVqkzPW+RI92sVQwzGd3zlpMrleWpSmUO2
u77x6GsfJw+0xNiJvMzM4BWdmd0Q3uSkpJ4p3GEQjFT97YnCKbNbwQIdQ6fXWdZo
jEXcZcsVG6k5htAQws8pYILvfK5F3Xz58TvtkzcqrPMdedgLZSifRm40SXJFhHpP
emChwMrIXjBq7uy2W7q+UH/AIdgLbplMZ4czrju35NvdnCAeo2f1b6k6spt3tllP
a5uCo1twD/H4jc+QAKu1w/ZwY3zkePZllKlp0j4HySXJo87oG5U/F/8vhXGdr+Dn
XfNaVaMziOwNej55pFrI0Yh7v2z3L3roQ2u/IzT0+4XnLHoaIJ2oP822j36mQCex
oe8YmDLZc1lbonkHpWDSCK34cMFE/ylqK4DJYjHESIZEIR0zFU530hoLSBQoVJIC
DoxKms71J9OhCCC5XWZ0+x4W1GP9xXFApSjOlYDWzcqkoFutGcQJ1EHAHmQXmKui
YwwEPTXw8ahgdLvdjoHEFJLm5hw/rK2fWpAHZbRUT/0SbJXMS784Vy9EOwmBNuCH
SMJvrxY8Mvky9lxnEF81I64WlAGQhJGKJkJT/C07fTfRkK9hNCRRK3SYLw74UnI0
qzIrzuftAsY=
=ZqGC
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76652@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76652
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help