ashish.is wrote 2 weeks ago
[PATCH] gnu: Add dte.
(address . guix-patches@gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
From: Ashish SHUKLA <ashish.is@lostca.se>
* gnu/packages/text-editors.scm (dte): New variable.
Change-Id: I1fdee33377b055a43cf61364f43a6dcbaf04a024
---
Hi,
This patch adds dte, a console based text editor, which is fairly fast, portable, and has a few modern features.
Thanks!
gnu/packages/text-editors.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)
Toggle diff (59 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index e96fceb510..d006b7909d 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2024 Murilo <murilo@disroot.org>
;;; Copyright © 2025 Ashvith Shetty <ashvithshetty0010@zohomail.in>
;;; Copyright © 2025 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2025 Ashish SHUKLA <ashish.is@lostca.se>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -104,6 +105,7 @@ (define-module (gnu packages text-editors)
#:use-module (gnu packages image)
#:use-module (gnu packages lesstif)
#:use-module (gnu packages libbsd)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages lisp-check)
#:use-module (gnu packages lisp-xyz)
#:use-module (gnu packages llvm)
@@ -1898,3 +1900,34 @@ (define-public xnedit
"XNEdit is a fast and classic X11 text editor, based on NEdit,
with full unicode support and antialiased text rendering.")
(license license:gpl2+)))
+
+(define-public dte
+ (package
+ (name "dte")
+ (version "1.11.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/craigbarnes/dte")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1q43jvhj6r1ws58ngpcq8mzj4di7mj2a4bmigk9zy0f3riagnlv1"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list util-linux))
+ (arguments
+ (list
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "prefix=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://gitlab.com/craigbarnes/dte/")
+ (synopsis "Small and easy to use console text editor.")
+ (description
+ "@command{dte} is a portable console text editor with features like multiple buffers/tabs,
+syntax highlighting, customizable color scheme (including support for 24-bit true
+colours), kitty keyboard protocol, editorconfig support, amongst other features.")
+ (license license:gpl2)))
base-commit: a76708a872e65230931f3c5c3b079d0a39d5cb84
--
2.48.1