[PATCH v2] gnu: Add dte.

  • Open
  • quality assurance status badge
Details
2 participants
  • ashish.is
  • 宋文武
Owner
unassigned
Submitted by
ashish.is
Severity
normal

Debbugs page

ashish.is wrote 2 weeks ago
[PATCH] gnu: Add dte.
(address . guix-patches@gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
1f65435f619972b542313f40b8e06c105382e672.1740735729.git.ashish.is@lostca.se
From: Ashish SHUKLA <ashish.is@lostca.se>

* gnu/packages/text-editors.scm (dte): New variable.

Change-Id: I1fdee33377b055a43cf61364f43a6dcbaf04a024
---
Hi,

This patch adds dte, a console based text editor, which is fairly fast, portable, and has a few modern features.

Thanks!

gnu/packages/text-editors.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index e96fceb510..d006b7909d 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2024 Murilo <murilo@disroot.org>
;;; Copyright © 2025 Ashvith Shetty <ashvithshetty0010@zohomail.in>
;;; Copyright © 2025 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2025 Ashish SHUKLA <ashish.is@lostca.se>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -104,6 +105,7 @@ (define-module (gnu packages text-editors)
#:use-module (gnu packages image)
#:use-module (gnu packages lesstif)
#:use-module (gnu packages libbsd)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages lisp-check)
#:use-module (gnu packages lisp-xyz)
#:use-module (gnu packages llvm)
@@ -1898,3 +1900,34 @@ (define-public xnedit
"XNEdit is a fast and classic X11 text editor, based on NEdit,
with full unicode support and antialiased text rendering.")
(license license:gpl2+)))
+
+(define-public dte
+ (package
+ (name "dte")
+ (version "1.11.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/craigbarnes/dte")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1q43jvhj6r1ws58ngpcq8mzj4di7mj2a4bmigk9zy0f3riagnlv1"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list util-linux))
+ (arguments
+ (list
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "prefix=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://gitlab.com/craigbarnes/dte/")
+ (synopsis "Small and easy to use console text editor.")
+ (description
+ "@command{dte} is a portable console text editor with features like multiple buffers/tabs,
+syntax highlighting, customizable color scheme (including support for 24-bit true
+colours), kitty keyboard protocol, editorconfig support, amongst other features.")
+ (license license:gpl2)))

base-commit: a76708a872e65230931f3c5c3b079d0a39d5cb84
--
2.48.1
宋文武 wrote 6 days ago
(address . ashish.is@lostca.se)(address . 76635@debbugs.gnu.org)
87mse0thi2.fsf@envs.net
Hello,

ashish.is@lostca.se writes:

Toggle quote (14 lines)
> [...]
> +(define-public dte
> + (package
> + (name "dte")
> + (version "1.11.1")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://gitlab.com/craigbarnes/dte")
> + (commit (string-append "v" version))))
> + (sha256
> + (base32
> + "1q43jvhj6r1ws58ngpcq8mzj4di7mj2a4bmigk9zy0f3riagnlv1"))))

When using git-fetch, it's required to also use '(file-name (git-file-name ...))'.

Toggle quote (12 lines)
> + (build-system gnu-build-system)
> + (native-inputs
> + (list util-linux))
> + (arguments
> + (list
> + #:make-flags
> + #~(list (string-append "CC=" #$(cc-for-target))
> + (string-append "prefix=" #$output))
> + #:phases
> + #~(modify-phases %standard-phases
> + (delete 'configure))))
> + (home-page "https://gitlab.com/craigbarnes/dte/")
Prefer a real home page if existed, so should be: https://craigbarnes.gitlab.io/dte/

Toggle quote (1 lines)
> + (synopsis "Small and easy to use console text editor.")
synopsis should not ends with '.'.


Otherwise looks good, could you send an update patch? Thanks.
ashish.is wrote 6 days ago
[PATCH v2] gnu: Add dte.
(address . iyzsong@envs.net)
b9151cc218995eb8bbcfda864f4760beba7beffa.1741183653.git.ashish.is@lostca.se
From: Ashish SHUKLA <ashish.is@lostca.se>

* gnu/packages/text-editors.scm (dte): New variable.

Change-Id: I1fdee33377b055a43cf61364f43a6dcbaf04a024
---
Hi,

Thanks for taking time to review.

gnu/packages/text-editors.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index e96fceb510..d32ba3b7b1 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2024 Murilo <murilo@disroot.org>
;;; Copyright © 2025 Ashvith Shetty <ashvithshetty0010@zohomail.in>
;;; Copyright © 2025 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2025 Ashish SHUKLA <ashish.is@lostca.se>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -104,6 +105,7 @@ (define-module (gnu packages text-editors)
#:use-module (gnu packages image)
#:use-module (gnu packages lesstif)
#:use-module (gnu packages libbsd)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages lisp-check)
#:use-module (gnu packages lisp-xyz)
#:use-module (gnu packages llvm)
@@ -1898,3 +1900,35 @@ (define-public xnedit
"XNEdit is a fast and classic X11 text editor, based on NEdit,
with full unicode support and antialiased text rendering.")
(license license:gpl2+)))
+
+(define-public dte
+ (package
+ (name "dte")
+ (version "1.11.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/craigbarnes/dte")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1q43jvhj6r1ws58ngpcq8mzj4di7mj2a4bmigk9zy0f3riagnlv1"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list util-linux))
+ (arguments
+ (list
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "prefix=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://craigbarnes.gitlab.io/dte/")
+ (synopsis "Small and easy to use console text editor")
+ (description
+ "@command{dte} is a portable console text editor with features like multiple buffers/tabs,
+syntax highlighting, customizable color scheme (including support for 24-bit true
+colours), kitty keyboard protocol, editorconfig support, amongst other features.")
+ (license license:gpl2)))

base-commit: cc71a8e8ea21584353e22771be643bdaadfa0c12
--
2.48.1
Ashish SHUKLA wrote 6 days ago
retitle bug
(address . control@debbugs.gnu.org)
D88E4PU3H61N.1K58PIYVR6C3M@lostca.se
retitle 76635 [PATCH v2] gnu: Add dte.
quit
--
Ashish SHUKLA | GPG: F682 CDCC 39DC 0FEA E116 20B6 C746 CFA9 E74F A4B0

"If I destroy you, what business is it of yours ?" (Dark Forest, Liu Cixin)
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76635@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76635
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help