[PATCH] gnu: Add r-randomforestexplainer.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • King, Spencer
Owner
unassigned
Submitted by
King, Spencer
Severity
normal

Debbugs page

King, Spencer wrote 2 weeks ago
(name . King, Spencer via Guix-patches via)(address . guix-patches@gnu.org)(name . Ricardo Wurmus)(address . rekado@elephly.net)(name . laurent.gatto@gmail.com)(address . laurent.gatto@gmail.com)(name . zimon.toutoune@gmail.com)(address . zimon.toutoune@gmail.com)
CH3PR02MB9746187DE387149CB09532DE90CC2@CH3PR02MB9746.namprd02.prod.outlook.com

From 6e6e7521eac6cfd2227946eebcc85c68438fd0b8 Mon Sep 17 00:00:00 2001
From: Spencer King <spencer.king@wustl.edu>
Date: Fri, 14 Feb 2025 17:20:25 -0600
Subject: [PATCH] gnu: Add r-randomforestexplainer.

* gnu/packages/cran.scm (r-randomforestexplainer): New variable.

Change-Id: I9236716971219c55850440f8cbae022f5641eebc
---
gnu/packages/cran.scm | 38 +++++++++++++++++++++++++++++++++++++-
1 file changed, 37 insertions(+), 1 deletion(-)

Toggle diff (60 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3d6ea6be28..863ef26af3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -38,7 +38,7 @@
;;; Copyright © 2022-2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
;;; Copyright © 2024 Marco Baggio <guix@mawumag.com>
-;;; Copyright © 2024 Spencer King <spencer.king@geneoscopy.com>
+;;; Copyright © 2024, 2025 Spencer King <spencer.king@geneoscopy.com>
;;; Copyright © 2024 Tor-björn Claesson <tclaesson@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -43999,6 +43999,42 @@ (define-public r-gsalib
for variant discovery in high-throughput sequencing data.")
(license license:expat)))
+(define-public r-randomforestexplainer
+ (package
+ (name "r-randomforestexplainer")
+ (version "0.10.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "randomForestExplainer" version))
+ (sha256
+ (base32 "1ny8c3vn2zvdx12avwvlm4lp648jigkrkcvnhf5qmj8rh0w069v0"))))
+ (properties `((upstream-name . "randomForestExplainer")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-data-table
+ r-dplyr
+ r-dt
+ r-ggally
+ r-ggplot2
+ r-ggrepel
+ r-randomforest
+ r-ranger
+ r-reshape2
+ r-rmarkdown))
+ (native-inputs (list r-knitr r-testthat))
+ (home-page "https://github.com/ModelOriented/randomForestExplainer")
+ (synopsis
+ "Explaining and Visualizing Random Forests in Terms of Variable Importance")
+ (description
+ "This package provides a set of tools to help explain which variables are most
+important in a random forests. Various variable importance measures are
+calculated and visualized in different settings in order to get an idea on how
+their importance changes depending on our criteria (Hemant Ishwaran and Udaya B.
+Kogalur and Eiran Z. Gorodeski and Andy J. Minn and Michael S. Lauer (2010)
+<doi:10.1198/jasa.2009.tm08622>, Leo Breiman (2001)
+<doi:10.1023/A:1010933404324>).")
+ (license (list license:gpl2+ license:gpl3+))))
+
(define-public r-randomforestsrc
(package
(name "r-randomforestsrc")

base-commit: 4b5f0408e66392ab745dc0f7830732217d88f17d
--
2.41.0
Christopher Baines wrote 2 weeks ago
(name . King, Spencer via Guix-patches via)(address . guix-patches@gnu.org)(address . 76630-done@debbugs.gnu.org)
87tt8cxsqo.fsf@cbaines.net
"King, Spencer via Guix-patches" via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> [2. 0001-gnu-Add-r-randomforestexplainer.patch --- text/x-patch; 0001-gnu-Add-r-randomforestexplainer.patch]...

Thanks, I've pushed this to master as
b9d183e567edf147fd3fc63630fadb149825ba20.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmfDkT9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xcwwg//VrODx5ctKG2ML2sonDVPctk5EAF/dpAZ
FAeZKV6bZ7/xPK6jULTbPpuxBeDGw1Oga4IiRJIYJNd2BFnfTsNM1HPuifOT+I6X
gQQCtNn0xkJGCsRJ3qMjr7A+3H11oeW3qmyKrzFoIoCSSTSpGryvqoXN6jKAV9Bk
2NBbVyNnZNbuWXcJtqRdxJCtanLIXp+tRXvX2Eq9tX3QaAUlMIHU6JIphGPO/a+I
F0VDeIaQaR+qB0bpvth3cGJSx3y4SgqDME0Zc7J3s+3PaZss9Ry8bWiXGo/bD9Kf
wz/uIZPS+J97GpainF6ZY3p+5TwOADIyjL/jYG1r6m48dKUOPgP4vON8WB8otuHp
+ni1ZbljPnQ3aEhurPBGbh0YdMhdC4hOfQmMyM4l2x/n9I8g0LgI6W4zt2hZifs1
McaQtfGz/c8MJuHghqr7k4SiRf7tKtCEF5E0lPW/aLM1++hJp41FgehzhIBE/7B/
temxxBgWlIAMcFVzfu179kVGYoHZncVEZt9TZTynjrCyOs0rPV6ubpqD6o6waMSH
5ylkPA4yuyU/6UsJ5+iZZghfPSxWbLPB7Lt+7hQOZJRuKGZM1KIZehKngTmmbOQ3
opNyQ00m7m3bfyV6N0tkr1rWeAZQQUPMKMbzPhXxYIRL8QGdwQDgi3MD0M/T1dvL
NasEOMcmhIo=
=or93
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76630@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76630
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help