Tomas Volf wrote 2 weeks ago
(address . bug-guile@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
* module/sxml/xpath.scm: Fix typo in a comment.
* module/sxml/upstream/SXPath-old.scm: Same.
* doc/ref/sxml.texi (SXPath): Reflect in the documentation.
---
doc/ref/sxml.texi | 2 +-
module/sxml/upstream/SXPath-old.scm | 2 +-
module/sxml/xpath.scm | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
Toggle diff (41 lines)
diff --git a/doc/ref/sxml.texi b/doc/ref/sxml.texi
index fceb30655..108a95d4e 100644
--- a/doc/ref/sxml.texi
+++ b/doc/ref/sxml.texi
@@ -726,7 +726,7 @@ mutually-recursive datatypes <Node> and <Nodeset> lends itself well to
processing by functional languages.
A location path is in fact a composite query over an XPath tree or its
-branch. A singe step is a combination of a projection, selection or a
+branch. A single step is a combination of a projection, selection or a
transitive closure. Multiple steps are combined via join and union
operations. This insight allows us to @emph{elegantly} implement XPath
as a sequence of projection and filtering primitives -- converters --
diff --git a/module/sxml/upstream/SXPath-old.scm b/module/sxml/upstream/SXPath-old.scm
index cf4526ed6..f46c83441 100644
--- a/module/sxml/upstream/SXPath-old.scm
+++ b/module/sxml/upstream/SXPath-old.scm
@@ -41,7 +41,7 @@
; <Nodeset> lends itself well to processing by functional languages.
;
; A location path is in fact a composite query over an XPath tree or
-; its branch. A singe step is a combination of a projection, selection
+; its branch. A single step is a combination of a projection, selection
; or a transitive closure. Multiple steps are combined via join and
; union operations. This insight allows us to _elegantly_ implement
; XPath as a sequence of projection and filtering primitives --
diff --git a/module/sxml/xpath.scm b/module/sxml/xpath.scm
index bdf4ae98a..edec2faea 100644
--- a/module/sxml/xpath.scm
+++ b/module/sxml/xpath.scm
@@ -68,7 +68,7 @@
;; <Nodeset> lends itself well to processing by functional languages.
;;
;; A location path is in fact a composite query over an XPath tree or
-;; its branch. A singe step is a combination of a projection, selection
+;; its branch. A single step is a combination of a projection, selection
;; or a transitive closure. Multiple steps are combined via join and
;; union operations. This insight allows us to @emph{elegantly}
;; implement XPath as a sequence of projection and filtering primitives
--
2.48.1