[PATCH] gnu: Add emacs-magit-tbdiff.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ian Eure
  • Liam Hupfer
Owner
unassigned
Submitted by
Liam Hupfer
Severity
normal

Debbugs page

Liam Hupfer wrote 2 weeks ago
(address . guix-patches@gnu.org)(name . Liam Hupfer)(address . liam@hpfr.net)
0ffee4f82eaddefbca0552ac05ce80198b49fbbb.1740338191.git.liam@hpfr.net
* gnu/packages/emacs-xyz.scm (emacs-magit-tbdiff): New variable.

Change-Id: I706875beba2c896962e8c811b7bc6b1e45e99c93
---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 59c1927135..31ee90d989 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2034,6 +2034,29 @@ (define-public emacs-magit-annex
"Magit-annex adds a few git-annex operations to the Magit interface.")
(license license:gpl3+)))
+(define-public emacs-magit-tbdiff
+ (package
+ (name "emacs-magit-tbdiff")
+ (version "1.2.0")
+ (home-page "https://github.com/magit/magit-tbdiff")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jh6wspb6ijmkqvyaswqj60ixpgjj2ijcf0b53q48pfs5dwc97p4"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-magit))
+ (synopsis "Magit extension for range diffs")
+ (description
+ "Magit-tbdiff provides a Magit interface to @code{git-range-diff} (and its
+third-party predecessor @code{git-tbdiff}), a Git subcommand for comparing two
+versions of a topic branch.")
+ (license license:gpl3+)))
+
(define-public emacs-malyon
(package
(name "emacs-malyon")

base-commit: 23b068c036223e70bdea9d7d579850a1cffc02a7
--
2.48.1
Ian Eure wrote 2 weeks ago
(name . Liam Hupfer)(address . liam@hpfr.net)
871pvgfzee.fsf@retrospec.tv
Hi Liam,

Pushed as 80dd91f957.

Thanks,
-- Ian
Ian Eure wrote 2 weeks ago
control message for bug #76511
(address . control@debbugs.gnu.org)
87senwekoj.fsf@retrospec.tv
close 76511
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76511@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76511
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help