[PATCH] gnu: connman: Update to 1.43.

  • Done
  • quality assurance status badge
Details
2 participants
  • 宋文武
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal

Debbugs page

Tomas Volf wrote 3 weeks ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
1a2e96f89d1eb20ddf3c62bdab154f5daca41722.1740180596.git.~@wolfsden.cz
* gnu/packages/connman.scm (connman): Update to 1.43.
* gnu/packages/patches/connman-add-missing-libppp-compat.h.patch: Delete
obsolete patch.
* gnu/local.mk (dist_patch_DATA): De-register it.

Change-Id: I563f535c27b99972e95d96f291ce5dfdc83a46f1
---
gnu/local.mk | 1 -
gnu/packages/connman.scm | 6 +-
.../connman-add-missing-libppp-compat.h.patch | 140 ------------------
3 files changed, 2 insertions(+), 145 deletions(-)
delete mode 100644 gnu/packages/patches/connman-add-missing-libppp-compat.h.patch

Toggle diff (183 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index c421da85cb..44e63e037b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1128,7 +1128,6 @@ dist_patch_DATA = \
%D%/packages/patches/collectd-5.11.0-noinstallvar.patch \
%D%/packages/patches/combinatorial-blas-awpm.patch \
%D%/packages/patches/combinatorial-blas-io-fix.patch \
- %D%/packages/patches/connman-add-missing-libppp-compat.h.patch \
%D%/packages/patches/containerd-create-pid-file.patch \
%D%/packages/patches/converseen-hide-updates-checks.patch \
%D%/packages/patches/converseen-hide-non-free-pointers.patch \
diff --git a/gnu/packages/connman.scm b/gnu/packages/connman.scm
index bc6328926a..c5a0f8482c 100644
--- a/gnu/packages/connman.scm
+++ b/gnu/packages/connman.scm
@@ -47,16 +47,14 @@ (define-module (gnu packages connman)
(define-public connman
(package
(name "connman")
- (version "1.42")
+ (version "1.43")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/network/connman/"
"connman-" version ".tar.xz"))
(sha256
- (base32 "1an24caah35chc1c48p67ln8kpj9fr7slg5fklpfz0f0dzjbmrm3"))
- (patches
- (search-patches "connman-add-missing-libppp-compat.h.patch"))))
+ (base32 "1g735gnhhhqzjhpwv62q8mg8345a62rhyk5qwavh0yby6azcwmqj"))))
(build-system gnu-build-system)
(arguments
(list #:configure-flags
diff --git a/gnu/packages/patches/connman-add-missing-libppp-compat.h.patch b/gnu/packages/patches/connman-add-missing-libppp-compat.h.patch
deleted file mode 100644
index 4432c161fd..0000000000
--- a/gnu/packages/patches/connman-add-missing-libppp-compat.h.patch
+++ /dev/null
@@ -1,140 +0,0 @@
-From: Tobias Geerinckx-Rice <me@tobias.gr>
-Date: Sun Sep 24 02:00:00 2023 +0200
-Subject: connman: Add missing libppp-compat.h.
-
-This file was taken verbatim from upstream commit
-a48864a2e5d2a725dfc6eef567108bc13b43857f. Its absence was since
-fixed in upstream commit 09c1bbfd55647b18b5bbbb99ef2b6d902465ca16.
-
----
-diff -Naur a/scripts/libppp-compat.h b/scripts/libppp-compat.h
---- a/scripts/libppp-compat.h 1970-01-01 01:00:00.000000000 +0100
-+++ b/scripts/libppp-compat.h 2023-09-29 00:45:18.726709659 +0200
-@@ -0,0 +1,127 @@
-+/* Copyright (C) Eivind Naess, eivnaes@yahoo.com */
-+/* SPDX-License-Identifier: GPL-2.0-or-later */
-+
-+#ifndef __LIBPPP_COMPAT_H__
-+#define __LIBPPP_COMPAT_H__
-+
-+/* Define USE_EAPTLS compile with EAP TLS support against older pppd headers,
-+ * pppd >= 2.5.0 use PPP_WITH_EAPTLS and is defined in pppdconf.h */
-+#define USE_EAPTLS 1
-+
-+/* Define INET6 to compile with IPv6 support against older pppd headers,
-+ * pppd >= 2.5.0 use PPP_WITH_IPV6CP and is defined in pppdconf.h */
-+#define INET6 1
-+
-+/* PPP < 2.5.0 defines and exports VERSION which overlaps with current package VERSION define.
-+ * this silly macro magic is to work around that. */
-+#undef VERSION
-+#include <pppd/pppd.h>
-+
-+#ifndef PPPD_VERSION
-+#define PPPD_VERSION VERSION
-+#endif
-+
-+#include <pppd/fsm.h>
-+#include <pppd/ccp.h>
-+#include <pppd/eui64.h>
-+#include <pppd/ipcp.h>
-+#include <pppd/ipv6cp.h>
-+#include <pppd/eap.h>
-+#include <pppd/upap.h>
-+
-+#ifdef HAVE_PPPD_CHAP_H
-+#include <pppd/chap.h>
-+#endif
-+
-+#ifdef HAVE_PPPD_CHAP_NEW_H
-+#include <pppd/chap-new.h>
-+#endif
-+
-+#ifdef HAVE_PPPD_CHAP_MS_H
-+#include <pppd/chap_ms.h>
-+#endif
-+
-+#ifndef PPP_PROTO_CHAP
-+#define PPP_PROTO_CHAP 0xc223
-+#endif
-+
-+#ifndef PPP_PROTO_EAP
-+#define PPP_PROTO_EAP 0xc227
-+#endif
-+
-+
-+#if WITH_PPP_VERSION < PPP_VERSION(2,5,0)
-+
-+static inline bool
-+debug_on (void)
-+{
-+ return debug;
-+}
-+
-+static inline const char
-+*ppp_ipparam (void)
-+{
-+ return ipparam;
-+}
-+
-+static inline int
-+ppp_ifunit (void)
-+{
-+ return ifunit;
-+}
-+
-+static inline const char *
-+ppp_ifname (void)
-+{
-+ return ifname;
-+}
-+
-+static inline int
-+ppp_get_mtu (int idx)
-+{
-+ return netif_get_mtu(idx);
-+}
-+
-+typedef enum ppp_notify
-+{
-+ NF_PID_CHANGE,
-+ NF_PHASE_CHANGE,
-+ NF_EXIT,
-+ NF_SIGNALED,
-+ NF_IP_UP,
-+ NF_IP_DOWN,
-+ NF_IPV6_UP,
-+ NF_IPV6_DOWN,
-+ NF_AUTH_UP,
-+ NF_LINK_DOWN,
-+ NF_FORK,
-+ NF_MAX_NOTIFY
-+} ppp_notify_t;
-+
-+typedef void (ppp_notify_fn) (void *ctx, int arg);
-+
-+static inline void
-+ppp_add_notify (ppp_notify_t type, ppp_notify_fn *func, void *ctx)
-+{
-+ struct notifier **list[NF_MAX_NOTIFY] = {
-+ [NF_PID_CHANGE ] = &pidchange,
-+ [NF_PHASE_CHANGE] = &phasechange,
-+ [NF_EXIT ] = &exitnotify,
-+ [NF_SIGNALED ] = &sigreceived,
-+ [NF_IP_UP ] = &ip_up_notifier,
-+ [NF_IP_DOWN ] = &ip_down_notifier,
-+ [NF_IPV6_UP ] = &ipv6_up_notifier,
-+ [NF_IPV6_DOWN ] = &ipv6_down_notifier,
-+ [NF_AUTH_UP ] = &auth_up_notifier,
-+ [NF_LINK_DOWN ] = &link_down_notifier,
-+ [NF_FORK ] = &fork_notifier,
-+ };
-+
-+ struct notifier **notify = list[type];
-+ if (notify) {
-+ add_notifier(notify, func, ctx);
-+ }
-+}
-+
-+#endif /* #if WITH_PPP_VERSION < PPP_VERSION(2,5,0) */
-+#endif /* #if__LIBPPP_COMPAT_H__ */
--
2.48.1
宋文武 wrote 7 days ago
(name . Tomas Volf)(address . ~@wolfsden.cz)(address . 76482-done@debbugs.gnu.org)
8734frd8al.fsf@envs.net
Tomas Volf <~@wolfsden.cz> writes:

Toggle quote (5 lines)
> * gnu/packages/connman.scm (connman): Update to 1.43.
> * gnu/packages/patches/connman-add-missing-libppp-compat.h.patch: Delete
> obsolete patch.
> * gnu/local.mk (dist_patch_DATA): De-register it.

Pushed as 92f0049f04, thanks.
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76482@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76482
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help