[PATCH] gnu: Add aacircuit.

  • Open
  • quality assurance status badge
Details
One participant
  • Evgeny Pisemsky
Owner
unassigned
Submitted by
Evgeny Pisemsky
Severity
normal

Debbugs page

Evgeny Pisemsky wrote 3 weeks ago
(address . guix-patches@gnu.org)
87d7eb973101cd15613f034961cfc64eb11069e6.1740129127.git.mail@pisemsky.site
* gnu/packages/engineering.scm (aacircuit): New variable.

Change-Id: I0f44b1037866c729fe1d29a52d9447f6cbea6704
---
gnu/packages/engineering.scm | 50 ++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 234f4a2b03..40309f45f4 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -176,6 +176,56 @@ (define-module (gnu packages engineering)
#:use-module (gnu packages xorg)
#:use-module ((srfi srfi-1) #:hide (zip)))
+(define-public aacircuit
+ (let ((commit "18635c846754b6219da1a2ceb8977714f70004d0")
+ (revision "0"))
+ (package
+ (name "aacircuit")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Blokkendoos/AACircuit")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "07agb7fbpbq74zm27j9b00imr46q6kpwhxzmmffw2s9scv80c1km"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Exclude tests intended for visual review.
+ (setenv "NOSE_EXCLUDE"
+ (string-join '("test_export_pdf"
+ "test_import_aacircuit_export_pdf")
+ ","))
+ (setenv "HOME" "/tmp")
+ (invoke "xvfb-run" "./testrunner.sh")))))))
+ (native-inputs (list python-flake8
+ python-nose
+ python-setuptools
+ python-wheel
+ xvfb-run))
+ (propagated-inputs (list gtk+
+ python-bresenham
+ python-platformdirs
+ python-pycairo
+ python-pyclip
+ python-pygobject
+ python-pypubsub))
+ (home-page "https://github.com/Blokkendoos/AACircuit")
+ (synopsis "Draw electronic circuits with ASCII characters")
+ (description
+ "This is a pythonized, kind of reverse engineered version of original AACircuit
+written by Andreas Weber in Borland Delphi. The idea and GUI layout are also
+taken from the original.")
+ (license license:gpl3+))))
+
(define-public cutecom
(package
(name "cutecom")

base-commit: 38b4358f4d84cafa54deff77dee6fafac3e03864
--
2.48.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76463@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76463
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help