[PATCH] tests: Fix system tests source path

  • Done
  • quality assurance status badge
Details
One participant
  • Morgan Smith
Owner
unassigned
Submitted by
Morgan Smith
Severity
normal

Debbugs page

Morgan Smith wrote 3 weeks ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
CH3PR84MB3424580EDBB6F15D82F4FF36C5C72@CH3PR84MB3424.NAMPRD84.PROD.OUTLOOK.COM
Follow up to commit 12d00767f036029f1f5738de644d4972db374f4f

That commit moved the manifests into a subdirectory but failed to update the
relative path. That caused 'make check-system' to fail.

* etc/system-tests.scm (system-test-manifest): Set the source path to be the
root of the repository as it had been previously.

Change-Id: I68fb460861c4af080f5b14d1343d67b7e96109b0
---
etc/manifests/system-tests.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/etc/manifests/system-tests.scm b/etc/manifests/system-tests.scm
index 221a63bb7f..4e16c53dcf 100644
--- a/etc/manifests/system-tests.scm
+++ b/etc/manifests/system-tests.scm
@@ -74,7 +74,7 @@ (define (system-test-manifest)
"Return a manifest containing all the system tests, or all those selected by
the 'TESTS' environment variable."
(define source
- (string-append (current-source-directory) "/.."))
+ (string-append (current-source-directory) "/../.."))
(define commit
;; Fetch the current commit ID so we can potentially build the same

base-commit: 959a88e6f426b274694d4bce83375707434656d2
--
2.48.1
Morgan Smith wrote 2 weeks ago
control message for bug #76450
(address . control@debbugs.gnu.org)
CH3PR84MB34248E1C91D462B3E84F0346C5C62@CH3PR84MB3424.NAMPRD84.PROD.OUTLOOK.COM
close 76450
quit

Pushed as commit 8451e489bddf348abc042601308cd12d3416f841 by Maxim
Cournoyer <maxim.cournoyer@gmail.com>
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76450@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76450
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help