[javascript-team 1/2] gnu: libuv-for-node-lts: Update to 1.49.2.

  • Open
  • quality assurance status badge
Details
One participant
  • Jelle Licht
Owner
unassigned
Submitted by
Jelle Licht
Severity
normal

Debbugs page

Jelle Licht wrote 1 months ago
(address . guix-patches@gnu.org)
3e80219beb566f0db90559013a09931fa25ad898.1739875902.git.jlicht@fsfe.org
* gnu/packages/libevent.scm (libuv-for-node-lts): Update to 1.49.2.

Change-Id: I584156f643a51d5346f79cc9c0b4b1faad7c52fb
---
gnu/packages/libevent.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 40de182ff8..be9086d7ce 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -164,14 +164,14 @@ (define-public libuv-for-node-lts
(package
(inherit libuv)
(name "libuv")
- (version "1.49.1")
+ (version "1.49.2")
(source (origin
(method url-fetch)
(uri (string-append "https://dist.libuv.org/dist/v" version
"/libuv-v" version ".tar.gz"))
(sha256
(base32
- "0rk73b373zb495jd0qsl2gpnc8fc60jbhn3aayqnglfgyhagg14d"))))
+ "1a75p8wp4l43y2ffj1szs1ssm6nzjad7k51bqi2r04ngs9mp044c"))))
(properties '((hidden? . #t)))))
(define-public libuv-for-r-httpuv

base-commit: 400f89503b4e08205ded25d92f40b0f3ad837613
--
2.48.1
Jelle Licht wrote 1 months ago
[javascript-team 2/2] gnu: node-lts: Update to 22.14.0 [security fixes].
(address . 76391@debbugs.gnu.org)
aac25a98fe8d58c304a996a5b73ce3830753e037.1739875902.git.jlicht@fsfe.org
* gnu/packages/node.scm (node-lts): Update to 22.14.0.
[#:phases]<patch-problematic-tests>: New phase. Patch tests that fail when
trying to connect to the wrong address when using IPv6.

Change-Id: Icd93e2954d84824ff8b74ff58a24666c3de27e76
---
gnu/packages/node.scm | 12 ++++++++++--
1 file changed, 10 insertions(+), 2 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 6d6768e590..3e64d6ceb3 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -756,14 +756,14 @@ (define-public llhttp-bootstrap
(define-public node-lts
(package
(inherit node-bootstrap)
- (version "22.12.0")
+ (version "22.14.0")
(source (origin
(method url-fetch)
(uri (string-append "https://nodejs.org/dist/v" version
"/node-v" version ".tar.gz"))
(sha256
(base32
- "1qrcn9hm85bmh81ircaa0vmxrqmiip1iwczvpsyn9sdn0b0ffmri"))
+ "12msprh604s6qdsgwymxw4kl8ivaldbaydf4v37lbp02aznk2kkc"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -902,6 +902,14 @@ (define-public node-lts
"test/parallel/test-process-initgroups.js"
"test/parallel/test-process-setgroups.js"
"test/parallel/test-process-uid-gid.js"))))
+ (add-after 'delete-problematic-tests 'patch-problematic-tests
+ (lambda _
+ ;; XXX: These tests seem to not work by default
+ (substitute*
+ '("test/parallel/test-http2-premature-close.js"
+ "test/parallel/test-http2-invalid-last-stream-id.js")
+ (("client\\.connect\\(address\\)")
+ "client.connect(address.port)"))))
(add-after 'delete-problematic-tests 'replace-llhttp-sources
(lambda* (#:key inputs #:allow-other-keys)
;; Replace pre-generated llhttp sources
--
2.48.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76391@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76391
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help