[PATCH] gnu: Add twitch-hls-client

  • Open
  • quality assurance status badge
Details
One participant
  • Vitor Hugo
Owner
unassigned
Submitted by
Vitor Hugo
Severity
normal

Debbugs page

Vitor Hugo wrote 3 weeks ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
9s-pMpWdqwXSUTEGDwTVDNITfO3T2_iZnEX25cYFxSIJfTI66KYyLQvmJuYrMPF-ePRNY01RgQgl3Axyre70kGcBZX7knsJmpQOfz5D8n1Y=@proton.me
* gnu/packages/rust-apps.scm (twitch-hls-client): New variable.

Change-Id: I5cf9b3e199068f5a37ae598cf14ba26be4cf8c05
---
gnu/packages/rust-apps.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)
Toggle diff (42 lines)
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 054a09c47d..65f2d097b0 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -4298,6 +4298,35 @@ (define-public tealdeer
Full featured offline client with caching support.")
(license (list license:expat license:asl2.0))))
+(define-public twitch-hls-client
+ (package
+ (name "twitch-hls-client")
+ (version "1.3.13")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/2bc4/twitch-hls-client")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0nh2lqb41z7h0ak946nqbm6n3igj2rlpl6dkljlnhi3hf6lkm3hz"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:install-source? #f
+ #:cargo-inputs
+ (("rust-anyhow" ,rust-anyhow-1)
+ ("rust-chunked-transfer" ,rust-chunked-transfer-1)
+ ("rust-flate2" ,rust-flate2-1)
+ ("rust-getrandom" ,rust-getrandom-0.2)
+ ("rust-pico-args" ,rust-pico-args-0.5)
+ ("rust-rustls" ,rust-rustls-0.23)
+ ("rust-rustls-native-certs" ,rust-rustls-native-certs-0.7)
+ ("rust-log" ,rust-log-0.4))))
+ (home-page "https://github.com/2bc4/twitch-hls-client")
+ (synopsis "Command line client for Twitch.tv")
+ (description "twitch-hls-client is a minimal command line client for watching/recording Twitch streams")
+ (license license:gpl3)))
+
(define-public git-absorb
(package
(name "git-absorb")
--
2.46.0
Vitor Hugo wrote 3 weeks ago
Fix linting error
(name . 76378@debbugs.gnu.org)(address . 76378@debbugs.gnu.org)
9uS3mK9uD6PSnhugVLZPsQG-5CETZpNBhmg0Nj8agW-auOKYnsBkJEMRTD9ZnU4zCappJN_5M9rTaVqFSnCJVod6fLpLGyJt2yf4cE0miMA=@proton.me
I made one of the lines too long and didn't check
the linter.

Change-Id: I6bcd6265fddb6ee22c833e418d7c5ec9e70e9a8f
---
gnu/packages/rust-apps.scm | 38 ++++++++++++++++++++------------------
1 file changed, 20 insertions(+), 18 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 65f2d097b0..d3c6b1e822 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -4302,29 +4302,31 @@ (define-public twitch-hls-client
(package
(name "twitch-hls-client")
(version "1.3.13")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/2bc4/twitch-hls-client")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0nh2lqb41z7h0ak946nqbm6n3igj2rlpl6dkljlnhi3hf6lkm3hz"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/2bc4/twitch-hls-client")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0nh2lqb41z7h0ak946nqbm6n3igj2rlpl6dkljlnhi3hf6lkm3hz"))))
(build-system cargo-build-system)
(arguments
`(#:install-source? #f
- #:cargo-inputs
- (("rust-anyhow" ,rust-anyhow-1)
- ("rust-chunked-transfer" ,rust-chunked-transfer-1)
- ("rust-flate2" ,rust-flate2-1)
- ("rust-getrandom" ,rust-getrandom-0.2)
- ("rust-pico-args" ,rust-pico-args-0.5)
- ("rust-rustls" ,rust-rustls-0.23)
- ("rust-rustls-native-certs" ,rust-rustls-native-certs-0.7)
- ("rust-log" ,rust-log-0.4))))
+ #:cargo-inputs (("rust-anyhow" ,rust-anyhow-1)
+ ("rust-chunked-transfer" ,rust-chunked-transfer-1)
+ ("rust-flate2" ,rust-flate2-1)
+ ("rust-getrandom" ,rust-getrandom-0.2)
+ ("rust-pico-args" ,rust-pico-args-0.5)
+ ("rust-rustls" ,rust-rustls-0.23)
+ ("rust-rustls-native-certs" ,rust-rustls-native-certs-0.7)
+ ("rust-log" ,rust-log-0.4))))
(home-page "https://github.com/2bc4/twitch-hls-client")
(synopsis "Command line client for Twitch.tv")
- (description "twitch-hls-client is a minimal command line client for watching/recording Twitch streams")
+ (description
+ "twitch-hls-client is a minimal command line client for
+watching/recording Twitch streams")
(license license:gpl3)))

(define-public git-absorb
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76378@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76378
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help