Skylar Hill wrote 3 weeks ago
(address . guix-patches@gnu.org)(name . Skylar Hill)(address . stellarskylark@posteo.net)
* gnu/packages/guile-xyz.scm (guile-oauth): New variable.
Change-Id: Ie5e8e15a35e2e71171ef6b8ea2e4b86e339152d3
---
gnu/packages/guile-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
Toggle diff (39 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 295f69d2de..ad43a129a8 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -319,6 +319,29 @@ (define-public guilescript
currently does not do much, but it might in the future.")
(license license:gpl3+)))
+(define-public guile-oauth
+ (package
+ (name "guile-oauth")
+ (version "1.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aconchillo/guile-oauth")
+ (commit version)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32 "002hgs4xfrrz0rqa6n1078cn7vz5f70azw1kpljvb4dmv228gfxq"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake pkg-config))
+ (inputs (list guile-3.0 gnutls guile-gcrypt guile-gnutls guile-json-4))
+ (home-page "https://github.com/aconchillo/guile-oauth")
+ (synopsis "OAuth module for Guile")
+ (description
+ "This package provides Guile modules to interface with the OAuth and
+OAuth2 protocols.")
+ (license license:gpl3+)))
+
(define-public guile-openai
(let ((commit "751cd5db5f8bb7c00e60042a7ec86100930b0f02")
(revision "1"))
base-commit: 6dde0ee30e5e030c2535514e9e39aa50518a5d20
prerequisite-patch-id: cc459efaf23197e58e97a6f0ad62058f71178746
--
2.48.1