[PATCH] gnu: llvm-spirv-translator: Fix cross compilation

  • Open
  • quality assurance status badge
Details
One participant
  • Yarl Baudig
Owner
unassigned
Submitted by
Yarl Baudig
Severity
normal

Debbugs page

Yarl Baudig wrote 3 weeks ago
[PATCH] gnu: llvm-spirv-translator: Fix cross compilation
(address . guix-patches@gnu.org)(name . Yarl Baudig)(address . yarl-baudig@mailoo.org)
a982b23d1921f044ccf0a0ce669853f78ceb6a56.1739714838.git.yarl-baudig@mailoo.org
* gnu/packages/vulkan.scm (llvm-spirv-translator): Fix
cross-compilation. [configure-flags]: replace ungexp with ungexp-native when
relevant. Fix headers path.

Change-Id: If0fe4c42e98a67cbda27519815f556bb44713a60
---
gnu/packages/vulkan.scm | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 241dff73ac..bfa32740e0 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -177,10 +177,9 @@ (define-public spirv-llvm-translator
(target-x86-64?))
#:configure-flags
#~(list (string-append "-DLLVM_EXTERNAL_SPIRV_HEADERS_SOURCE_DIR="
- #$(this-package-native-input "spirv-headers")
- "/include/spirv")
+ #+(this-package-native-input "spirv-headers"))
(string-append "-DLLVM_EXTERNAL_LIT="
- #$(this-package-native-input "python-lit")
+ #+(this-package-native-input "python-lit")
"/bin/lit")
(string-append "-DCMAKE_EXE_LINKER_FLAGS=-Wl,-rpath="
#$output "/lib")

base-commit: 1725d74c9f730f2628e2a02659b5ce925276d7ca
--
2.48.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76337@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76337
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help