[PATCH 0/1] trash-cli: Update to 0.24.5.26.

  • Open
  • quality assurance status badge
Details
One participant
  • simon
Owner
unassigned
Submitted by
simon
Severity
normal

Debbugs page

simon wrote 3 weeks ago
(address . guix-patches@gnu.org)(name . Simon Streit)(address . simon@netpanic.org)
cover.1739707953.git.simon@netpanic.org
From: Simon Streit <simon@netpanic.org>

Hello,


as promised to clear my local modifications, please find attached a
patch to update trash-cli to 0.24.5.26.

I added python-shtab as new native-input to enable the generation of
completion files. I tried to get this working in the build process.
The results where not as good as expected.

I am leaving this as an open task for someone else to pick up. Thus
the package is only upgraded to the newest current version for now.


Kind regards

Simon Streit (1):
gnu: trash-cli: Update to 0.24.5.26.

gnu/packages/shellutils.scm | 61 +++++++++++++++----------------------
1 file changed, 25 insertions(+), 36 deletions(-)

--
2.47.1
simon wrote 3 weeks ago
[PATCH 1/1] gnu: trash-cli: Update to 0.24.5.26.
(address . 76335@debbugs.gnu.org)(name . Simon Streit)(address . simon@netpanic.org)
ed526a2b3c8161e93c1fb21df877639be136ae44.1739707953.git.simon@netpanic.org
From: Simon Streit <simon@netpanic.org>

* gnu/packages/shellutils.scm (trash-cli): Update to 0.24.5.26.

* gnu/packages/shellutils.scm: Update to 0.24.5.26. Improve
style. [native-iinputs]: Add python-shtab. Sort.

Change-Id: I2f9ca7e2eb27657d8356c5cd3648c1e3a10cd0a8
---
gnu/packages/shellutils.scm | 61 +++++++++++++++----------------------
1 file changed, 25 insertions(+), 36 deletions(-)

Toggle diff (84 lines)
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index dc9a51e25f..7bd245142a 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -645,7 +645,7 @@ (define-public envstore
(define-public trash-cli
(package
(name "trash-cli")
- (version "0.22.10.20")
+ (version "0.24.5.26")
(source
(origin
(method git-fetch)
@@ -654,44 +654,33 @@ (define-public trash-cli
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32
- "0hkn0hmwrag56g447ddqapib0s399a6b4a9wlliif6zmirxlww9n"))))
+ (base32 "1mqs3y9vbph33jsaa5hc0fhk80pklmsn8ylp979k9qj63fgqrnwn"))))
(build-system python-build-system)
(arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (add-before 'build 'patch-path-constants
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((libc (search-input-file inputs "lib/libc.so.6"))
- (df #$(file-append coreutils "/bin/df")))
- (substitute* "trashcli/list_mount_points.py"
- (("\"/lib/libc.so.6\".*")
- (string-append "\"" libc "\"\n"))
- (("\"df\"")
- (string-append "\"" df "\""))))))
- (add-before 'build 'fix-setup.py
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((bin (string-append #$output "/bin")))
- (mkdir-p bin)
- (substitute* "setup.py"
- (("add_script\\('")
- (string-append "add_script('" bin "/" ))))))
- ;; Whenever setup.py is invoked, scripts in out/bin/ are
- ;; replaced. Thus we cannot invoke setup.py for testing.
- ;; Upstream also uses pytest.
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest")))))))
- (native-inputs
- (list python-pytest
- python-parameterized
- python-flexmock
- python-mock
- python-six))
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'build 'fix-setup.py
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append #$output "/bin")))
+ (mkdir-p bin)
+ (substitute* "setup.py"
+ (("add_script\\('")
+ (string-append "add_script('" bin "/"))))))
+ ;; Whenever setup.py is invoked, scripts in out/bin/ are
+ ;; replaced. Thus we cannot invoke setup.py for testing.
+ ;; Upstream also uses pytest.
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (native-inputs (list python-flexmock
+ python-mock
+ python-parameterized
+ python-pytest
+ python-shtab
+ python-six))
(inputs (list coreutils))
- (propagated-inputs
- (list python-psutil))
+ (propagated-inputs (list python-psutil))
(home-page "https://github.com/andreafrancia/trash-cli")
(synopsis "Trash can management tool")
(description
--
2.47.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76335@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76335
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help