[PATCH] gnu: Add guile-mqtt.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Evgeny Pisemsky
Owner
unassigned
Submitted by
Evgeny Pisemsky
Severity
normal

Debbugs page

Evgeny Pisemsky wrote 4 weeks ago
(address . guix-patches@gnu.org)
39bb6d17b8fbbf3679c446a3d2936a794495b86f.1739612794.git.mail@pisemsky.site
* gnu/packages/guile-xyz.scm (guile-mqtt): New variable.

Change-Id: I3e9d4ebdb2357023f77962b9d40e3b10242aeac3
---
gnu/packages/guile-xyz.scm | 29 ++++++++++++++++++++++++++++-
1 file changed, 28 insertions(+), 1 deletion(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 295f69d2de..6c2a6d8d9c 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -44,7 +44,7 @@
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
;;; Copyright © 2022, 2023 Zheng Junjie <873216071@qq.com>
-;;; Copyright © 2022 Evgeny Pisemsky <mail@pisemsky.site>
+;;; Copyright © 2022, 2025 Evgeny Pisemsky <mail@pisemsky.site>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2023 Andrew Tropin <andrew@trop.in>
;;; Copyright © 2024 Ilya Chernyshov <ichernyshovvv@gmail.com>
@@ -106,6 +106,7 @@ (define-module (gnu packages guile-xyz)
#:use-module (gnu packages man)
#:use-module (gnu packages maths)
#:use-module (gnu packages mes)
+ #:use-module (gnu packages messaging)
#:use-module (gnu packages mp3)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
@@ -1557,6 +1558,32 @@ (define-public guile-aws
the Guile compiler tower to generate the DSL from AWS JSON specifications.")
(license license:gpl3+))))
+(define-public guile-mqtt
+ (package
+ (name "guile-mqtt")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mdjurfeldt/" name
+ "/releases/download/v" version
+ "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "16a3r6yk41yskwv4qbkrsi0f5rvc7aw2s5di74i8y89j1x9yp9zs"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags #~(list "GUILE_AUTO_COMPILE=0")))
+ (native-inputs (list guile-3.0 pkg-config))
+ (inputs (list mosquitto))
+ (home-page "https://github.com/mdjurfeldt/guile-mqtt")
+ (synopsis "Guile bindings for the libmosquitto library")
+ (description
+ "This package provides Guile bindings for the libmosquitto MQTT client library.
+The bindings are written in GOOPS, and the user can extend the client class by
+inheritance.")
+ (license license:lgpl3+)))
+
(define-public guile-simple-zmq
(let ((commit "d25d1865e3378d93c44e2b4f5246a70b078a489d")
(revision "11"))

base-commit: 9b1fe3bd70a57cdbf99339eb06b3a9b57f060f97
--
2.48.1
Ludovic Courtès wrote 3 weeks ago
(name . Evgeny Pisemsky)(address . mail@pisemsky.site)(address . 76302-done@debbugs.gnu.org)
87bjuzji57.fsf@gnu.org
Evgeny Pisemsky <mail@pisemsky.site> skribis:

Toggle quote (4 lines)
> * gnu/packages/guile-xyz.scm (guile-mqtt): New variable.
>
> Change-Id: I3e9d4ebdb2357023f77962b9d40e3b10242aeac3

Applied, thanks!
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76302@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76302
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help