Lars Bilke wrote 4 weeks ago
(address . guix-patches@gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
Depends on https://issues.guix.gnu.org/76173.
* gnu/packages/image-processing.scm (vtkdiff): New variable.
Change-Id: I9d7e9ff2dbe9683177d3f5c835466d3d052289ed
---
gnu/packages/image-processing.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
Toggle diff (41 lines)
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 20e188bd70..4c1b1885cb 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -487,6 +487,32 @@ (define-public vtk-7
(("Host system: \\@CMAKE_HOST_SYSTEM\\@")
"Host system: @CMAKE_SYSTEM_NAME@"))))))))))
+(define-public vktdiff
+ (package
+ (name "vtkdiff")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ufz/vtkdiff")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15nwzfhgyjfvd083kw1s19xkxcds9h31hx9cr339x3bkllbj609j"))))
+ (build-system cmake-build-system)
+ (inputs (list tclap vtk))
+ (arguments
+ (list
+ #:tests? #f ;There are no tests.
+ #:configure-flags #~(list "-DGUIX_BUILD=ON")))
+ (home-page "https://github.com/ufz/vtkdiff")
+ (synopsis "Numerical difference of data arrays in vtk files")
+ (description
+ "The vtkdiff tool shall provide means of numerical comparison of
+different data arrays similar to those available in the numdiff software.")
+ (license license:bsd-3)))
+
(define-public opencv
(package
(name "opencv")
base-commit: 4b5f0408e66392ab745dc0f7830732217d88f17d
--
2.46.1