[PATCH] gnu: Add vtkdiff

  • Done
  • quality assurance status badge
Details
2 participants
  • Lars Bilke
  • Ludovic Courtès
Owner
unassigned
Submitted by
Lars Bilke
Severity
normal

Debbugs page

Lars Bilke wrote 4 weeks ago
(address . guix-patches@gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
8fc5848aa4cbe3c7abd1ab34b262b6ae7dfad105.1739529021.git.lars.bilke@ufz.de

* gnu/packages/image-processing.scm (vtkdiff): New variable.

Change-Id: I9d7e9ff2dbe9683177d3f5c835466d3d052289ed
---
gnu/packages/image-processing.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 20e188bd70..4c1b1885cb 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -487,6 +487,32 @@ (define-public vtk-7
(("Host system: \\@CMAKE_HOST_SYSTEM\\@")
"Host system: @CMAKE_SYSTEM_NAME@"))))))))))
+(define-public vktdiff
+ (package
+ (name "vtkdiff")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ufz/vtkdiff")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15nwzfhgyjfvd083kw1s19xkxcds9h31hx9cr339x3bkllbj609j"))))
+ (build-system cmake-build-system)
+ (inputs (list tclap vtk))
+ (arguments
+ (list
+ #:tests? #f ;There are no tests.
+ #:configure-flags #~(list "-DGUIX_BUILD=ON")))
+ (home-page "https://github.com/ufz/vtkdiff")
+ (synopsis "Numerical difference of data arrays in vtk files")
+ (description
+ "The vtkdiff tool shall provide means of numerical comparison of
+different data arrays similar to those available in the numdiff software.")
+ (license license:bsd-3)))
+
(define-public opencv
(package
(name "opencv")

base-commit: 4b5f0408e66392ab745dc0f7830732217d88f17d
--
2.46.1
Ludovic Courtès wrote 2 days ago
(name . Lars Bilke)(address . lars.bilke@ufz.de)(address . 76284-done@debbugs.gnu.org)
87senlq9v3.fsf@gnu.org
Lars Bilke <lars.bilke@ufz.de> skribis:

Toggle quote (6 lines)
>
> * gnu/packages/image-processing.scm (vtkdiff): New variable.
>
> Change-Id: I9d7e9ff2dbe9683177d3f5c835466d3d052289ed

Applied, thanks!
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76284@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76284
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help