Nicolas Graves wrote 4 weeks ago
(address . guix-patches@gnu.org)(address . andrew@trop.in)
* gnu/packages/emacs-xyz.scm (emacs-age): New variable.
---
gnu/packages/emacs-xyz.scm | 29 ++++++++++++++++++++++++++++-
1 file changed, 28 insertions(+), 1 deletion(-)
Toggle diff (55 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 89da0dd489..13139243a1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -116,7 +116,7 @@
;;; Copyright © 2022 Haider Mirza <haider@haider.gq>
;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
-;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2022, 2024, 2025 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2022 Thiago Jung Bauermann <bauermann@kolabnow.com>
;;; Copyright © 2022 Joeke de Graaf <joeke@posteo.net>
;;; Copyright © 2023 Simon Streit <simon@netpanic.org>
@@ -436,6 +436,33 @@ (define-public emacs-activities
compatible.")
(license license:gpl3+)))
+(define-public emacs-age
+ (let ((commit "890c467ebc27538507c54a03afd2f7260630d7f5")
+ (revision "0"))
+ (package
+ (name "emacs-age")
+ ;; 0.1.4 in the code but 0.1.5 on github
+ (version (git-version "0.1.5" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/anticomputer/age.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0777nvrvswv81g0rkclm7r2ai1xfjf380lhg8lidd060dkp71ic1"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/anticomputer/age.el")
+ (synopsis "The Age Encryption Library")
+ (description
+ "This package provides transparent Age file encryption and decryption in
+Emacs. It is based on the Emacs @code{EasyPG} code and offers similar Emacs
+file handling for Age encrypted files: maintain .org.age encrypted Org files,
+provide Age encrypted authentication information out of .authinfo.age,
+open/edit/save Age encrypted files via @code{tramp}...")
+ (license license:gpl3+))))
+
(define-public emacs-bookmark-plus
(package
(name "emacs-bookmark-plus")
--
2.48.1
--
Best regards,
Nicolas Graves