[PATCH] gnu: Add emacs-age.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal

Debbugs page

Nicolas Graves wrote 4 weeks ago
(address . guix-patches@gnu.org)(address . andrew@trop.in)
87a5arjnhl.fsf@ngraves.fr
* gnu/packages/emacs-xyz.scm (emacs-age): New variable.
---
gnu/packages/emacs-xyz.scm | 29 ++++++++++++++++++++++++++++-
1 file changed, 28 insertions(+), 1 deletion(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 89da0dd489..13139243a1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -116,7 +116,7 @@
;;; Copyright © 2022 Haider Mirza <haider@haider.gq>
;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
-;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2022, 2024, 2025 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2022 Thiago Jung Bauermann <bauermann@kolabnow.com>
;;; Copyright © 2022 Joeke de Graaf <joeke@posteo.net>
;;; Copyright © 2023 Simon Streit <simon@netpanic.org>
@@ -436,6 +436,33 @@ (define-public emacs-activities
compatible.")
(license license:gpl3+)))
+(define-public emacs-age
+ (let ((commit "890c467ebc27538507c54a03afd2f7260630d7f5")
+ (revision "0"))
+ (package
+ (name "emacs-age")
+ ;; 0.1.4 in the code but 0.1.5 on github
+ (version (git-version "0.1.5" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/anticomputer/age.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0777nvrvswv81g0rkclm7r2ai1xfjf380lhg8lidd060dkp71ic1"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/anticomputer/age.el")
+ (synopsis "The Age Encryption Library")
+ (description
+ "This package provides transparent Age file encryption and decryption in
+Emacs. It is based on the Emacs @code{EasyPG} code and offers similar Emacs
+file handling for Age encrypted files: maintain .org.age encrypted Org files,
+provide Age encrypted authentication information out of .authinfo.age,
+open/edit/save Age encrypted files via @code{tramp}...")
+ (license license:gpl3+))))
+
(define-public emacs-bookmark-plus
(package
(name "emacs-bookmark-plus")
--
2.48.1



--
Best regards,
Nicolas Graves
Nicolas Graves wrote 4 weeks ago
[PATCH v2] gnu: Add emacs-age.
(address . 76225@debbugs.gnu.org)
877c5vjne0.fsf@ngraves.fr
* gnu/packages/emacs-xyz.scm (emacs-age): New variable.
---
gnu/packages/emacs-xyz.scm | 29 ++++++++++++++++++++++++++++-
1 file changed, 28 insertions(+), 1 deletion(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 89da0dd489..d57c17d45f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -116,7 +116,7 @@
;;; Copyright © 2022 Haider Mirza <haider@haider.gq>
;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
-;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2022, 2024, 2025 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2022 Thiago Jung Bauermann <bauermann@kolabnow.com>
;;; Copyright © 2022 Joeke de Graaf <joeke@posteo.net>
;;; Copyright © 2023 Simon Streit <simon@netpanic.org>
@@ -436,6 +436,33 @@ (define-public emacs-activities
compatible.")
(license license:gpl3+)))
+(define-public emacs-age
+ (let ((commit "890c467ebc27538507c54a03afd2f7260630d7f5")
+ (revision "0"))
+ (package
+ (name "emacs-age")
+ ;; 0.1.4 in the code but 0.1.5 on github
+ (version (git-version "0.1.5" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/anticomputer/age.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0777nvrvswv81g0rkclm7r2ai1xfjf380lhg8lidd060dkp71ic1"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/anticomputer/age.el")
+ (synopsis "Age Encryption support for Emacs")
+ (description
+ "This package provides transparent Age file encryption and decryption
+in Emacs. It is based on the Emacs @code{EasyPG} code and offers similar
+Emacs file handling for Age encrypted files: maintain @code{.org.age}
+encrypted Org files, provide Age encrypted authentication information out of
+@code{.authinfo.age}, open/edit/save Age encrypted files via @code{tramp}...")
+ (license license:gpl3+))))
+
(define-public emacs-bookmark-plus
(package
(name "emacs-bookmark-plus")
--
2.48.1



--
Best regards,
Nicolas Graves
Nicolas Goaziou wrote 4 weeks ago
(name . Nicolas Graves via Guix-patches via)(address . guix-patches@gnu.org)
87a5ardk43.fsf@nicolasgoaziou.fr
Hello,

Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-age): New variable.

Thanks.

Toggle quote (8 lines)
> +(define-public emacs-age
> + (let ((commit "890c467ebc27538507c54a03afd2f7260630d7f5")
> + (revision "0"))
> + (package
> + (name "emacs-age")
> + ;; 0.1.4 in the code but 0.1.5 on github
> + (version (git-version "0.1.5" revision commit))

Please use the "v0.1.5" tag instead of a raw commit.

Toggle quote (4 lines)
> + (description
> + "This package provides transparent Age file encryption and decryption
> +in Emacs. It is based on the Emacs @code{EasyPG} code and offers similar

Nitpick: I think EasyPG is better than @code{EasyPG}. See below.

Toggle quote (4 lines)
> +Emacs file handling for Age encrypted files: maintain @code{.org.age}
> +encrypted Org files, provide Age encrypted authentication information out of
> +@code{.authinfo.age},

@code -> @file (x2)

Toggle quote (2 lines)
> + open/edit/save Age encrypted files via @code{tramp}...")

Nitpick: I prefer Tramp over @code{tramp} as you’re referring to
a project, not to some piece of code. It is also coherent with Age and
Emacs in the same description.

Otherwise, LGTM.

Regards,
--
Nicolas Goaziou
Nicolas Graves wrote 4 weeks ago
[PATCH v3 1/3] gnu: Add emacs-age.
(address . 76225@debbugs.gnu.org)(address . mail@nicolasgoaziou.fr)
87o6yrw1cm.fsf@ngraves.fr
* gnu/packages/emacs-xyz.scm (emacs-age): New variable.
---
gnu/packages/emacs-xyz.scm | 26 +++++++++++++++++++++++++-
1 file changed, 25 insertions(+), 1 deletion(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 59c1927135..832a6c09b1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -116,7 +116,7 @@
;;; Copyright © 2022 Haider Mirza <haider@haider.gq>
;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
-;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2022, 2024, 2025 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2022 Thiago Jung Bauermann <bauermann@kolabnow.com>
;;; Copyright © 2022 Joeke de Graaf <joeke@posteo.net>
;;; Copyright © 2023 Simon Streit <simon@netpanic.org>
@@ -437,6 +437,30 @@ (define-public emacs-activities
compatible.")
(license license:gpl3+)))
+(define-public emacs-age
+ (package
+ (name "emacs-age")
+ (version "0.1.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/anticomputer/age.el")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1703ijdgahanzkrs0w3j1l563969qnsw872vkdsmfj7qw1940ndj"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/anticomputer/age.el")
+ (synopsis "Age Encryption support for Emacs")
+ (description
+ "This package provides transparent Age file encryption and decryption
+in Emacs. It is based on the Emacs EasyPG@ code and offers similar Emacs file
+handling for Age encrypted files: maintain @code{.org.age} encrypted Org
+files, provide Age encrypted authentication information out of
+@code{.authinfo.age}, open/edit/save Age encrypted files via Tramp...")
+ (license license:gpl3+)))
+
(define-public emacs-bookmark-plus
(package
(name "emacs-bookmark-plus")
--
2.48.1



--
Best regards,
Nicolas Graves
Nicolas Graves wrote 2 weeks ago
[PATCH v3 3/3] gnu: Add emacs-passage.
(address . 76225@debbugs.gnu.org)(address . mail@nicolasgoaziou.fr)
87ldtvw1br.fsf@ngraves.fr
* gnu/packages/emacs-xyz.scm (emacs-passage): New variable.
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 832a6c09b1..aee8e67d74 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -24773,6 +24773,31 @@ (define-public emacs-pass
and can be consulted and modified.")
(license license:gpl3+)))
+(define-public emacs-passage
+ (let ((commit "5f1ad815464b1e4ce7880b835f9e805a8b9b15a4")
+ (revision "0"))
+ (package
+ (name "emacs-passage")
+ (version (git-version "2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/anticomputer/passage.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "12sxaig36n3qrmnyq2znar74hgbgfh3sgghki4n7aq2bzxwfbn8h"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-age emacs-f emacs-s emacs-with-editor))
+ (home-page "https://github.com/anticomputer/passage.el")
+ (synopsis "Pass-Age Encryption support for Emacs")
+ (description
+ "This package provides transparent Age file encryption and decryption
+in Emacs for @code{pass-age}, a port of @code{pass}, the standard unix
+password manager.")
+ (license license:gpl3+))))
+
(define-public emacs-psc-ide
;; There is no proper release. The base version is extracted from the
;; "Version" keyword in the main file.
--
2.48.1



--
Best regards,
Nicolas Graves
Nicolas Graves wrote 2 weeks ago
[PATCH v3 2/3] gnu: pass-age: Update to 1.7.4a2.
(address . 76225@debbugs.gnu.org)(address . mail@nicolasgoaziou.fr)
87msebw1c7.fsf@ngraves.fr
* gnu/packages/password-utils.scm (pass-age): Update to 1.7.4a2.
---
gnu/packages/password-utils.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 81758cea43..78154b967c 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -827,7 +827,7 @@ (define-public pass-age
(package
(inherit password-store)
(name "pass-age")
- (version "1.7.4a1")
+ (version "1.7.4a2")
(source
(origin
(method git-fetch)
@@ -836,7 +836,7 @@ (define-public pass-age
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0g8x2zivid18qf1czq1yqychmbdzxzs83rg8a5b392m2rzxlrx08"))))
+ (base32 "1ap2i08zjvacd2rllrsx9bw3zz5i99bk0i5yxrssvn6w60bwjqdl"))))
(build-system copy-build-system)
(arguments
'(#:modules
--
2.48.1



--
Best regards,
Nicolas Graves
Nicolas Graves wrote 4 weeks ago
[PATCH v4 1/3] gnu: Add emacs-age.
(address . 76225@debbugs.gnu.org)(address . mail@nicolasgoaziou.fr)
87frk3w18m.fsf@ngraves.fr
* gnu/packages/emacs-xyz.scm (emacs-age): New variable.
---

Sorry I made a small typo on the previous one, seen when sent.

gnu/packages/emacs-xyz.scm | 26 +++++++++++++++++++++++++-
1 file changed, 25 insertions(+), 1 deletion(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 59c1927135..700ac9f0cb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -116,7 +116,7 @@
;;; Copyright © 2022 Haider Mirza <haider@haider.gq>
;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
-;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2022, 2024, 2025 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2022 Thiago Jung Bauermann <bauermann@kolabnow.com>
;;; Copyright © 2022 Joeke de Graaf <joeke@posteo.net>
;;; Copyright © 2023 Simon Streit <simon@netpanic.org>
@@ -437,6 +437,30 @@ (define-public emacs-activities
compatible.")
(license license:gpl3+)))
+(define-public emacs-age
+ (package
+ (name "emacs-age")
+ (version "0.1.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/anticomputer/age.el")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1703ijdgahanzkrs0w3j1l563969qnsw872vkdsmfj7qw1940ndj"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/anticomputer/age.el")
+ (synopsis "Age Encryption support for Emacs")
+ (description
+ "This package provides transparent Age file encryption and decryption
+in Emacs. It is based on the Emacs EasyPG code and offers similar Emacs file
+handling for Age encrypted files: maintain @code{.org.age} encrypted Org
+files, provide Age encrypted authentication information out of
+@code{.authinfo.age}, open/edit/save Age encrypted files via Tramp...")
+ (license license:gpl3+)))
+
(define-public emacs-bookmark-plus
(package
(name "emacs-bookmark-plus")
--
2.48.1



--
Best regards,
Nicolas Graves
Nicolas Goaziou wrote 2 weeks ago
Re: [PATCH] gnu: Add emacs-age.
(address . 76225-done@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
87msebouwt.fsf@nicolasgoaziou.fr
Hello,

I applied the patch set. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76225@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76225
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help