[PATCH] gnu: Add uhdm.

  • Open
  • quality assurance status badge
Details
2 participants
  • Cayetano Santos
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Cayetano Santos
Severity
normal

Debbugs page

Cayetano Santos wrote on 11 Feb 17:25 +0100
(address . guix-patches@gnu.org)(name . Cayetano Santos)(address . csantosb@inventati.org)
a29368bff328fa162eedc1eba2304bfc3869cab1.1739291149.git.csantosb@inventati.org
* gnu/packages/electronics.scm (uhdm): New variable.

Change-Id: I581fa4de57c377f6b2c99aa439fdfb98e2e472a9
---
gnu/packages/electronics.scm | 43 ++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (71 lines)
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index df0238c348..868bfb0571 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -38,6 +38,7 @@ (define-module (gnu packages electronics)
#:use-module (gnu packages boost)
#:use-module (gnu packages c)
#:use-module (gnu packages check)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages documentation)
#:use-module (gnu packages embedded)
@@ -52,10 +53,13 @@ (define-module (gnu packages electronics)
#:use-module (gnu packages m4)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages sdl)
+ #:use-module (gnu packages serialization)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages stb)
+ #:use-module (gnu packages tls)
#:use-module (gnu packages toolkits))
(define-public libserialport
@@ -522,3 +526,42 @@ (define-public minipro
Additionally your user must be member of the @code{plugdev} group.")
(home-page "https://gitlab.com/DavidGriffith/minipro")
(license license:gpl3+))))
+
+(define-public uhdm
+ (package
+ (name "uhdm")
+ (version "1.84")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chipsalliance/UHDM/")
+ (commit (string-append "v" version))
+ (recursive? #f)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1364kv8fg4nh76qs7j1h7sqfhsfav6bda9hcxkqhcgzsiysnxqwy"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "make" "test")))))
+ #:make-flags #~(list (string-append "PREFIX="
+ #$output))))
+ (inputs (list python-orderedmultidict
+ python
+ cmake-minimal
+ openssl
+ zlib
+ googletest
+ capnproto))
+ (home-page "https://github.com/chipsalliance/UHDM/")
+ (synopsis "Universal Hardware Data Model")
+ (description
+ "UHDM is a complete modeling of the IEEE SystemVerilog Object Model with
+VPI Interface, Elaborator, Serialization, Visitor and Listener.")
+ (license license:asl2.0)))

base-commit: e72b988cfb36f48ec8f43700fe0ad132acb98ca1
--
2.48.1
Cayetano Santos wrote on 12 Feb 11:01 +0100
[PATCH v1] gnu: Add uhdm.
(address . 76207@debbugs.gnu.org)(name . Cayetano Santos)(address . csantosb@inventati.org)
71df39a4d43dc1b6fbf9e7a1966139040b122796.1739354464.git.csantosb@inventati.org
* gnu/packages/electronics.scm (uhdm): New variable.

Change-Id: I85438daefa41fae999500f19b6d0c2e4035d57a9
Signed-off-by: Cayetano Santos <csantosb@inventati.org>
---
gnu/packages/electronics.scm | 44 ++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index df0238c348..9d6fbea936 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -38,6 +38,7 @@ (define-module (gnu packages electronics)
#:use-module (gnu packages boost)
#:use-module (gnu packages c)
#:use-module (gnu packages check)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages documentation)
#:use-module (gnu packages embedded)
@@ -52,6 +53,10 @@ (define-module (gnu packages electronics)
#:use-module (gnu packages m4)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages serialization)
+ #:use-module (gnu packages swig)
+ #:use-module (gnu packages tls)
#:use-module (gnu packages qt)
#:use-module (gnu packages sdl)
#:use-module (gnu packages sqlite)
@@ -522,3 +527,42 @@ (define-public minipro
Additionally your user must be member of the @code{plugdev} group.")
(home-page "https://gitlab.com/DavidGriffith/minipro")
(license license:gpl3+))))
+
+(define-public uhdm
+ (package
+ (name "uhdm")
+ (version "1.84")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chipsalliance/UHDM/")
+ (commit (string-append "v" version))
+ (recursive? #f)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06i06wfyymhvmpnw79lgb84l9w9cyydvnr7n3bgmgf8a77jbxk2y"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))
+ #:test-target "test"
+ #:make-flags #~(list
+ "ADDITIONAL_CMAKE_OPTIONS=-DUHDM_USE_HOST_CAPNP=On -DUHDM_USE_HOST_GTEST=On"
+ (string-append "PREFIX="
+ #$output))))
+ (native-inputs (list pkg-config swig))
+ (inputs (list capnproto
+ cmake-minimal
+ googletest
+ openssl
+ python
+ python-orderedmultidict
+ zlib))
+ (home-page "https://github.com/chipsalliance/UHDM/")
+ (synopsis "Universal Hardware Data Model")
+ (description
+ "UHDM is a complete modeling of the IEEE SystemVerilog Object Model with
+VPI Interface, Elaborator, Serialization, Visitor and Listener.")
+ (license license:asl2.0)))

base-commit: d59a13b6401e7494d8d5c9c9f66df3318451be79
--
2.48.1
Sharlatan Hellseher wrote 2 days ago
[PATCH] gnu: Add uhdm.
(address . 76207@debbugs.gnu.org)
87v7t69sm2.fsf@gmail.com
Hi,

Thank you for the patch.

Please check my review points:
Toggle snippet (8 lines)
+ (inputs (list python-orderedmultidict
+ python
+ cmake-minimal
+ openssl
+ zlib
+ googletest
+ capnproto))
I contains build and runtime dependencies, let's split them out e.g.

- native-inputs:
+ cmake-minimal
+ googletest
+ python-wrapper
- inputs:
+ capnproto
+ openssl
+ python-orderedmultidict
+ zlib

Toggle snippet (5 lines)
+ (uri (git-reference
+ (url "https://github.com/chipsalliance/UHDM/")
+ (commit (string-append "v" version))
+ (recursive? #f)))
Does it pull any extra dependencies? May you check if they may be
replaced by available in Guix, if not provide some notes why it's not
possible for now.

Toggle snippet (8 lines)
capnproto @ 8c7e0fd
decompile vpiHandle
2 years ago
googletest @ 58d77fa
Switch to current googletest release.
3 years ago
Verilog_Object_Model.pdf
Let's remove them as you already provided in inputs.

Toggle snippet (4 lines)
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))
Please, provide some notes for the future package maintainer describing
why you did this.

License looks correct:
Toggle snippet (9 lines)
licensecheck -r UHDM | awk -F: '{print $2}' | sort | uniq -c | sort -rn
305 Apache License (v2.0)
63 *No copyright* UNKNOWN
19 Apache License (v2.0) GENERATED FILE
4 *No copyright* GENERATED FILE
2 UNKNOWN
1 *No copyright* Apache License (v2.0)

Looking forward for v2!

---
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAme1p+UACgkQdtcnv/Ys
0rW5dBAAv8EquBljm89TIsxDoli0AtYMfTv5NIKzKCgZfsFIjSRaV2WYwmyvNLFU
QGqa3QhP3wyOjcDkUl013AhVV6oPKYGpMheXKBHXdzRrPymK3jM9eSfGjDakkqZJ
EQhqRISdVgwGgyIhaxyTmHCxbeRexQHRxFIatgVO3Z2KlXHqNfbPtr/Ewa1+koQl
yN/2KJF8UGPL/tPiNjyEwLfzHmTSppCnThcasVDYa35rRsvTLdQjIC/NSNdBr+uo
MQJOfeJXSYbAGEXVBuZ/P7P492Ctuqr+mZ53lA1SyfSJp2vzMc6H0a8LA2yLcbUo
343DUPGgM8GcQ9pLHXp4+Q6MqDDesUFIbaHak6kuAL/6wLPeleA4ZSKllexRuJyO
6rXJIsaW/ZvCFuLNUaLnIh07f7vZmNOqRkUYIjJw0n1uq9aWr26mMfy+lMUNQKNk
vX91rzG3muG4pSClOocA99gmiUsISxLNOMdHG2fzFTLaxKTxtCDQqhUacms/2EBO
uPIen872WIVYdu2AciwpFoRpduMaTlUSiQsfU2knWe8RN0XJHXBpi7LYcFYqf/9K
0cFxjSWshWGgVFizWPWM7qOEoHzH1XAB9XuhoPIGxdpJ7SnKeonbcqGw/G4dh4wO
j+GGFlcyTRi9IHMm4PGVklYZQHfu+6YOHOKYd2lk8PWtm9sxYAc=
=jR5F
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76207@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76207
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch