[PATCH] gnu: xonsh: Fix tests.

  • Done
  • quality assurance status badge
Details
2 participants
  • Greg Hogan
  • Ian Eure
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal

Debbugs page

Greg Hogan wrote on 11 Feb 17:13 +0100
(address . guix-patches@gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
958e1b247cdc99ec617c433c112c1bd342ec5968.1739288188.git.code@greghogan.com
The two failing tests are in tests/completers/test_pip_completer, so
rather than exclude the tests instead add the native input.

* gnu/packages/shells.scm (xonsh)[native-inputs]: Add python-pip.

Change-Id: Ide457ffca0e05d03d9d4d3fea36c1d23a2257c27
---
gnu/packages/shells.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (16 lines)
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 7763c2729b5..6f830d54aa6 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -620,6 +620,7 @@ (define-public xonsh
(setenv "HOME" "/tmp"))))))
(native-inputs
(list git-minimal
+ python-pip
python-pyte
python-pytest
python-pytest-mock

base-commit: 3fc24b4a6ab9612919c8661d2df77731861e36b4
--
2.48.1
Ian Eure wrote on 11 Feb 21:50 +0100
control message for bug #76206
(address . control@debbugs.gnu.org)
8734gktdds.fsf@retrospec.tv
close 76206
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76206@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76206
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch