[PATCH] Bump revision to fix a bug with unintended removal of NEWS line from previous PR

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid.Afkhami@mdc-berlin.de
  • Navid Afkhami
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote on 11 Feb 12:54 +0100
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
ad07d6de26d73e79b53db947bc5ed2045283afc6.1739274867.git.navid.afkhami@mdc-berlin.de
Change-Id: Id40d7d18c644c112500fed68c22633b33195e899
---
gnu/packages/bioinformatics.scm | 107 ++++++++++++++++----------------
1 file changed, 54 insertions(+), 53 deletions(-)

Toggle diff (126 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6b2e552585..a1690392af 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -856,63 +856,64 @@ (define-public r-bedtorch
(license license:expat))))
(define-public r-bpcells
- (package
- (name "r-bpcells")
- (version "0.3.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/bnprks/BPCells")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "12h1di45fg06nhsliii7v0h1z567pkpis1xm4ar1qr8ns1n8iljw"))))
- (properties `((upstream-name . "BPCells")))
- (build-system r-build-system)
- (arguments
- (list
- #:phases
- '(modify-phases %standard-phases
- (add-after 'unpack 'chdir
- (lambda _ (chdir "r"))))))
- (propagated-inputs
- (list r-dplyr
- r-ggplot2
- r-ggrepel
- r-hexbin
- r-lifecycle
- r-magrittr
- r-matrix
- r-patchwork
- r-rcolorbrewer
- r-rcpp
- r-rcppeigen
- r-readr
- r-rlang
- r-scales
- r-scattermore
- r-stringr
- r-tibble
- r-tidyr
- r-vctrs
+ (let ((commit "966820b8da473ad2d4fc85354f280d926364abb7")
+ (revision "1"))
+ (package
+ (name "r-bpcells")
+ (version (git-version "0.3.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bnprks/BPCells")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ig23cqsycgp96x71y6504vkd1sjjpl05vvi7ikly32rvij94nph"))))
+ (properties `((upstream-name . "BPCells")))
+ (build-system r-build-system)
+ (arguments
+ (list
+ #:phases '(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "r"))))))
+ (propagated-inputs (list r-dplyr
+ r-ggplot2
+ r-ggrepel
+ r-hexbin
+ r-lifecycle
+ r-magrittr
+ r-matrix
+ r-patchwork
+ r-rcolorbrewer
+ r-rcpp
+ r-rcppeigen
+ r-readr
+ r-rlang
+ r-scales
+ r-scattermore
+ r-stringr
+ r-tibble
+ r-tidyr
+ r-vctrs
- ;; Suggested packages
- r-genomicranges
- r-igraph
- r-iranges
- r-matrixstats))
- (inputs (list hdf5 zlib))
- (native-inputs (list pkg-config))
- (home-page "https://github.com/bnprks/BPCells")
- (synopsis "Single cell counts matrices to PCA")
- (description
- "This is a package providing efficient operations for single cell
+ ;; Suggested packages
+ r-genomicranges
+ r-igraph
+ r-iranges
+ r-matrixstats))
+ (inputs (list hdf5 zlib))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/bnprks/BPCells")
+ (synopsis "Single cell counts matrices to PCA")
+ (description
+ "This is a package providing efficient operations for single cell
ATAC-seq fragments and RNA counts matrices. It is interoperable with standard
file formats, and introduces efficient bit-packed formats that allow large
storage savings and increased read speeds.")
- ;; Either license
- (license (list license:asl2.0 license:expat))))
+ ;; Either license
+ (license (list license:asl2.0 license:expat)))))
(define-public r-btools
(let ((commit "fa21d4ca01d37ea4d98b45582453f3bf95cbc2b5")

base-commit: 23c39e0d1bff210c3bea35cc666a4421c5d1f165
--
2.43.0
Navid.Afkhami@mdc-berlin.de wrote on 13 Feb 17:38 +0100
Closing this issue
(name . 76201-done@debbugs.gnu.org)(address . 76201-done@debbugs.gnu.org)
4ce796efa2454d888dcde64c91a5fe70@mdc-berlin.de
Hi,


I am closing this because the commit message is wrong.



- -

Navid Afkhami

High Performance Computing (HPC)

Max Delbrück Center for Molecular Medicine (MDC)

Robert-Rössle-Straße 10, 13125 Berlin

Phone: +49 30 9406 1316

Email: navid.afkhami@mdc-berlin.de
Attachment: file
Attachment: smime.p7s
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76201@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76201
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch