[PATCH] gnu: icewm: make available during instalation.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Christopher Baines
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 1 months ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
d29e368af469974829fa155f07be4278c8cf9ec8.1739128779.git.atai@atai.org
* gnu/installer/services.scm (icewm): Make icewm a desktop service.
* gnu/tests/install.scm: Make icewm an installation target for tests.
* etc/manifests/release.scm: Make icewm available at system install.

Change-Id: I881c1dd4289281e51c81d83fac785ef064e6ff6a
---
etc/manifests/release.scm | 2 +-
gnu/installer/services.scm | 3 +++
gnu/tests/install.scm | 2 +-
3 files changed, 5 insertions(+), 2 deletions(-)

Toggle diff (45 lines)
diff --git a/etc/manifests/release.scm b/etc/manifests/release.scm
index b003f216ff..93ac7dcec8 100644
--- a/etc/manifests/release.scm
+++ b/etc/manifests/release.scm
@@ -68,7 +68,7 @@ (define %system-packages
;; Key packages proposed by the Guix System installer.
(append (map specification->package
'("xorg-server" "xfce" "gnome" "mate" "enlightenment"
- "openbox" "awesome" "i3-wm" "ratpoison"
+ "icewm" "openbox" "awesome" "i3-wm" "ratpoison"
"emacs" "emacs-exwm" "emacs-desktop-environment"
"xlockmore" "slock" "libreoffice"
"connman" "network-manager" "network-manager-applet"
diff --git a/gnu/installer/services.scm b/gnu/installer/services.scm
index 8b117d9a20..acb2d9ead9 100644
--- a/gnu/installer/services.scm
+++ b/gnu/installer/services.scm
@@ -83,6 +83,9 @@ (define (%system-services)
(desktop-environment
(name "Enlightenment")
(snippet '((service enlightenment-desktop-service-type))))
+ (desktop-environment
+ (name "Icewm")
+ (snippet '((specification->package "icewm"))))
(desktop-environment
(name "Openbox")
(packages '((specification->package "openbox"))))
diff --git a/gnu/tests/install.scm b/gnu/tests/install.scm
index c8dccd38b0..b799a6752e 100644
--- a/gnu/tests/install.scm
+++ b/gnu/tests/install.scm
@@ -2013,7 +2013,7 @@ (define* (installation-target-desktop-os-for-gui-tests
;; Make sure that all the packages and services that may be used by the
;; graphical installer are available.
(packages (append
- (list openbox awesome i3-wm i3status
+ (list icewm openbox awesome i3-wm i3status
dmenu st ratpoison xterm
emacs emacs-exwm emacs-desktop-environment)
%base-packages))

base-commit: fd3876ec2a47909eac8e7fa0f24710a94ccb1459
prerequisite-patch-id: 881f4620ea8e644e636c77f82f383aea28f5688f
--
2.46.0
Christopher Baines wrote 2 weeks ago
(name . Andy Tai)(address . atai@atai.org)(address . 76166-done@debbugs.gnu.org)
87y0xoxsro.fsf@cbaines.net
Andy Tai <atai@atai.org> writes:

Toggle quote (6 lines)
> * gnu/installer/services.scm (icewm): Make icewm a desktop service.
> * gnu/tests/install.scm: Make icewm an installation target for tests.
> * etc/manifests/release.scm: Make icewm available at system install.
>
> Change-Id: I881c1dd4289281e51c81d83fac785ef064e6ff6a

The changes seem OK, the commit message seemed a bit off though, I've
rewritten it as:

installer: Include icewm as a desktop environment.

* gnu/installer/services.scm (%system-services): Include icewm as a desktop
environment.
* gnu/tests/install.scm (installation-target-desktop-os-for-gui-tests): Add
icewm to the list of packages.
* etc/manifests/release.scm: (%system-packages): Add icewm.

I think that better reflects the actual changes being made.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmfDkRtfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xd6dxAAg9n01dunCQ4sDyxASBYvrn7mJ2OUaHJg
ywZ95D1IDORnCDtNVe7BsjWQvzTEeuBKaoacklCskbYRrjuVtmdXirbLjFZPza4k
XeTdYRhlASnmOdaHuNbmeoowcORGIgdNokneW6rJYUzHzXQ0exDmRBq+WkBGApZM
t68WyhsGBpJe3c4bkWapjJ7eKEIgGOp6XbcCpxopZ5F8xR63B21rmU4rJJ4wsuax
LhWAY3dCo50O9DJ7U/pVOcvVowxK0F1TKDhHPGo0xEh0TXEDpimSfq4f9QXo63v8
rFKRi7bN//EsENhmGNjncJbWUgJ6sCG8bDndvDNhv6GNy56qLJ3w/2XY0jUqxTqu
lLL2vkAR1tVbtRhL8S7wSe5Zxjiz0E4oKt0nKH4XvSw4R6fOL9SxIgsen+1YACq4
Daj6VPluaIYauXyGPtAQEA2hLsmDcKz1EPffUNOYqXSMSGRhJkDI8mldIFLI4nyc
I/SVQBGI6UuMHyRkAc0nu78joRCv5bdK8JoPcJd84fGV8mRS8bMwQmOwacFg4+oe
U0UY3SfVbJsc8PVjEqUsX4EsMHWhf0Osx1s3Fs8f6l9teZJLsYx3M/wA3VAYx1tj
N1Gn7xfL9J98gclC4yCjqm8MBXyiII2wHMz+ME9QZXVuH6+Ey/dNSdbrVTbVfTsT
3AuFdZQ/U4E=
=Pv04
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76166@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76166
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help