[PATCH] gnu: Add go-github-com-golang-jwt-jwt.

  • Done
  • quality assurance status badge
Details
2 participants
  • Roman Scherer
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Roman Scherer
Severity
normal

Debbugs page

Roman Scherer wrote 1 months ago
(address . guix-patches@gnu.org)(name . Roman Scherer)(address . roman@burningswell.com)
d216ae2a26e894fe9fb285cab1661932b57847f7.1739127414.git.roman@burningswell.com
* gnu/packages/golang-crypto.scm (go-github-com-golang-jwt-jwt): New variable.

Change-Id: I9a7cec096236e6fbce4a345277e6e87a9e700419
---
gnu/packages/golang-crypto.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 70e40ee400..f283658995 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -1234,6 +1234,30 @@ (define-public go-github-com-jcmturner-aescts-v2
Stealing encryption and decryption methods.")
(license license:asl2.0)))
+(define-public go-github-com-golang-jwt-jwt
+ (package
+ (name "go-github-com-golang-jwt-jwt")
+ (version "5.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/golang-jwt/jwt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13l2p4g9f7bpz0nf2sc4r5ms06ps7bs7z1vpzzv943q094pjs0yw"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/golang-jwt/jwt/cmd/jwt"
+ #:unpack-path "github.com/golang-jwt/jwt"))
+ (home-page "https://github.com/golang-jwt/jwt")
+ (synopsis "Go implementation of JSON Web Tokens")
+ (description "This package provides an implementation of JSON Web Tokens
+in Go.")
+ (license license:expat)))
+
(define-public go-github-com-jzelinskie-whirlpool
(package
(name "go-github-com-jzelinskie-whirlpool")

base-commit: 5f6fdadb4af5a0a94f41c4365a3c73e31fed01af
--
2.48.1
Sharlatan Hellseher wrote 1 months ago
(address . 76164-done@debbugs.gnu.org)
87pljpx2pg.fsf@gmail.com
Hi,

Thanks for the patch.

There are 3 version variants are in golang-crypto right now:

go-github-com-golang-jwt-jwt@3.2.2
go-github-com-golang-jwt-jwt-v4@4.5.0
go-github-com-golang-jwt-jwt-v5@5.2.0

I've refreshed go-github-com-golang-jwt-jwt-v5 to 5.2.1.

Close as no applied.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmeqFQsACgkQdtcnv/Ys
0rXETA/+KtzBT8UnrKk7shHa8YmG0mJiRClTUTs9HIUokw5QHgVDKh24P/YX/RVf
bpTNfWK7XRHTkS+qGi9sYb4Do91NnmlYTNWbUDo+Md0w5hOrDbKZFc8EhQqkfA8I
Xzicd8IIWLBHcgR7FWreg9Wg1kaw4RDYF8YD1RHSCDxI+5lSEMz1vouR10n7Dj4g
AAHuoU59ge8rbu2kulY6obHrrD+G4kuwnHJvNWHNDMDU+RXBlUI/7SIkbSUO9y+/
EJ7hrUT4fW2VUnxx687pa5tB/01eQMZF4/FodBval7W3eokLpIF+0BcaEzpjpS6G
IEJR15Pdv7F33JQmWdsyfUfv2Moc0SWOGz3egaxBSLThvOuta2rESoqK8grgqn/I
TPHCMUpz1K1Cxck5tVmOZcIHNXGX5r/T9n/Rtj1TGwFFx+XK+nj0kfFLt68gmycs
L3MG3NLa4EAZ/f4s8cad6E/Jr8/G69WRVjbk60z/xY8HxKh7gg9kbZ8GWqfo90wH
9bNDjwpiHXcCSGkCu40Ce9iZEzPzhvmCGBbHbo+ILk/aFDa8PP2YCWyDGqu90mM5
FMHk6vw6+cBxtertmIrQv0Jz0Ke/qIwtVt++OMjFwMgyinJjsfkJ26SWmp7dlPy0
UTdcfE9AIjl6jv9R2UhRIcKqhofMWY8jqx1IZLzN91DN4TDxHdw=
=oWwL
-----END PGP SIGNATURE-----

Closed
Roman Scherer wrote 1 months ago
Re: bug#76164: closed ([PATCH] gnu: Add go-github-com-golang-jwt-jwt.)
(name . GNU bug Tracking System)(address . help-debbugs@gnu.org)(address . 76164@debbugs.gnu.org)(name . Roman Scherer)(address . roman@burningswell.com)
86ldudof3t.fsf@burningswell.com
References: <87pljpx2pg.fsf@gmail.com>
<d216ae2a26e894fe9fb285cab1661932b57847f7.1739127414.git.roman@burningswell.com>
<handler.76164.D76164.173919976718580.notifdone@debbugs.gnu.org>
User-Agent: mu4e 1.12.8; emacs 29.4
Oops, I did not see that we already have it.

Thanks for refreshing the version!

Date: Mon, 10 Feb 2025 18:59:34 +0100

help-debbugs@gnu.org (GNU bug Tracking System) writes:

Toggle quote (90 lines)
> Your bug report
>
> #76164: [PATCH] gnu: Add go-github-com-golang-jwt-jwt.
>
> which was filed against the guix-patches package, has been closed.
>
> The explanation is attached below, along with your original report.
> If you require more details, please reply to 76164@debbugs.gnu.org.
>
> --
> 76164: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=76164
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
>
> From: Sharlatan Hellseher <sharlatanus@gmail.com>
> Subject: [PATCH] gnu: Add go-github-com-golang-jwt-jwt.
> To: 76164-done@debbugs.gnu.org
> Date: Mon, 10 Feb 2025 15:02:35 +0000 (2 hours, 56 minutes, 20 seconds ago)
>
>
> Hi,
>
> Thanks for the patch.
>
> There are 3 version variants are in golang-crypto right now:
>
> go-github-com-golang-jwt-jwt@3.2.2
> go-github-com-golang-jwt-jwt-v4@4.5.0
> go-github-com-golang-jwt-jwt-v5@5.2.0
>
> I've refreshed go-github-com-golang-jwt-jwt-v5 to 5.2.1.
>
> Close as no applied.
>
> --
> Oleg
>
> ----------
>
> From: Roman Scherer <roman@burningswell.com>
> Subject: [PATCH] gnu: Add go-github-com-golang-jwt-jwt.
> To: guix-patches@gnu.org
> Cc: Roman Scherer <roman@burningswell.com>
> Date: Sun, 9 Feb 2025 19:57:20 +0100
> Date: Sun, 9 Feb 2025 19:57:20 +0100 (23 hours, 1 minute, 35 seconds ago)
>
> * gnu/packages/golang-crypto.scm (go-github-com-golang-jwt-jwt): New variable.
>
> Change-Id: I9a7cec096236e6fbce4a345277e6e87a9e700419
> ---
> gnu/packages/golang-crypto.scm | 24 ++++++++++++++++++++++++
> 1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
> index 70e40ee400..f283658995 100644
> --- a/gnu/packages/golang-crypto.scm
> +++ b/gnu/packages/golang-crypto.scm
> @@ -1234,6 +1234,30 @@ (define-public go-github-com-jcmturner-aescts-v2
> Stealing encryption and decryption methods.")
> (license license:asl2.0)))
>
> +(define-public go-github-com-golang-jwt-jwt
> + (package
> + (name "go-github-com-golang-jwt-jwt")
> + (version "5.2.1")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/golang-jwt/jwt")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "13l2p4g9f7bpz0nf2sc4r5ms06ps7bs7z1vpzzv943q094pjs0yw"))))
> + (build-system go-build-system)
> + (arguments
> + (list
> + #:import-path "github.com/golang-jwt/jwt/cmd/jwt"
> + #:unpack-path "github.com/golang-jwt/jwt"))
> + (home-page "https://github.com/golang-jwt/jwt")
> + (synopsis "Go implementation of JSON Web Tokens")
> + (description "This package provides an implementation of JSON Web Tokens
> +in Go.")
> + (license license:expat)))
> +
> (define-public go-github-com-jzelinskie-whirlpool
> (package
> (name "go-github-com-jzelinskie-whirlpool")
>
> base-commit: 5f6fdadb4af5a0a94f41c4365a3c73e31fed01af
-----BEGIN PGP SIGNATURE-----

iQFLBAEBCAA1FiEE0iajOdjfRIFd3gygPdpSUn0qwZkFAmeqPoYXHHJvbWFuQGJ1
cm5pbmdzd2VsbC5jb20ACgkQPdpSUn0qwZm3YAgAooM3jnLufKnFQjgUAB4vkk6Y
6PU1VhDBMVe3qaSA7quAysQcfdo5DG62ME1a4blv1el98DXQpEbwEDTAPtTkW1yJ
jkQoldf4Oyj5RslsgQ6txcAvkV9hX0Y4XCnAeSZYhBDQxTWRUbG/FP5xSsMU9V4U
WB/acVWxOnD63lrv3ZJmCqgp8BVwpgc4j54lBCWNh6fBvePPp2IJLYYrktgD7IFa
D9Jjd/3GSISInHTXMG1Cn06fOZ7hgcwGiM0SYgVxPbEIyTt4vLa2aRIdjN6JcLVQ
X/N1aOy2mzX9ouscom4Tcm+eS830uyVFPx+RRN1+U97xMq9dDbFUirsJ8o/y2Q==
=bCNg
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 76164@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76164
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help