Roman Scherer wrote 1 months ago
(address . guix-patches@gnu.org)(name . Roman Scherer)(address . roman@burningswell.com)
* gnu/packages/golang-crypto.scm (go-github-com-golang-jwt-jwt): New variable.
Change-Id: I9a7cec096236e6fbce4a345277e6e87a9e700419
---
gnu/packages/golang-crypto.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
Toggle diff (39 lines)
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 70e40ee400..f283658995 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -1234,6 +1234,30 @@ (define-public go-github-com-jcmturner-aescts-v2
Stealing encryption and decryption methods.")
(license license:asl2.0)))
+(define-public go-github-com-golang-jwt-jwt
+ (package
+ (name "go-github-com-golang-jwt-jwt")
+ (version "5.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/golang-jwt/jwt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13l2p4g9f7bpz0nf2sc4r5ms06ps7bs7z1vpzzv943q094pjs0yw"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/golang-jwt/jwt/cmd/jwt"
+ #:unpack-path "github.com/golang-jwt/jwt"))
+ (home-page "https://github.com/golang-jwt/jwt")
+ (synopsis "Go implementation of JSON Web Tokens")
+ (description "This package provides an implementation of JSON Web Tokens
+in Go.")
+ (license license:expat)))
+
(define-public go-github-com-jzelinskie-whirlpool
(package
(name "go-github-com-jzelinskie-whirlpool")
base-commit: 5f6fdadb4af5a0a94f41c4365a3c73e31fed01af
--
2.48.1