[PATCH] gnu: icewm: iAdd icewm.desktop file.

  • Open
  • quality assurance status badge
Details
One participant
  • Andy Tai
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
A
A
Andy Tai wrote 37 hours ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
9a98aea8a4ba530cc59d35f16c989bb298c2c913.1739085365.git.atai@atai.org
* gnu/packages/wm.scm (icewm): Add 'install-xsession phase that
installs the icewm.desktop.file.

Change-Id: I94661ec15bccc3bcb1539a52c78cc303a4b5caf3
---
gnu/packages/wm.scm | 55 ++++++++++++++++++++++++++++++---------------
1 file changed, 37 insertions(+), 18 deletions(-)

Toggle diff (81 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 8aa314e56b..7ce4bb9f34 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1027,19 +1027,19 @@ (define-public icewm
(package
(name "icewm")
(version "3.6.0")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/ice-wm/icewm/releases/download/"
- version "/icewm-" version ".tar.lz"))
- (sha256
- (base32
- "0xmw4ilzsc932fxqahxvqix66x940nzf54p5mz5p67rplg9sz7wp"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/ice-wm/icewm/releases/download/" version
+ "/icewm-" version ".tar.lz"))
+ (sha256
+ (base32 "0xmw4ilzsc932fxqahxvqix66x940nzf54p5mz5p67rplg9sz7wp"))))
(build-system gnu-build-system)
(native-inputs (list pkg-config))
(inputs (list fontconfig
fribidi
- glib ;for icewm-menu-fdo
+ glib ;for icewm-menu-fdo
imlib2
libice
libjpeg-turbo
@@ -1057,15 +1057,34 @@ (define-public icewm
lzip
perl))
(arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'skip-failing-test
- ;; strtest.cc tests failing due to $HOME and /etc setup
- ;; difference under guix
- (lambda _
- (substitute* "src/Makefile.in"
- (("TESTS = strtest\\$\\(EXEEXT\\)")
- "TESTS = ")))))))
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-failing-test
+ ;; strtest.cc tests failing due to $HOME and /etc setup
+ ;; difference under guix
+ (lambda _
+ (substitute* "src/Makefile.in"
+ (("TESTS = strtest\\$\\(EXEEXT\\)")
+ "TESTS = "))))
+ (add-after 'install 'install-xsession
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Add a .desktop file to xsessions.
+ (let* ((output (assoc-ref outputs "out"))
+ (xsessions (string-append output
+ "/share/xsessions")))
+ (mkdir-p xsessions)
+ (call-with-output-file (string-append xsessions
+
+ "/icewm.desktop")
+ (lambda (port)
+ (format port
+ "[Desktop Entry]~@
+ Name=icewm~@
+ Comment=IceWM window manager~@
+ Exec=~a/bin/icewm~@
+ TryExec=~@*~a/bin/icewm~@
+ Type=Application~%"
+ output)))))))))
(home-page "https://ice-wm.org/")
(synopsis "Window manager for the X Window System")
(description

base-commit: fd3876ec2a47909eac8e7fa0f24710a94ccb1459
--
2.46.0
A
A
Andy Tai wrote 37 hours ago
[PATCH v2] gnu: icewm: Add icewm.desktop file.
(address . 76153@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
97224d956e711613b54fbcffed781a5d503a63e2.1739085587.git.atai@atai.org
* gnu/packages/wm.scm (icewm): Add 'install-xsession phase that
installs the icewm.desktop.file.

Change-Id: I94661ec15bccc3bcb1539a52c78cc303a4b5caf3
---
gnu/packages/wm.scm | 55 ++++++++++++++++++++++++++++++---------------
1 file changed, 37 insertions(+), 18 deletions(-)

Toggle diff (81 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 8aa314e56b..7ce4bb9f34 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1027,19 +1027,19 @@ (define-public icewm
(package
(name "icewm")
(version "3.6.0")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/ice-wm/icewm/releases/download/"
- version "/icewm-" version ".tar.lz"))
- (sha256
- (base32
- "0xmw4ilzsc932fxqahxvqix66x940nzf54p5mz5p67rplg9sz7wp"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/ice-wm/icewm/releases/download/" version
+ "/icewm-" version ".tar.lz"))
+ (sha256
+ (base32 "0xmw4ilzsc932fxqahxvqix66x940nzf54p5mz5p67rplg9sz7wp"))))
(build-system gnu-build-system)
(native-inputs (list pkg-config))
(inputs (list fontconfig
fribidi
- glib ;for icewm-menu-fdo
+ glib ;for icewm-menu-fdo
imlib2
libice
libjpeg-turbo
@@ -1057,15 +1057,34 @@ (define-public icewm
lzip
perl))
(arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'skip-failing-test
- ;; strtest.cc tests failing due to $HOME and /etc setup
- ;; difference under guix
- (lambda _
- (substitute* "src/Makefile.in"
- (("TESTS = strtest\\$\\(EXEEXT\\)")
- "TESTS = ")))))))
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-failing-test
+ ;; strtest.cc tests failing due to $HOME and /etc setup
+ ;; difference under guix
+ (lambda _
+ (substitute* "src/Makefile.in"
+ (("TESTS = strtest\\$\\(EXEEXT\\)")
+ "TESTS = "))))
+ (add-after 'install 'install-xsession
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Add a .desktop file to xsessions.
+ (let* ((output (assoc-ref outputs "out"))
+ (xsessions (string-append output
+ "/share/xsessions")))
+ (mkdir-p xsessions)
+ (call-with-output-file (string-append xsessions
+
+ "/icewm.desktop")
+ (lambda (port)
+ (format port
+ "[Desktop Entry]~@
+ Name=icewm~@
+ Comment=IceWM window manager~@
+ Exec=~a/bin/icewm~@
+ TryExec=~@*~a/bin/icewm~@
+ Type=Application~%"
+ output)))))))))
(home-page "https://ice-wm.org/")
(synopsis "Window manager for the X Window System")
(description

base-commit: fd3876ec2a47909eac8e7fa0f24710a94ccb1459
--
2.46.0
A
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76153@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76153
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch