[PATCH 00/16] More patches towards SageMath.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote 43 hours ago
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
cover.1739064949.git.monego@posteo.net
This series adds some optional packages for SageMath and updates other standard packages.

The version bumps to m4ri, m4rie, python-cvxopt and singular are required for the latest version of sage. The other patches introduce new optional packages.

Vinicius Monego (16):
gnu: Add normaliz.
gnu: Add python-pynormaliz.
gnu: Add python-nibabel.
gnu: python-cvxopt: Update to 1.3.2.
gnu: Add msolve.
gnu: Add python-cylp.
gnu: singular: Remove package labels.
gnu: singular: Update to 4.4.0p7.
gnu: singular: Use G-Expressions.
gnu: Add python-pysingular.
gnu: m4ri: Update to 20200125.
gnu: m4rie: Update to 20200125.
gnu: Add hpcombi.
gnu: Add libsemigroups.
gnu: Add plantri.
gnu: Add glucose.

gnu/packages/algebra.scm | 157 ++++++++++++++++++++++++++++----
gnu/packages/graph.scm | 35 ++++++-
gnu/packages/maths.scm | 153 ++++++++++++++++++++++++++++++-
gnu/packages/python-science.scm | 35 ++++++-
4 files changed, 356 insertions(+), 24 deletions(-)


base-commit: 05516fcb24799d00947751a434dd797f3fbb9d64
--
2.48.1
V
V
Vinicius Monego wrote 43 hours ago
[PATCH 01/16] gnu: Add normaliz.
(address . 76150@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
82223555512250f32116e577ee99c171559f4381.1739064949.git.monego@posteo.net
* gnu/packages/algebra.scm (normaliz): New variable.

Change-Id: I3e0936c598b0a5fdd88af9d22280137d42c45cc5
---
gnu/packages/algebra.scm | 28 +++++++++++++++++++++++++++-
1 file changed, 27 insertions(+), 1 deletion(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index afca739766..f1d4820dcb 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
-;;; Copyright © 2020, 2021, 2023, 2024 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021, 2023, 2024, 2025 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2023 Mehmet Tekman <mtekman89@gmail.com>
@@ -1017,6 +1017,32 @@ (define-public ginac
extends it by a set of algebraic capabilities.")
(license license:gpl2+)))
+(define-public normaliz
+ (package
+ (name "normaliz")
+ (version "3.10.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/normaliz/Normaliz")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1smla96wjyv5ygg77ps9np6bfzp2qynq8vd1msybabi4621cnrma"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake libtool pkg-config))
+ ;; Flint is optional. TODO: Try to build with nauty and cocoalib support.
+ ;; The configure script fails to find nauty.h.
+ (inputs (list flint gmp))
+ (home-page "https://www.normaliz.uni-osnabrueck.de/")
+ (synopsis "Tool for discrete convex geometry")
+ (description "Normaliz is a tool for computations in affine monoids,
+vector configurations, rational polyhedra and rational cones. Normaliz now
+computes rational and algebraic polyhedra, i.e., polyhedra defined over real
+algebraic extensions of QQ.")
+ (license license:gpl3+)))
+
(define-public eigen
(package
(name "eigen")
--
2.48.1
V
V
Vinicius Monego wrote 43 hours ago
[PATCH 02/16] gnu: Add python-pynormaliz.
(address . 76150@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
3167451161f6b33144c496fe9832ee196701580c.1739064949.git.monego@posteo.net
* gnu/packages/algebra.scm (python-pynormaliz): New variable.

Change-Id: I94379cfeed2a67bb4ffbda34823e4e000f4f961e
---
gnu/packages/algebra.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index f1d4820dcb..4e111a542a 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1043,6 +1043,35 @@ (define-public normaliz
algebraic extensions of QQ.")
(license license:gpl3+)))
+(define-public python-pynormaliz
+ (package
+ (name "python-pynormaliz")
+ (version "2.21")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pynormaliz" version))
+ (sha256
+ (base32 "0hsyxml71i2b9pa375ipbfpackj3y67jlg2rxgc433sfy3895wvf"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #f ; tests need normaliz to be built with nauty support
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "python" "tests/runtests.py")))))))
+ (native-inputs (list python-setuptools python-wheel))
+ (inputs (list flint gmp normaliz))
+ (home-page "https://github.com/Normaliz/PyNormaliz")
+ (synopsis "Python interface to Normaliz")
+ (description
+ "PyNormaliz provides an interface to Normaliz via libNormaliz. It offers
+the complete functionality of Normaliz, and can be used interactively from
+Python.")
+ (license license:gpl2+)))
+
(define-public eigen
(package
(name "eigen")
--
2.48.1
V
V
Vinicius Monego wrote 43 hours ago
[PATCH 03/16] gnu: Add python-nibabel.
(address . 76150@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
6942109990137daf5cdee6b4505102f646a90e22.1739064949.git.monego@posteo.net
* gnu/packages/python-science.scm (python-nibabel): New variable.

Change-Id: I27d3841def6f360ae3996aacb787142bcfa92291
---
gnu/packages/python-science.scm | 35 ++++++++++++++++++++++++++++++++-
1 file changed, 34 insertions(+), 1 deletion(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 7772dce248..bd7ea99c60 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2019, 2021, 2022, 2023, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
-;;; Copyright © 2020, 2021, 2022, 2023, 2024 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020-2025 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 Roel Janssen <roel@gnu.org>
;;; Copyright © 2021 Paul Garlick <pgarlick@tourbillion-technology.com>
@@ -1128,6 +1128,39 @@ (define-public python-pyet
Evapotranspiration using various standard methods.")
(license license:expat)))
+(define-public python-nibabel
+ (package
+ (name "python-nibabel")
+ (version "5.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "nibabel" version))
+ (sha256
+ (base32 "16snprwgp7qzp51j3mx0zdn7brvx6r14ankldi24ny0w7d8adp0b"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; AttributeError: 'dict' object has no attribute 'add'.
+ #:test-flags #~(list "-k" "not test_first and not test_second")))
+ (propagated-inputs (list python-importlib-resources python-numpy
+ python-packaging python-typing-extensions))
+ (native-inputs (list python-hatch-vcs
+ python-hatchling
+ python-pytest
+ python-pytest-httpserver
+ python-pytest-xdist))
+ (home-page "https://nipy.org/nibabel/")
+ (synopsis "Read and write access to common neuroimaging file formats")
+ (description
+ "@code{nibabel} is a library that provides read and write access to
+common neuroimaging file formats, including: ANALYZE (plain, SPM99, SPM2
+and later), GIFTI, NIfTI1, NIfTI2, CIFTI-2, MINC1, MINC2, AFNI BRIK/HEAD,
+ECAT and Philips PAR/REC. In addition, NiBabel also supports FreeSurfer’s
+MGH, geometry, annotation and morphometry files, and provides some limited
+support for DICOM.")
+ (license license:expat)))
+
(define-public python-tspex
(package
(name "python-tspex")
--
2.48.1
V
V
Vinicius Monego wrote 43 hours ago
[PATCH 04/16] gnu: python-cvxopt: Update to 1.3.2.
(address . 76150@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
99a51c88eb0333d3e05747146ab65b00a95edc58.1739064949.git.monego@posteo.net
* gnu/packages/maths.scm (python-cvxopt): Update to 1.3.2.

Change-Id: I7924821a69e092da529a5188df3d1b2e3f4eed49
---
gnu/packages/maths.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index bfdad0eff3..47a81a510c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -39,7 +39,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
-;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021, 2025 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2021 Gerd Heber <gerd.heber@gmail.com>
@@ -3975,7 +3975,7 @@ (define-public python-blis-for-thinc
(define-public python-cvxopt
(package
(name "python-cvxopt")
- (version "1.2.7")
+ (version "1.3.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3984,7 +3984,7 @@ (define-public python-cvxopt
(file-name (git-file-name name version))
(sha256
(base32
- "114z34wwx1bsv4q6xj9p5q99dffgnj9s4i4arx10g191xq9q8i5y"))))
+ "0vdfag3rr906w0gk7vxm2yxfy8y92i4wmqxi82cbykpfp5r82i36"))))
(build-system python-build-system)
(arguments
`(#:phases
--
2.48.1
V
V
Vinicius Monego wrote 42 hours ago
[PATCH 05/16] gnu: Add msolve.
(address . 76150@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
4ca0caa93189db29f8bfb7f9c803b29cedaf97c8.1739064949.git.monego@posteo.net
* gnu/packages/maths.scm (msolve): New variable.

Change-Id: I8587f7527a6eb1cc9065751351491777c4cd00be
---
gnu/packages/maths.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 47a81a510c..2c89451d0f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -7095,6 +7095,40 @@ (define-public lpsolve
revised simplex and the branch-and-bound methods.")
(license license:lgpl2.1+)))
+(define-public msolve
+ (package
+ (name "msolve")
+ (version "0.7.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/algebraic-solving/msolve")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ipsdw5sk4d344ki4r5ma9vn8gyi8hrk0n951r0720wvgxkw920p"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake libtool))
+ (inputs (list flint gmp mpfr))
+ (home-page "https://msolve.lip6.fr/")
+ (synopsis
+ "Library for polynomial system solving through algebraic methods")
+ (description "@code{msolve} is a C library implementing computer algebra
+algorithms for solving polynomial systems (with rational coefficients or
+coefficients in a prime field).
+
+Currently, with msolve, you can basically solve multivariate polynomial
+systems. This encompasses:
+
+@itemize
+@item the computation of Groebner bases
+@item real root isolation of the solutions to polynomial systems
+@item the computation of the dimension and the degree of the solution set and
+many other things you can do using msolve.
+@end itemize")
+ (license license:gpl2+)))
+
;; Private Trilinos package for dealii-openmpi (similar to
;; trilinos-serial-xyce and trilinos-parallel-xyce).
;; This version is the latest known to be compatible with deal.II [1].
--
2.48.1
V
V
Vinicius Monego wrote 42 hours ago
[PATCH 06/16] gnu: Add python-cylp.
(address . 76150@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
bbc1e00626bde11e667bf988650c4e1fcff2c390.1739064949.git.monego@posteo.net
* gnu/packages/maths.scm (python-cylp): New variable.

Change-Id: Id3467bc34833472aa7fca3416801a5fbf5c033e6
---
gnu/packages/maths.scm | 48 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 2c89451d0f..44bd1b15d9 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2739,6 +2739,54 @@ (define-public clp
and quadratic objectives using the Simplex algorithm.")
(license license:epl1.0)))
+(define-public python-cylp
+ (package
+ (name "python-cylp")
+ (version "0.92.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cylp" version))
+ (sha256
+ (base32 "1mhvjrhvpgnpw4zwri92dj168qvyclcpsqvzbj5maxx5cilnhkww"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags #~(list "-k" (string-append
+ "not " (string-join
+ (list
+ "test_removeVar2" ; AssertionError
+ ;; Tests below segfault
+ "test_dantzig"
+ "test_lifo"
+ "test_mf"
+ "test_pe")
+ " and not ")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests? ; rebuild extensions
+ (invoke "python" "setup.py" "build_ext" "--inplace")))))))
+ (propagated-inputs (list python-numpy python-pytest python-scipy))
+ (inputs (list cbc))
+ (native-inputs (list pkg-config
+ python-cython-3
+ python-hypothesis
+ python-numpy
+ python-pytest
+ python-setuptools
+ python-wheel))
+ (home-page "https://github.com/coin-or/cylp")
+ (synopsis "Python interface for CLP, CBC, and CGL")
+ (description
+ "CyLP is a Python interface to COIN-OR’s Linear and mixed-integer program
+solvers (CLP, CBC, and CGL). CyLP’s unique feature is that you can use it to
+alter the solution process of the solvers from within Python. For example,
+you may define cut generators, branch-and-bound strategies, and primal/dual
+Simplex pivot rules completely in Python.")
+ (license license:epl2.0)))
+
(define-public gecode
(let* ((commit "f7f0d7c273d6844698f01cec8229ebe0b66a016a")
(version (git-version "6.2.0" "1" commit)))
--
2.48.1
V
V
Vinicius Monego wrote 42 hours ago
[PATCH 07/16] gnu: singular: Remove package labels.
(address . 76150@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
e000edd76cb46339dc847e9ad2de7574533e15f0.1739064949.git.monego@posteo.net
* gnu/packages/algebra.scm (singular)[inputs]: Remove package labels.

Change-Id: Iecdcf07df4c0f18c0305a8f990d4a2e3c832cdd6
---
gnu/packages/algebra.scm | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 4e111a542a..bf3abaa8ed 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -619,13 +619,13 @@ (define-public singular
(native-inputs
(list doxygen graphviz perl))
(inputs
- `(("cddlib" ,cddlib)
- ("gmp" ,gmp)
- ("flint" ,flint)
- ("mpfr" ,mpfr)
- ("ntl" ,ntl)
- ("python" ,python-2)
- ("readline" ,readline)))
+ (list cddlib
+ gmp
+ flint
+ mpfr
+ ntl
+ python-2
+ readline))
(arguments
`(#:configure-flags
(list (string-append "--with-ntl="
--
2.48.1
V
V
Vinicius Monego wrote 42 hours ago
[PATCH 08/16] gnu: singular: Update to 4.4.0p7.
(address . 76150@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
b82ee6b70ce8f7bf0929f2bfe9be59fe910147c2.1739064949.git.monego@posteo.net
* gnu/packages/algebra.scm (singular): Update to 4.4.0p7.

Change-Id: I64f74815097ca3aaeeaba9f3177580818c433a4c
---
gnu/packages/algebra.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index bf3abaa8ed..acbc76b4ca 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -599,7 +599,7 @@ (define-public ntl
(define-public singular
(package
(name "singular")
- (version "4.3.2p16")
+ (version "4.4.0p7")
(source
(origin
(method url-fetch)
@@ -613,8 +613,9 @@ (define-public singular
version))
#\.) "-")
"/singular-" version ".tar.gz"))
- (sha256 (base32
- "05ia8zqiddj1agg9bfdx54z0sjqcgjgi6lz7ck2ngv562fx36mv7"))))
+ (sha256
+ (base32
+ "0625541pxxhs7789i3ddf5fm1pqvf1kyljyaii41djg9j12cdhbc"))))
(build-system gnu-build-system)
(native-inputs
(list doxygen graphviz perl))
--
2.48.1
V
V
Vinicius Monego wrote 42 hours ago
[PATCH 09/16] gnu: singular: Use G-Expressions.
(address . 76150@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
6c5f5034d72976249920afbdf3ce28a6de4d0701.1739064949.git.monego@posteo.net
* gnu/packages/algebra.scm (singular)[arguments]: Use
G-Expressions. Move below build-system.

Change-Id: I4253b8a9a9cd3b7d2b7492853323d1e8c4fbec4e
---
gnu/packages/algebra.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index acbc76b4ca..b69b14fa28 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -617,6 +617,10 @@ (define-public singular
(base32
"0625541pxxhs7789i3ddf5fm1pqvf1kyljyaii41djg9j12cdhbc"))))
(build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags #~(list (string-append "--with-ntl="
+ #$(this-package-input "ntl")))))
(native-inputs
(list doxygen graphviz perl))
(inputs
@@ -627,10 +631,6 @@ (define-public singular
ntl
python-2
readline))
- (arguments
- `(#:configure-flags
- (list (string-append "--with-ntl="
- (assoc-ref %build-inputs "ntl")))))
(synopsis "Computer algebra system for polynomial computations")
(description
"Singular is a computer algebra system for polynomial computations,
--
2.48.1
V
V
Vinicius Monego wrote 42 hours ago
[PATCH 10/16] gnu: Add python-pysingular.
(address . 76150@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
b304e3432dc70f84b8a8b7fed28cd5521b196bfb.1739064949.git.monego@posteo.net
* gnu/packages/algebra.scm (python-pysingular): New variable.

Change-Id: I57e828bd4eb2c64b2ba094ed0c9cb516fee1c5b4
---
gnu/packages/algebra.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index b69b14fa28..6abe959343 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -642,6 +642,28 @@ (define-public singular
(license license:gpl3)
(home-page "https://www.singular.uni-kl.de/index.php")))
+(define-public python-pysingular
+ (package
+ (name "python-pysingular")
+ (version "0.9.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "PySingular" version))
+ (sha256
+ (base32 "037n3s1l08g75k22saki6813wi3ciiq45zxca11izilgagbx20ya"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f)) ; there are no tests
+ (native-inputs (list python-setuptools python-wheel))
+ ;; XXX: GMP failed to be loaded from Singular. Pass it here for now.
+ (inputs (list gmp singular))
+ (home-page "https://github.com/sebasguts/SingularPython")
+ (synopsis "Simple interface to Singular")
+ (description "This package provides a simple Python interface to the
+Singular computer algebra system.")
+ (license license:gpl2+)))
+
(define-public gmp-ecm
(package
(name "gmp-ecm")
--
2.48.1
V
V
Vinicius Monego wrote 42 hours ago
[PATCH 11/16] gnu: m4ri: Update to 20200125.
(address . 76150@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
5650cf40c203cfa13153854def744d00d54c3774.1739064949.git.monego@posteo.net
* gnu/packages/algebra.scm (m4ri): Update to 20200125.

Change-Id: I0b6ec9c92e224fa6ac8200c8aea0abb343dae8a6
---
gnu/packages/algebra.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 6abe959343..90cee7e2ac 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1573,7 +1573,7 @@ (define-public linbox
(define-public m4ri
(package
(name "m4ri")
- (version "20140914")
+ (version "20200125")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1582,7 +1582,7 @@ (define-public m4ri
(file-name (git-file-name name version))
(sha256
(base32
- "0xfg6pffbn8r1s0y7bn9b8i55l00d41dkmhrpf7pwk53qa3achd3"))))
+ "1dxgbv6zdyki3h61qlv7003wzhy6x14zmcaz9x19md1i7ng07w1k"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf automake libtool pkg-config))
--
2.48.1
V
V
Vinicius Monego wrote 42 hours ago
[PATCH 12/16] gnu: m4rie: Update to 20200125.
(address . 76150@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
3f23458797eb21ffd9711c5fb87229be6eb7b24a.1739064949.git.monego@posteo.net
* gnu/packages/algebra.scm (m4rie): Update to 20200125.

Change-Id: I114f5c2bf3a689d8d7e66dd3a9125970852c90a6
---
gnu/packages/algebra.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 90cee7e2ac..8175589006 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1662,7 +1662,7 @@ (define-public symmetrica
(define-public m4rie
(package
(name "m4rie")
- (version "20150908")
+ (version "20200125")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1671,7 +1671,7 @@ (define-public m4rie
(file-name (git-file-name name version))
(sha256
(base32
- "0r8lv46qx5mkz5kp3ay2jnsp0mbhlqr5z2z220wdk73wdshcznss"))))
+ "078f0b4skv1bbdj0j9b397hydj7gimhfzf407nisy2zcyp2iqc3f"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf automake libtool))
--
2.48.1
V
V
Vinicius Monego wrote 42 hours ago
[PATCH 13/16] gnu: Add hpcombi.
(address . 76150@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
93ae923ef783285073180ec35ea7792336a6e7f8.1739064949.git.monego@posteo.net
* gnu/packages/maths.scm (hpcombi): New variable.

Change-Id: I64eb46aa4002a2291ae59122e083998a9c846eaf
---
gnu/packages/maths.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 44bd1b15d9..cd0a0828e1 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2976,6 +2976,32 @@ (define-public libflame
includes a complete LAPACK implementation.")
(license license:bsd-3))))
+(define-public hpcombi
+ (package
+ (name "hpcombi")
+ (version "1.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libsemigroups/hpcombi")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00mbxw5x6m61n0x68dsiyq97i7b08h3hkbj9is2w6gcg571jy319"))))
+ (arguments
+ (list #:configure-flags #~(list "-DBUILD_TESTING=ON")))
+ (native-inputs
+ (list catch2-3))
+ (build-system cmake-build-system)
+ (home-page "https://libsemigroups.github.io/HPCombi/")
+ (synopsis "Fast combinatorics in C++ using SSE/AVX instruction sets")
+ (description "HPCombi is a C++17 header-only library using the SSE and AVX
+instruction sets, and some equivalents, for very fast manipulation of
+combinatorial objects such as transformations, permutations, and boolean
+matrices of small size.")
+ (license license:gpl3+)))
+
(define-public scasp
(package
(name "scasp")
--
2.48.1
V
V
Vinicius Monego wrote 42 hours ago
[PATCH 14/16] gnu: Add libsemigroups.
(address . 76150@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
b048e8595188e90ee08a5de8f340ba6930c71f32.1739064949.git.monego@posteo.net
* gnu/packages/algebra.scm (libsemigroups): New variable.

Change-Id: I6e929fe6b479c7e7c2b5b4632759bd781af3c927
---
gnu/packages/algebra.scm | 41 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 8175589006..9da5f0124c 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -63,6 +63,7 @@ (define-module (gnu packages algebra)
#:use-module (gnu packages ocaml)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pretty-print)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
@@ -1836,6 +1837,46 @@ (define-public r-dtt
(@dfn{DHT}).")
(license license:gpl2+)))
+(define-public libsemigroups
+ (package
+ (name "libsemigroups")
+ (version "2.7.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libsemigroups/libsemigroups")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0acpx6n6chqm365k71ba6lwqqzapbh6h4wzra63p6mbgb8dw9l1f"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ ;; XXX: libsemigroup's build system doesn't have an option to use
+ ;; external HPCombi. Try to work it around in the future and skip
+ ;; support for now.
+ #:configure-flags #~(list "--enable-fmt=yes"
+ "--enable-hpcombi=no"
+ "--with-external-eigen=yes"
+ "--with-external-fmt=yes")
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-version
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "etc/version-number.sh"
+ (("/bin/sh")
+ (search-input-file inputs "/bin/bash"))))))))
+ (native-inputs
+ (list autoconf automake libtool pkg-config))
+ (inputs (list eigen fmt))
+ (home-page "https://github.com/libsemigroups/libsemigroups")
+ (synopsis "Library for semigroups and monoids")
+ (description
+ "@code{libsemigroups} is a C++14 library containing implementations of
+several algorithms for computing finite, and finitely presented,
+semigroups and monoids.")
+ (license license:gpl2+)))
+
(define-public sollya
(package
(name "sollya")
--
2.48.1
V
V
Vinicius Monego wrote 42 hours ago
[PATCH 15/16] gnu: Add plantri.
(address . 76150@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
30eb654cc83ccabe7be3a8351405d09169f974ae.1739064949.git.monego@posteo.net
* gnu/packages/graph.scm (plantri): New variable.

Change-Id: I976eb88437b47bc06d7b2c2f8703da217e85cc7e
---
gnu/packages/graph.scm | 35 ++++++++++++++++++++++++++++++++++-
1 file changed, 34 insertions(+), 1 deletion(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index c8bd25af9c..5303f2e9db 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2020 Alexander Krotov <krotov@iitp.ru>
;;; Copyright © 2020 Pierre Langlois <pierre.langlos@gmx.com>
-;;; Copyright © 2021, 2023 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021, 2023, 2025 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Alexandre Hannud Abdo <abdo@member.fsf.org>
;;; Copyright © 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
@@ -783,6 +783,39 @@ (define-public edge-addition-planarity-suite
(home-page
"https://github.com/graph-algorithms/edge-addition-planarity-suite")))
+(define-public plantri
+ (package
+ (name "plantri")
+ (version "5.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://users.cecs.anu.edu.au/~bdm/plantri/"
+ "plantri" (string-join
+ (string-split version #\.)
+ "") ".tar.gz"))
+ (sha256
+ (base32
+ "1vbxpjih293d9nmb65fsh6xgg0w12kygwycg1yw4wad7ridxy74i"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ; there are no tests
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda _
+ (for-each
+ (lambda (bin)
+ (install-file bin (string-append #$output "/bin")))
+ '("fullgen" "plantri")))))))
+ (home-page "https://users.cecs.anu.edu.au/~bdm/plantri/")
+ (synopsis "Generate certain types of planar graphs")
+ (description
+ "@code{plantri} and @code{fullgen} are programs for generation of certain
+types of planar graphs. Graphs are generated in such a way that exactly one
+member of each isomorphism class is output without the need for storing them.")
+ (license license:asl2.0)))
+
(define-public rw
(package
(name "rw")
--
2.48.1
V
V
Vinicius Monego wrote 42 hours ago
[PATCH 16/16] gnu: Add glucose.
(address . 76150@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
fd11c9b7ef03f329d9e8d3029c763df33b29f33e.1739064949.git.monego@posteo.net
* gnu/packages/maths.scm (glucose): New variable.

Change-Id: I8e9031db55aa98ddde82ea676d3287656f7c4288
---
Is it OK to use -DCMAKE_BUILD_RPATH here? I don't see anyone doing it this way, it usually has a dedicated phase but it's more verbose that way.
gnu/packages/maths.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index cd0a0828e1..1856a68d10 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2899,6 +2899,45 @@ (define-public libfixmath
fixed point (16.16) format.")
(license license:expat))))
+(define-public glucose
+ (package
+ (name "glucose")
+ (version "4.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/audemard/glucose")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0zrn4hnkf8k95dc3s3acydl1bqkr8a0axw56g7n562lx7zj7sd62"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f ; there are no tests
+ #:configure-flags
+ #~(list "-DBUILD_SHARED_LIBS=ON"
+ (string-append "-DCMAKE_BUILD_RPATH=" #$output "/lib"))
+ #:phases #~(modify-phases %standard-phases
+ (replace 'install
+ (lambda _
+ (for-each
+ (lambda (bin)
+ (install-file bin (string-append #$output "/bin")))
+ '("glucose-simp" "glucose-syrup"))
+ (for-each
+ (lambda (lib)
+ (install-file lib (string-append #$output "/lib")))
+ '("libglucose.so" "libglucosep.so")))))))
+ (inputs (list zlib))
+ (home-page "https://www.labri.fr/perso/lsimon/research/glucose/")
+ (synopsis "SAT Solver")
+ (description "Glucose is a SAT solver based on a scoring scheme introduced
+in 2009 for the clause learning mechanism of so called “Modern” SAT solvers.
+It is designed to be parallel.")
+ (license license:expat)))
+
(define-public libflame
;; The latest release (5.2.0) dates back to 2019. Use a newer one, which
;; among other things provides extra LAPACK symbols, such as 'dgemlq_'
--
2.48.1
A
A
Andreas Enge wrote 35 hours ago
Re: Fwd: [PATCH 00/16] More patches towards SageMath.
(name . Vinicius Monego)(address . monego@posteo.net)
Z6h4ORaSO2hg6zLx@jurong
Thanks for the patches! I have built and applied the first two, and will
continue working on the others as time permits, probably starting
tomorrow.

Andreas
A
A
Andreas Enge wrote 7 hours ago
(name . Vinicius Monego)(address . monego@posteo.net)
Z6oDzOB83NRJfOIl@jurong
Hello!

All packages are pushed to master now. I have changed the licence of
libsemigroups (it is gpl3+) and updated it to the latest version.
For good measure, I have also updated eclib.

Thanks for all these high quality patches!

Closing this bug report.

Andreas
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76150@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76150
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch