[PATCH] gnu: libcxx: update to 19.1.4.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hikari
  • 宋文武
Owner
unassigned
Submitted by
Hikari
Severity
normal

Debbugs page

Hikari wrote 1 months ago
(address . guix-patches@gnu.org)(name . Hikari)(address . aneris@disroot.org)
d7794501075928178a4c9790a8ce51626fe84188.1739005427.git.aneris@disroot.org
* gnu/packages/llvm.scm (libcxx): update to 19.1.4.
[native-inputs]: remove clang; add clang-19.
[native-inputs]: add libunwind-headers.
[arguments]<#:configure-flags>: add libunwind.

Change-Id: I8235077727b6f54edddc60d9bf1c4c9de93b32fe
---
gnu/packages/llvm.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 07506fa850..5f5b38ef6e 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1858,14 +1858,14 @@ (define-public lldb
(define-public libcxx
(package
(name "libcxx")
- (version (package-version llvm-15))
+ (version (package-version llvm-19))
(source (llvm-monorepo version))
(build-system cmake-build-system)
(arguments
(list
#:tests? #f
#:configure-flags
- #~(list "-DLLVM_ENABLE_RUNTIMES=libcxx;libcxxabi"
+ #~(list "-DLLVM_ENABLE_RUNTIMES=libcxx;libcxxabi;libunwind"
"-DCMAKE_C_COMPILER=clang"
"-DCMAKE_CXX_COMPILER=clang++"
;; libc++.so is actually a GNU ld style linker script, however,
@@ -1894,7 +1894,7 @@ (define-public libcxx
(getenv "CPLUS_INCLUDE_PATH"))
#t))))))
(native-inputs
- (list clang llvm python))
+ (list clang-19 libunwind-headers llvm python))
(home-page "https://libcxx.llvm.org")
(synopsis "C++ standard library")
(description

base-commit: 0c9da3dbcb47840089a0213a59c385e780317bb6
--
2.48.1
宋文武 wrote 4 weeks ago
(name . Hikari)(address . aneris@disroot.org)(address . 76145-done@debbugs.gnu.org)
87ikpeed5j.fsf@envs.net
Hikari <aneris@disroot.org> writes:

Toggle quote (2 lines)
> * gnu/packages/llvm.scm (libcxx): update to 19.1.4.

Pushed with adjusted commit message, thanks.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 76145@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76145
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help