[PATCH] gnu: guile-g-golf: Update to 0.8.0.

  • Open
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • pelzflorian (Florian Pelz)
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
A
A
Andy Tai wrote 3 days ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
09afa3a4ed10bf2dfaa3c4918d99236a26e48940.1738998193.git.atai@atai.org
* gnu/packages/guile-xyz.scm (guile-g-golf): Update to 0.8.0.

Change-Id: I625528c7c59c085f1eb6250cae472643501822e0
---
gnu/packages/guile-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 6d12ab9688..3175da0e93 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2524,7 +2524,7 @@ (define-public guile-sly
(define-public guile-g-golf
(package
(name "guile-g-golf")
- (version "0.8.0-rc9")
+ (version "0.8.0")
(source
(origin
(method git-fetch)
@@ -2533,7 +2533,7 @@ (define-public guile-g-golf
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1x340xr2ki1y3w1cg37fhjsfw27268vlsyc8hby9lmv13l349l8b"))))
+ (base32 "14b6pjchra0axqifpm90m7jbxla2sarhd7bfhzqbn7d14b74sv2d"))))
(build-system gnu-build-system)
(arguments
(list

base-commit: 5674adeb7579bdcfdb7342e6552f4735cd8f2afc
--
2.34.1
P
P
pelzflorian (Florian Pelz) wrote 2 days ago
(name . Andy Tai)(address . atai@atai.org)(address . 76139@debbugs.gnu.org)
87r0483rop.fsf@pelzflorian.de
Andy Tai <atai@atai.org> writes:
Toggle quote (2 lines)
> * gnu/packages/guile-xyz.scm (guile-g-golf): Update to 0.8.0.

Thank you for the patch!

LGTM, except the clutter input is no longer required for tests. Could
you remove it?

I currently do not have a trusted machine at hand and cannot push your
patch for a few days. Could someone else push Andy’s patch when the
clutter input is removed?

This is the only relevant difference to the previous version 0.8.0-rc9
that I found from looking at the diff.

Most G-Golf examples shipped with $(guix build --source guile-g-golf)
work fine with your patch, except layout-manager-2 (which also did not
work before at 0.8.0-rc9), and the Adwaita demo example needs some
modifications to paths, but since you do not package the examples, I
don’t think there is a fault at your package. If someone wants to run
G-Golf’s examples:

Running the GTK examples is hindered by bug
https://bugs.gnu.org/75157 since December 2024.

To work around it in development environments, use
`guix shell --no-grafts`.

E.g. to run the examples,

guix shell --no-grafts guile-g-golf gtk graphene libadwaita guile-cairo --development guile-g-golf

The animated-paintable, simple-paintable examples cannot be run, because
as described in the example source code, they need instead a guile-cairo
that is newer than the latest release.

(define-public guile-cairo-next
(package
(inherit guile-cairo)
(source (origin
(method git-fetch)
(uri (git-reference
(url "git://git.savannah.nongnu.org/guile-cairo.git")
(commit "30da459d7a4380174ff243b1560d5512a4bca86e")))
(sha256
(base32
"0dslfldzgxis8g0g3xaffcqnd1njzz23fjy0v3lc0r2694ra4ny4"))
(file-name (string-append "guile-cairo-next"))))
(inputs
(list guile-lib expat guile-3.0 gettext-minimal))
(native-inputs
(list autoconf-2.71 automake libtool pkg-config texinfo))))



(When security updates are desired for use in production environments,
instead of --no-grafts, set GI_TYPELIB_PATH to ungraft like guix.git’s
etc/manifests/ungraft.scm as described at bug#75157 above, but that
takes days to build.)

Regards,
Florian
A
A
Andy Tai wrote 47 hours ago
[PATCH v2] gnu: guile-g-golf: Update to 0.8.0.
(address . 76139@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
4b87c8e3594b7f21b4ed078b6f437b760fa195f5.1739076643.git.atai@atai.org
* gnu/packages/guile-xyz.scm (guile-g-golf): Update to 0.8.0.
[native-inputa]: Remove clutter.

Change-Id: I625528c7c59c085f1eb6250cae472643501822e0
---
gnu/packages/guile-xyz.scm | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 6d12ab9688..060446715e 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2524,7 +2524,7 @@ (define-public guile-sly
(define-public guile-g-golf
(package
(name "guile-g-golf")
- (version "0.8.0-rc9")
+ (version "0.8.0")
(source
(origin
(method git-fetch)
@@ -2533,7 +2533,7 @@ (define-public guile-g-golf
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1x340xr2ki1y3w1cg37fhjsfw27268vlsyc8hby9lmv13l349l8b"))))
+ (base32 "14b6pjchra0axqifpm90m7jbxla2sarhd7bfhzqbn7d14b74sv2d"))))
(build-system gnu-build-system)
(arguments
(list
@@ -2593,7 +2593,6 @@ (define-public guile-g-golf
pkg-config
;; required for tests
gtk+
- clutter
xorg-server-for-tests))
(propagated-inputs
(list gobject-introspection))

base-commit: 5674adeb7579bdcfdb7342e6552f4735cd8f2afc
--
2.34.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76139@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76139
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch