[PATCH] gnu: emacs-stgit: Fix install location.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan Smith
  • Ian Eure
Owner
unassigned
Submitted by
Morgan Smith
Severity
normal

Debbugs page

Morgan Smith wrote 1 months ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
CH3PR84MB342411B75CF05B5614880A8DC5F02@CH3PR84MB3424.NAMPRD84.PROD.OUTLOOK.COM
* gnu/packages/version-control.scm (emacs-stgit): Previously the files got
installed under a "contrib" sub-directory that does not work with our Emacs
configuration. This fixes that.

Change-Id: Ic7c237476fd18f73dbfbde3368ceae4962ba9634
---
gnu/packages/version-control.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 6e139e75d4..bc99d6bdfd 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2123,7 +2123,12 @@ (define-public emacs-stgit
(name "emacs-stgit")
(build-system emacs-build-system)
(arguments
- (list #:include '(list "contrib/stgit.el")))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'enter-lisp-directory
+ (lambda _
+ (chdir "contrib"))))))
(synopsis "Emacs major mode for StGit interaction")
(description "This package a interactive tool to interact with git
branches using StGit.")
--
2.48.1
Ian Eure wrote 1 months ago
(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)(address . 76138@debbugs.gnu.org)
87seonykay.fsf@retrospec.tv
Hi Morgan,

Morgan Smith <Morgan.J.Smith@outlook.com> writes:

Toggle quote (7 lines)
> * gnu/packages/version-control.scm (emacs-stgit): Previously the
> files got
> installed under a "contrib" sub-directory that does not work
> with our Emacs
> configuration. This fixes that.
>

This part of the patch looks good, but I noticed that the
/usr/share/doc directory (which contains the license) is no longer
included. Could you send a v2 which restores it, please?

Thanks,
-- Ian
Morgan Smith wrote 1 months ago
[PATCH v2] gnu: emacs-stgit: Fix install location.
(address . ian@retrospec.tv)
CH3PR84MB3424F7BBFA459D31F0786721C5F32@CH3PR84MB3424.NAMPRD84.PROD.OUTLOOK.COM
* gnu/packages/version-control.scm (emacs-stgit): Previously the files got
installed under a "contrib" sub-directory that does not work with our Emacs
configuration. This fixes that.

Change-Id: Ic7c237476fd18f73dbfbde3368ceae4962ba9634
---
gnu/packages/version-control.scm | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 6e139e75d4..fc1ccdca38 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2123,7 +2123,15 @@ (define-public emacs-stgit
(name "emacs-stgit")
(build-system emacs-build-system)
(arguments
- (list #:include '(list "contrib/stgit.el")))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'enter-lisp-directory
+ (lambda _
+ (chdir "contrib")))
+ (add-before 'install-license-files 'leave-lisp-directory
+ (lambda _
+ (chdir ".."))))))
(synopsis "Emacs major mode for StGit interaction")
(description "This package a interactive tool to interact with git
branches using StGit.")
--
2.48.1
Ian Eure wrote 1 months ago
control message for bug #76138
(address . control@debbugs.gnu.org)
871pw6wg15.fsf_-_@retrospec.tv
close 76138
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 76138@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76138
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help