Morgan Smith wrote 1 months ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
* gnu/packages/version-control.scm (emacs-stgit): Previously the files got
installed under a "contrib" sub-directory that does not work with our Emacs
configuration. This fixes that.
Change-Id: Ic7c237476fd18f73dbfbde3368ceae4962ba9634
---
gnu/packages/version-control.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)
Toggle diff (20 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 6e139e75d4..bc99d6bdfd 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2123,7 +2123,12 @@ (define-public emacs-stgit
(name "emacs-stgit")
(build-system emacs-build-system)
(arguments
- (list #:include '(list "contrib/stgit.el")))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'enter-lisp-directory
+ (lambda _
+ (chdir "contrib"))))))
(synopsis "Emacs major mode for StGit interaction")
(description "This package a interactive tool to interact with git
branches using StGit.")
--
2.48.1