imp@2.15.0 fails to build

  • Done
  • quality assurance status badge
Details
2 participants
  • Ricardo Wurmus
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 1 months ago
(address . bug-guix@gnu.org)(address . rekado@elephly.net)
87frksgkpp.fsf@gmail.com
Hi,

While refreshing python-feature which is in the first level of
dependencies for imp I noticed it has failed to build.


Toggle snippet (13 lines)
In file included from /tmp/guix-build-imp-2.15.0.drv-0/imp-2.15.0/modules/kernel/src/Model_evaluate.cpp:21,
from /tmp/guix-build-imp-2.15.0.drv-0/build/src/kernel_all.cpp:13:
/gnu/store/wjcwaddsgzibk7vyk3q256bax5yfwsbn-boost-1.83.0/include/boost/timer.hpp:21:3: error: #error This header is deprecated and will be removed. (You can define BOOST_TIMER_ENABLE_DEPRECATED to suppress this error.)
21 | # error This header is deprecated and will be removed. (You can define BOOST_TIMER_ENABLE_DEPRECATED to suppress this error.)
| ^~~~~
In file included from /tmp/guix-build-imp-2.15.0.drv-0/imp-2.15.0/modules/kernel/src/internal/base_static.h:19,
from /tmp/guix-build-imp-2.15.0.drv-0/imp-2.15.0/modules/kernel/src/base_utility.cpp:11,
from /tmp/guix-build-imp-2.15.0.drv-0/build/src/kernel_all.cpp:33:
/gnu/store/wjcwaddsgzibk7vyk3q256bax5yfwsbn-boost-1.83.0/include/boost/progress.hpp:23:3: error: #error This header is deprecated and will be removed. (You can define BOOST_TIMER_ENABLE_DEPRECATED to suppress this error.)
23 | # error This header is deprecated and will be removed. (You can define BOOST_TIMER_ENABLE_DEPRECATED to suppress this error.)
| ^~~~~

Toggle snippet (8 lines)
guix describe
Generation 75 Feb 03 2025 21:37:27 (current)
guix 2574ae3
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: 2574ae3733637ead786fb3dc454369590794bc51

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmej1CIACgkQdtcnv/Ys
0rUrag/7B/4Yyb9c7etm0A2JF2RkkG4HGvjbYb8J6GA9WUJ4tJxoF9bugJ0KlrXE
znXXf8h4zxOn7gN3c+PdKfYwGUZYC09hGqcx2xT+ZfM3uGrsrCUDs0PUf0Q8xbF1
l4aBAxOHEGzZf0GF3g8h/KuOkZDCBLzOhgM/Dtf/Vt22O9NYk/D0JPT1fUj5eut3
eZo51vxTzn7Gz7XHVgTuw1ISk3vVdRU/et6+giAhFfHLlOVEe7v5lZ8omjza9cIj
vK0R1/RhDl4BS663FxCFFzWp0VYWGgVt/Vg1Q4Txpjn10/R8/mGjRQrHTv/zwnoB
XurfSq0ELGhxZSewMLhA4L8X5npR4FKjXOR6qN/ULmO6tCM8hXIgyVmpD19RMgZl
B6gglReU6Q4FCvUlHHvBx7INHvbncKHJuRrSJBu4w9PbVfGE7FclwKktPAjx3EQJ
M88IJakmfIQ1ix5y6XKEblKSZjO91BxLPAelWpNnWpiMMeLEXlbU6NiHLYkNCzwi
PqaWEn1MHQAfWDx53rbxMz6k49Pd2884Jiu45bXEcZzQeeu1UBvFUyn8Wf72gVJ3
TB6s/PaoG2q3JrRxgwuEzhxJ2jCu0dYJrX9wbWj6Qc1YL4np736Tis1tq93a+T9T
+NGxQHVAMoK/i+Q4tP47WswnjJH67moUR3iYxs7PydP1jBZioyw=
=tLoB
-----END PGP SIGNATURE-----

Ricardo Wurmus wrote 1 months ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 76079@debbugs.gnu.org)
875xlnjr6r.fsf@elephly.net
Here's what I tried:
From 475248bfaafcb122676460383705f72ccb050adb Mon Sep 17 00:00:00 2001
Message-ID: <475248bfaafcb122676460383705f72ccb050adb.1738837944.git.rekado@elephly.net>
From: Ricardo Wurmus <rekado@elephly.net>
Date: Thu, 6 Feb 2025 11:27:17 +0100
Subject: [PATCH 1/2] gnu: imp: Drop input labels.

* gnu/packages/bioinformatics.scm (imp)[native-inputs]: Drop labels.

Change-Id: I3182a4608a88c59ba0de2fa00d74b8d72b72d8bb
---
gnu/packages/bioinformatics.scm | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4ef4f6788f..16038a7c74 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -15768,8 +15768,7 @@ (define-public imp
"-E" (format #f "'(~a)'" (string-join disabled-tests "|")))
";"))))))
(native-inputs
- `(("python" ,python-wrapper)
- ("swig" ,swig)))
+ (list python-wrapper swig))
(inputs
(list boost
cgal

base-commit: 0c9da3dbcb47840089a0213a59c385e780317bb6
--
2.48.1
From 7786b4e477b888cda42cffd764aacea705631dc1 Mon Sep 17 00:00:00 2001
Message-ID: <7786b4e477b888cda42cffd764aacea705631dc1.1738837944.git.rekado@elephly.net>
In-Reply-To: <475248bfaafcb122676460383705f72ccb050adb.1738837944.git.rekado@elephly.net>
References: <475248bfaafcb122676460383705f72ccb050adb.1738837944.git.rekado@elephly.net>
From: Ricardo Wurmus <rekado@elephly.net>
Date: Thu, 6 Feb 2025 11:29:23 +0100
Subject: [PATCH 2/2] gnu: imp: Use an older version of boost.

* gnu/packages/bioinformatics.scm (imp):[inputs]: Replace boost with
boost-for-mysql.

Change-Id: I3d3bec8589972f15770c264f4b2445f4798b7901
---
gnu/packages/bioinformatics.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 16038a7c74..b64baaf463 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -15770,7 +15770,7 @@ (define-public imp
(native-inputs
(list python-wrapper swig))
(inputs
- (list boost
+ (list boost-for-mysql
cgal
gsl
hdf5
--
2.48.1
Haven't been able to build it yet, because my laptop runs out of memory,
but it might be enough to fix this.

Merely defining BOOST_TIMER_ENABLE_DEPRECATED=TRUE is not enough to make
it build with the current version of Boost. I tried this before:

Toggle snippet (8 lines)
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'patch-build-system
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("if\\(IMP_STATIC\\)" m)
+ (string-append "add_definitions(-DBOOST_TIMER_ENABLE_DEPRECATED=TRUE)\n" m))))))))

--
Ricardo
Ricardo Wurmus wrote 1 months ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 76079-done@debbugs.gnu.org)
87wme3ia0i.fsf@elephly.net
I pushed my changes to the master branch, because imp built fine with them.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 76079@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76079
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help