[PATCH] gnu: Add python-cnmf.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 1 months ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
7fabab03035a0614a41803ad33f47b1f8a4451df.1738772458.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-cnmf): New variable.

Change-Id: I8a4f2293bde59b10e7b673025bbb4c5a8420738b
---
gnu/packages/bioinformatics.scm | 43 +++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 317c15817e..7566346df1 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2581,6 +2581,49 @@ (define-public python-cmseq
and sequence consensus.")
(license license:expat)))
+(define-public python-cnmf
+ (package
+ (name "python-cnmf")
+ (version "1.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cnmf" version))
+ (sha256
+ (base32 "0aic8cwj6riykcfgl6v2x3si5z04gaknkh5a8lcyv1qh4s1gx3d3"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #f ;There are no tests
+ #:phases '(modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _
+ (setenv "MPLCONFIGDIR" "/tmp")))
+ ;; Numba needs a writable dir to cache functions.
+ (add-before 'build 'set-numba-cache-dir
+ (lambda _
+ (setenv "NUMBA_CACHE_DIR" "/tmp"))))))
+ (propagated-inputs (list python-anndata
+ python-fastcluster
+ python-matplotlib
+ python-numba
+ python-numpy
+ python-palettable
+ python-pandas
+ python-pyyaml
+ python-scanpy
+ python-scikit-learn
+ python-scipy))
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://github.com/dylkot/cNMF")
+ (synopsis "Consensus NMF for scRNA-Seq data")
+ (description
+ "This tool offers a pipeline for inferring gene expression programs from scRNA-Seq.
+It takes a count matrix (N cells X G genes) as input and produces a (K x G) matrix of
+gene expression programs (GEPs) and a (N x K) matrix specifying the usage of each
+program for each cell in the data.")
+ (license license:expat)))
+
(define-public python-cyvcf2
(package
(name "python-cyvcf2")

base-commit: 49a113e3fc618d6f6bd5000c164a1d33701a30c4
--
2.43.0
Sharlatan Hellseher wrote 1 months ago
(address . 76073-done@debbugs.gnu.org)
874j18i8il.fsf@gmail.com
Hi,

Thank you for the patch.

I've applied some cosmetic adjustments:

Toggle snippet (62 lines)
@@ -2596,34 +2596,36 @@ (define-public python-cnmf
(build-system pyproject-build-system)
(arguments
(list
- #:tests? #f ;There are no tests
- #:phases '(modify-phases %standard-phases
- (add-before 'check 'pre-check
- (lambda _
- (setenv "MPLCONFIGDIR" "/tmp")))
- ;; Numba needs a writable dir to cache functions.
- (add-before 'build 'set-numba-cache-dir
- (lambda _
- (setenv "NUMBA_CACHE_DIR" "/tmp"))))))
- (propagated-inputs (list python-anndata
- python-fastcluster
- python-matplotlib
- python-numba
- python-numpy
- python-palettable
- python-pandas
- python-pyyaml
- python-scanpy
- python-scikit-learn
- python-scipy))
- (native-inputs (list python-setuptools python-wheel))
+ #:tests? #f ; no tests in git checkout and PyPI archive
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'set-envs
+ (lambda _
+ (setenv "MPLCONFIGDIR" "/tmp")
+ ;; Numba needs a writable dir to cache functions.
+ (setenv "NUMBA_CACHE_DIR" "/tmp"))))))
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-anndata
+ python-fastcluster
+ python-matplotlib
+ python-numba
+ python-numpy
+ python-palettable
+ python-pandas
+ python-pyyaml
+ python-scanpy
+ python-scikit-learn
+ python-scipy))
(home-page "https://github.com/dylkot/cNMF")
(synopsis "Consensus NMF for scRNA-Seq data")
(description
- "This tool offers a pipeline for inferring gene expression programs from scRNA-Seq.
-It takes a count matrix (N cells X G genes) as input and produces a (K x G) matrix of
-gene expression programs (GEPs) and a (N x K) matrix specifying the usage of each
-program for each cell in the data.")
+ "This tool offers a pipeline for inferring gene expression programs from
+scRNA-Seq. It takes a count matrix (N cells X G genes) as input and produces
+a (K x G) matrix of gene expression programs (GEPs) and a (N x K) matrix
+specifying the usage of each program for each cell in the data.")
(license license:expat)))

Pushed to master as 985c0fd63c1f0c1f2ab8adaac3109ccdad258a28

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmejpWIACgkQdtcnv/Ys
0rU5xw/9HOE/BwwVFiFpC87mnTF0URAg8x9q56KxeUioSa+AAoWwJosZFzLwLXSK
kXJSYuvk5Ygd9CwLURE1B5Ax+EvryeOdeIT/SjjwPUoaWlOMuHPxnUq4DU8kPOK2
VK5Fhbugua/OwApFFWsGHPxixNe2/JLrkDRmP3fFCFNPEc6kPggXIQNXTDlpFRKW
A5DbyIe7LAvGtuhQl/1KOfxom6Ss2Q/VuA5ZGk/bGEy1Q/bv6c04uaSFGLHoSrNr
WP3iOzhAci7f5BVX0B6NCLJHefgqnL2TDuQj9M5tSj+QGvI9ido6g+SMrj2Ven51
g6M3W/6FY0OZt+WX7Biprr3K/ntnavCqsNH/tQqeB+P6XxnS1E8n9qelThdc7UU2
VJsDsy7cqW0ZVw6zqEln7D9lxG+nuyYVyWoMEZ0iNjv0p/gNjgC+xv2wOGrnsJaz
eWjrqtnrIc8R56S8nW92qQZodbrrrWVqMXWddxV+g99VhBohkA546qB4geyPjHEJ
6zP1ilf6SxYx03tLrOHd8oyjreKW9Vcc6VdsWI8vJc0SyqzDgBV9JjgLbmTBf0Yg
gtCYbWS8y5seSevRtaYL1ctboqcroAl3PqY9o1EclV3u3F98062wWM4hiK0qlt9b
HqAWAuY/pCA2lhhBsMzq4WrauFe0ZWT4kHtA08/iCHPX7d/1Gac=
=z3Bc
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 76073@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76073
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help