Navid Afkhami wrote 1 months ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
* gnu/packages/bioinformatics.scm (python-cnmf): New variable.
Change-Id: I8a4f2293bde59b10e7b673025bbb4c5a8420738b
---
gnu/packages/bioinformatics.scm | 43 +++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)
Toggle diff (58 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 317c15817e..7566346df1 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2581,6 +2581,49 @@ (define-public python-cmseq
and sequence consensus.")
(license license:expat)))
+(define-public python-cnmf
+ (package
+ (name "python-cnmf")
+ (version "1.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cnmf" version))
+ (sha256
+ (base32 "0aic8cwj6riykcfgl6v2x3si5z04gaknkh5a8lcyv1qh4s1gx3d3"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #f ;There are no tests
+ #:phases '(modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _
+ (setenv "MPLCONFIGDIR" "/tmp")))
+ ;; Numba needs a writable dir to cache functions.
+ (add-before 'build 'set-numba-cache-dir
+ (lambda _
+ (setenv "NUMBA_CACHE_DIR" "/tmp"))))))
+ (propagated-inputs (list python-anndata
+ python-fastcluster
+ python-matplotlib
+ python-numba
+ python-numpy
+ python-palettable
+ python-pandas
+ python-pyyaml
+ python-scanpy
+ python-scikit-learn
+ python-scipy))
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://github.com/dylkot/cNMF")
+ (synopsis "Consensus NMF for scRNA-Seq data")
+ (description
+ "This tool offers a pipeline for inferring gene expression programs from scRNA-Seq.
+It takes a count matrix (N cells X G genes) as input and produces a (K x G) matrix of
+gene expression programs (GEPs) and a (N x K) matrix specifying the usage of each
+program for each cell in the data.")
+ (license license:expat)))
+
(define-public python-cyvcf2
(package
(name "python-cyvcf2")
base-commit: 49a113e3fc618d6f6bd5000c164a1d33701a30c4
--
2.43.0