[PATCH 0/3] hypr* updates

  • Open
  • quality assurance status badge
Details
One participant
  • Murilo
Owner
unassigned
Submitted by
Murilo
Severity
normal
M
M
Murilo wrote 5 hours ago
(address . guix-patches@gnu.org)(name . Murilo)(address . murilo@disroot.org)
cover.1738755962.git.murilo@disroot.org
This patch series updates the hypr* packages to their latest upstream versions.

Relevant changes:
spng is now a dependency of hyprgraphics.

Checks done:

$ guix shell -D guix -CPW -- ./pre-inst-env guix build \
--rounds=2 \
--dependents hyprland-protocols \
--dependents hyprland \
--dependents hyprgraphics
guix build: computing dependents of package hyprland-protocols@0.6.2...
guix build: computing dependents of package hyprland@0.47.2...
guix build: computing dependents of package hyprgraphics@0.1.2...
/gnu/store/9mf4v09kd0j33mpmy5hdqs4y6bvf198j-hyprland-protocols-0.6.2
/gnu/store/ynsamhdfxa9dkxk823skz7a5k7igs3zv-xdg-desktop-portal-hyprland-1.3.9
/gnu/store/90x8mqrqfpp1yig2rnrbgqr1bkkjibpq-hyprland-0.47.2
/gnu/store/xgmsisf3ag3y0awbi70r0iqwr5rrp4qx-grimblast-0.1-1.9d67858
/gnu/store/90x8mqrqfpp1yig2rnrbgqr1bkkjibpq-hyprland-0.47.2
/gnu/store/ynsamhdfxa9dkxk823skz7a5k7igs3zv-xdg-desktop-portal-hyprland-1.3.9
/gnu/store/xgmsisf3ag3y0awbi70r0iqwr5rrp4qx-grimblast-0.1-1.9d67858
/gnu/store/mqfwkwbpxjfg4cm9n1xix3x3a2xc09pb-hyprgraphics-0.1.2
/gnu/store/90x8mqrqfpp1yig2rnrbgqr1bkkjibpq-hyprland-0.47.2
/gnu/store/ynsamhdfxa9dkxk823skz7a5k7igs3zv-xdg-desktop-portal-hyprland-1.3.9
/gnu/store/xgmsisf3ag3y0awbi70r0iqwr5rrp4qx-grimblast-0.1-1.9d67858
*** OK ***

$ guix pull --url=$(pwd) --profile=/tmp/guix.hyprland-update --branch=hyprland-update
*** OK ***

Murilo (3):
gnu: hyprland-protocols: Update to 0.6.2.
gnu: hyprland: Update to 0.47.2.
gnu: hyprgraphics: Update to 0.1.2.

gnu/packages/cpp.scm | 7 ++++---
gnu/packages/freedesktop.scm | 4 ++--
gnu/packages/wm.scm | 4 ++--
3 files changed, 8 insertions(+), 7 deletions(-)


base-commit: 9c36d38614079611aebe4721b9e087f98e57b1b3
--
2.48.1
M
M
Murilo wrote 5 hours ago
[PATCH 1/3] gnu: hyprland-protocols: Update to 0.6.2.
(address . 76068@debbugs.gnu.org)
39991c1001cfafb06473ea4758211eb4a3aed971.1738755962.git.murilo@disroot.org
* gnu/packages/freedesktop.scm (hyprland-protocols): Update to 0.6.2.

Change-Id: Ib541990c32822714681ae9f88c547a6802dc39fd
---
gnu/packages/freedesktop.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index a9a518cd3c..95d3742074 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1367,7 +1367,7 @@ (define-public python-pyxdg
(define-public hyprland-protocols
(package
(name "hyprland-protocols")
- (version "0.6.1")
+ (version "0.6.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1376,7 +1376,7 @@ (define-public hyprland-protocols
(file-name (git-file-name name version))
(sha256
(base32
- "01nlkznq9gkkz3q2y1m1q5v4rz0qdrxsngxbnpxarnmbg4is18lm"))))
+ "17044wvfgcj7sks1dvhsbycp3ls82g1wadi3hzd6n9bhpszrpzz6"))))
(build-system meson-build-system)
(home-page "https://github.com/hyprwm/hyprland-protocols")
(synopsis "Wayland protocol extensions for Hyprland")
--
2.48.1
M
M
Murilo wrote 5 hours ago
[PATCH 2/3] gnu: hyprland: Update to 0.47.2.
(address . 76068@debbugs.gnu.org)
d6093f7e19164047e95c92c768abaad82855f527.1738755962.git.murilo@disroot.org
* gnu/packages/wm.scm (hyprland): Update to 0.47.2.

Change-Id: Ifb80559076de305d28396025931de7450903f05f
---
gnu/packages/wm.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index dbec72698a..03f1dd7ab9 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -360,7 +360,7 @@ (define-public hypridle
(define-public hyprland
(package
(name "hyprland")
- (version "0.47.1")
+ (version "0.47.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/hyprwm/Hyprland"
@@ -377,7 +377,7 @@ (define-public hyprland
"subprojects"))))
(sha256
(base32
- "1k59aqny2bhfx5jw8yp0h8gqwxyrbvx9cp9pnsxhd4cgxk9fp2h5"))))
+ "1srgzg94978alv16wnx3r973rjwhph8781apzpr9q514kry49x77"))))
(build-system cmake-build-system)
(arguments
(list #:cmake cmake-3.30
--
2.48.1
M
M
Murilo wrote 5 hours ago
[PATCH 3/3] gnu: hyprgraphics: Update to 0.1.2.
(address . 76068@debbugs.gnu.org)
b2afdc0be49081389cc140d8baa0b9baa7c0369e.1738755962.git.murilo@disroot.org
* gnu/packages/cpp.scm (hyprgraphics): Update to 0.1.2.
[inputs]: Add spng.

Change-Id: I96485190b025e29c9f7f8cd3efd8a04c44f63543
---
gnu/packages/cpp.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 3e6da27fc5..c6c63d3ffc 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -673,7 +673,7 @@ (define-public google-highway
(define-public hyprgraphics
(package
(name "hyprgraphics")
- (version "0.1.1")
+ (version "0.1.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -684,7 +684,7 @@ (define-public hyprgraphics
(snippet #~(substitute* "CMakeLists.txt" (("libjxl_cms") "")))
(sha256
(base32
- "19vk1c1hli5921ai3ik6pbyixih7fhn1010injxi8dpjak6cjlhl"))))
+ "1ah29rrxhkds4wmw0n1id9ibg1xjqg3n54n40b0qas1y9jiqbbak"))))
(build-system cmake-build-system)
(native-inputs (list gcc-14 pkg-config))
(arguments (list #:cmake cmake-3.30))
@@ -693,7 +693,8 @@ (define-public hyprgraphics
libjpeg-turbo
libjxl
libwebp
- pixman))
+ pixman
+ spng))
(home-page "https://wiki.hyprland.org/Hypr-Ecosystem/hyprgraphics/")
(synopsis "Hyprland graphics/resource utilities")
(description
--
2.48.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76068@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76068
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch