* gnu/packages/emacs-xyz.scm (emacs-magit): Update to 4.3.0.
[propagated-inputs]: Add emacs-llama, and remove emacs-dash.
Change-Id: I7a7f24c066b01ceee24f9638f85105d4dc7827a6
---
Hi,
Thanks for the review. I've also updated the commit message which did not meet standards.
gnu/packages/emacs-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
Toggle diff (33 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0afef8ac9e..78d12787d5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1823,7 +1823,7 @@ (define-public emacs-llm
(define-public emacs-magit
(package
(name "emacs-magit")
- (version "4.2.0")
+ (version "4.3.0")
(source
(origin
(method git-fetch)
@@ -1832,7 +1832,7 @@ (define-public emacs-magit
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0zmrd6xlrvlr0i1a75xwlknmyx4hvpfxaqjkl61n12gd8598ji1j"))))
+ (base32 "1xz68154qmik4xs3ldl1gv87rb3famgd73k0174xbsr48d40ccyg"))))
(build-system emacs-build-system)
(arguments
(list
@@ -1897,7 +1897,7 @@ (define-public emacs-magit
(propagated-inputs
;; Note: the 'git-commit' and 'magit-section' dependencies are part of
;; magit itself.
- (list emacs-compat emacs-dash emacs-transient emacs-with-editor))
+ (list emacs-compat emacs-transient emacs-with-editor emacs-llama))
(home-page "https://magit.vc/")
(synopsis "Emacs interface for the Git version control system")
(description
--
2.48.1