[PATCH] gnu: hurd: Add libpciaccess-static.

  • Done
  • quality assurance status badge
Details
One participant
  • iyzsong
Owner
unassigned
Submitted by
iyzsong
Severity
normal

Debbugs page

iyzsong wrote 1 months ago
(address . guix-patches@gnu.org)(name . 宋文武)(address . iyzsong@member.fsf.org)
e98201f2c73dbe0a5433fd1e6bf28cef6e0c30bf.1738669418.git.iyzsong@member.fsf.org
From: 宋文武 <iyzsong@member.fsf.org>

This is a followup to 20a8d796f1e8ed3f2ff3344fcf4ab40a45bc3942, which broke
hurd.

* gnu/packages/hurd.scm (libpciaccess-static): New variable.
(hurd, netdde) [inputs]: Replace libpciaccess with libpciaccess-static.

Change-Id: Ifb2cc3d210cf4ce6f4798eac1e9643f1c75ba6fa
---
gnu/packages/hurd.scm | 15 +++++++++++++--
1 file changed, 13 insertions(+), 2 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 7a7f621e40..1045be31a3 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -311,6 +311,17 @@ (define %import-from-dde
(define %add-to-hurd-subdirs
(list "libmachdevdde" "libddekit"))
+;;; A static libpciaccess is required by hurd and netdde.
+(define libpciaccess-static
+ (package
+ (inherit libpciaccess)
+ (arguments
+ (substitute-keyword-arguments (package-arguments libpciaccess)
+ ((#:configure-flags flags)
+ #~(cons "-Ddefault_library=static" #$flags))))
+ (propagated-inputs
+ (list zlib (list zlib "static")))))
+
(define-public hurd
(package
(name "hurd")
@@ -572,7 +583,7 @@ (define-public hurd
`(("libgcrypt" ,libgcrypt) ;for /hurd/random
("libdaemon" ,libdaemon) ;for /bin/console --daemonize
("unifont" ,unifont)
- ("libpciaccess" ,libpciaccess)
+ ("libpciaccess" ,libpciaccess-static)
;; For NFS support
("libtirpc" ,libtirpc/hurd)
@@ -700,7 +711,7 @@ (define-public netdde
(install-file "netdde" hurd)
(install-file "netdde.static" hurd)))))))
(inputs
- (list hurd libpciaccess zlib `(,zlib "static")))
+ (list hurd libpciaccess-static zlib `(,zlib "static")))
(native-inputs
`(("coreutils" ,coreutils)
("gawk" ,gawk)

base-commit: 4fa41a04802c43dc4c064b7ac4c2e6a4e92f63b6
--
2.48.1
宋文武 wrote 1 months ago
(address . 76049-done@debbugs.gnu.org)(name . 宋文武)(address . iyzsong@member.fsf.org)(name . Janneke Nieuwenhuizen)(address . janneke@gnu.org)
8734gtq0z5.fsf@envs.net
Pushed to master, thanks.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 76049@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76049
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help