PyPy is Broken

  • Open
  • quality assurance status badge
Details
One participant
  • jgart
Owner
unassigned
Submitted by
jgart
Severity
normal
J
J
jgart wrote 5 days ago
(address . bug-guix@gnu.org)
fdb3b571ff08b0d2367086b56dc28ca9e150bffa@dismail.de
Hi,

I am reporting a bug that PyPy is broken on Guix and so users are aware that you can't currently use PyPy properly in a guix shell with Guix.

How do you reproduce this issue?

Run the following:

make -j6 && ./pre-inst-env guix shell pypy python-django strace ltrace

ltrace -e getenv pypy -c "import django"

Observe the following PYTHONPATH

libpypy3.10-c.so->getenv("PYTHONPATH") = nil

If instead I run the following commands I don't get an error response from ltrace:

make -j6 && ./pre-inst-env guix shell python-wrapper python-django strace ltrace

ltrace -e getenv python -c "import django"

all the best,

jgart

ps

Not sure when I can prioritize fixing this.

I am thinking that it might not be as trivial as setting the native-search-paths in the pypy package record.

I tried already and it didn't resolve the python paths.

My hypothesis is that the python-build-system or pyproject-build-system makes assumptions that are not compatible with how pypy sets and looks up paths.

I'll have to do some more experiments to find out more about that.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76027@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76027
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch