[PATCH] gnu: Add tree-sitter-sway.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan Smith
  • Ian Eure
Owner
unassigned
Submitted by
Morgan Smith
Severity
normal

Debbugs page

Morgan Smith wrote 1 months ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
CH3PR84MB3424EAFDD8F943A26474BAA6C5F52@CH3PR84MB3424.NAMPRD84.PROD.OUTLOOK.COM
* gnu/packages/tree-sitter.scm (tree-sitter-sway): New variable.

Change-Id: I9fef1bd6ac75bc16aa712e9e5455bb64a66bfc28
---
gnu/packages/tree-sitter.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (20 lines)
diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
index 1fcc5533c9..3f3f8cd16b 100644
--- a/gnu/packages/tree-sitter.scm
+++ b/gnu/packages/tree-sitter.scm
@@ -676,6 +676,13 @@ (define-public tree-sitter-scheme
#:repository-url "https://github.com/6cdh/tree-sitter-scheme"
#:commit commit)))
+(define-public tree-sitter-sway
+ (tree-sitter-grammar
+ "sway" "Sway"
+ "016zq8jbyy0274qyr38f6kvvllzgni0w7742vlbkmpv8d2blr7xj"
+ "1.0.0"
+ #:repository-url "https://github.com/FuelLabs/tree-sitter-sway"))
+
(define-public tree-sitter-racket
;; No tags
(let ((commit "1a5df0206b25a05cb1b35a68d2105fc7493df39b")
--
2.48.1
Ian Eure wrote 4 weeks ago
control message for bug #76021
(address . control@debbugs.gnu.org)
871pw3ubjt.fsf@retrospec.tv
close 76021
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76021@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76021
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help