(address . guix-patches@gnu.org)
[PATCH python-team] Add python-num2words python-ebaysdk
A
[PATCH python-team] Add python-ebaysdk
(address . 76006@debbugs.gnu.org)
1c1de840-a83a-45d9-a1fe-be173844b973@riseup.net
From 9dabb3a76c0e7a379b60f9638e934031260e9de4 Mon Sep 17 00:00:00 2001
Message-Id: <9dabb3a76c0e7a379b60f9638e934031260e9de4.1738493189.git.adriano_peluso@riseup.net>
From: Adriano Peluso <adriano_peluso@riseup.net>
Date: Sun, 2 Feb 2025 11:07:11 +0100
Subject: [PATCH 1/2] gnu: Add python-ebaysdk
* gnu/packages/python-web.scm (python-ebaysdk): New variable
Change-Id: Ie840cfa13486dc44666f8ab6f29139d4fe413d06
---
gnu/packages/python-web.scm | 28 +++++++++++++++++++++++++++-
1 file changed, 27 insertions(+), 1 deletion(-)
Toggle diff (44 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d17b61f29f..3df8aa4496 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1,4 +1,4 @@
-;;; GNU Guix --- Functional package management for GNU
+;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2015-2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
@@ -10671,3 +10671,29 @@ (define-public python-waybackpack
"This package provides a library and a command-line tool that lets
you download the entire Wayback Machine archive for a given URL.")
(license license:expat)))
+
+(define-public python-ebaysdk
+ (package
+ (name "python-ebaysdk")
+ (version "2.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ebaysdk" version))
+ (sha256
+ (base32 "1wy7m51h6sc4xz815kpr2il1krgpim9p8c6xm2fgb0dl0vbpbf1f"))))
+ (build-system pyproject-build-system)
+ ;;the tests
+ ;; 1) attempt to access the network
+ ;; 2) require ebay credentials to be written in a conf file
+ (arguments (list #:tests? #false))
+ (propagated-inputs (list python-lxml python-requests))
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://github.com/timotheus/ebaysdk-python")
+ (synopsis "The eBay SDK for Python")
+ (description "A programatic inteface into the eBay APIs.
+It simplifies development and cuts development time
+by standerizing calls, response processing, error handling, debugging
+across the Finding, Shopping, Merchandising, & Trading APIs.")
+ (license license:cddl1.0)))
+
base-commit: a175b3d150f8fd25db4355c46a3fcae6fe097b77
--
2.34.1
A
[PATCH python-team] Add python-num2words
(address . 76006@debbugs.gnu.org)
dd4a4ee6-3497-40a5-bc8a-ae40d3887312@riseup.net
From db0cb5f2063fa50d8e957701766322c8c9968696 Mon Sep 17 00:00:00 2001
Message-Id: <db0cb5f2063fa50d8e957701766322c8c9968696.1738493189.git.adriano_peluso@riseup.net>
In-Reply-To: <9dabb3a76c0e7a379b60f9638e934031260e9de4.1738493189.git.adriano_peluso@riseup.net>
References: <9dabb3a76c0e7a379b60f9638e934031260e9de4.1738493189.git.adriano_peluso@riseup.net>
From: Adriano Peluso <adriano_peluso@riseup.net>
Date: Sun, 2 Feb 2025 11:08:27 +0100
Subject: [PATCH 2/2] gnu: Add python-num2words
* gnu/packages/python-xyz.scm (python-num2words): New variable
Change-Id: I1217a168635802bf2e1625c8e2dd00fda5285fdf
---
gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b4b233d464..6c62661214 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9247,6 +9247,30 @@ (define-public python-cython-3
python-wheel))
(properties '())))
+(define-public python-num2words
+ (package
+ (name "python-num2words")
+ (version "0.5.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "num2words" version))
+ (sha256
+ (base32 "1ikryc61qig04xhs69mjd24amyxagmsbb1l0nfiicrkbwlcfqrmh"))))
+ (build-system pyproject-build-system)
+ ;;the tests
+ ;; 1) require python-pip
+ ;; 2) look for /etc/ssl/certs/ca-certificates.crt
+ (arguments (list #:tests? #false))
+ (propagated-inputs (list python-docopt))
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://github.com/savoirfairelinux/num2words")
+ (synopsis "Modules to convert numbers to words. Easily extensible")
+ (description "A library that converts numbers like 42 to words like forty-two.
+It supports multiple languages and can even generate ordinal numbers like forty-second
+(although this last feature is a bit buggy for some languages at the moment).")
+ (license license:gpl2)))
+
;; NOTE: when upgrading numpy please make sure that python-numba,
;; python-pandas and python-scipy still build, as these three packages are
;; often used together.
--
2.34.1
A
about python-num2words
(address . 76006@debbugs.gnu.org)
1ec9070b-480a-4db8-a47a-ea1caec3a6bf@riseup.net
guix size returns this
$ ./pre-inst-env guix size python-num2words
store item total self
/gnu/store/ksv5hc7yschbvq1zw4n31w30a3fjid4f-python-3.11.11 202.5
102.3 36.9%
/gnu/store/0ff2r8bk0g0if5n1lmw9v63gm1c74rbp-python-3.11.11 161.4
61.2 22.1%
Are these 2 distinct Python-3.11.11 ?
with different hashes and sizes ?
what is this, why does this happen ?
/gnu/store/zvlp3n8iwa1svxmwv4q22pv1pb1c9pjq-glibc-2.39 40.5 38.8 14.0%
/gnu/store/zzpbp6rr43smwxzvzd4qd317z5j7qblj-gcc-11.4.0-lib 75.6 35.0
12.6%
/gnu/store/xc98v8v485rs704wb26mipb0y5npdl1z-openssl-3.0.8 83.7 8.1
2.9%
/gnu/store/gfs2h9wxhaldm5v1xjvn73kczyk6rd5i-bash-5.1.16 89.1 6.2 2.2%
/gnu/store/7rsdf5kcqh0gl88av6nkgvgxg1ywvc5b-ncurses-6.2.20210619
81.5 5.9 2.1%
/gnu/store/m6pwkzix5xnmw3ywjyscm3la27q4fa7z-python-setuptools-67.6.1
5.8 5.8 2.1%
/gnu/store/laj6a3z6gjza9f18kyxw1nz5211ghwfs-sqlite-3.39.3 86.3 3.4
1.2%
/gnu/store/fbaw0sb21gv02qq7gs9wg5y5wlpdgzih-xz-5.4.5 79.1 2.5 0.9%
/gnu/store/87z5k84hxbqs87plgwsl2v6a4j7m3k7h-bash-static-5.1.16 1.7
1.7 0.6%
/gnu/store/dl3665ynrp41ynyw2ay5kfqix93myj5d-readline-8.1.2 82.9
1.4 0.5%
/gnu/store/27srvszj7vv9bghwfdng8cfp7hygjxdl-python-num2words-0.5.14
277.3 1.1 0.4%
/gnu/store/3jhfhxdf6v5ms10x5zmnl166dh3yhbr1-bash-minimal-5.1.16 41.5
1.0 0.4%
/gnu/store/hdb3jmxa67zkh4wj0l6w9ga3gj84k1yc-gdbm-1.23 76.2 0.6 0.2%
/gnu/store/q1vqb2hfclghbpl1vn094l1rzj12b6qb-libxcrypt-4.4.36 76.1
0.5 0.2%
/gnu/store/96np8rwhmfacb3hgxxq5gvp2a6zydpkr-python-wheel-0.40.0
209.1 0.5 0.2%
/gnu/store/59kd6jyvrq8prl9mbnh3g8d22rc1dbwv-bzip2-1.0.8 76.9 0.4 0.1%
/gnu/store/8bs3gia5rknqsw840rrwm2na4200ybc5-expat-2.5.0 75.9 0.4 0.1%
/gnu/store/1prv14v6jfnzzg7szm57690b7fr6sx33-zlib-1.3 75.8 0.2 0.1%
/gnu/store/s6iqwc5sqjrk76kzslqc1n1wlcvfyqkw-libffi-3.4.4 75.8 0.2 0.1%
/gnu/store/m5ipll6anv4mlcqjihss2r1riggi3hjc-python-docopt-0.6.2 0.1
0.1 0.0%
/gnu/store/22z3zlybj2n2ynfy3llb9kb1xipya04c-python-wrapper-3.11.11
167.6 0.0 0.0%
/gnu/store/9k0kvg0z8scjnc1mwymd6icbzq76b5n1-python-wrapper-3.11.11
208.6 0.0 0.0%
Are these 2 distinct python-wrapper-3.11.11 ?
with different hashes and sizes ?
Are these 2 associated with the 2 previous distinct Pythons ?
why does this happen ?
total: 277.3 MiB
Also guix size for this package returns so meny lines
other python packages return ONE line
I can't see anything wrong with the definition of this package
Is there anything wrong with the definition of this package ?
?