(address . guix-patches@gnu.org)(name . willow xyz)(address . willow@phantoma.online)
Hi, Guix,
I've never submitted a package to the project before, so hopefully everything here checks out. Let me know if anything more is required to get this merged.
---
gnu/packages/fonts.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
Toggle diff (40 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index c32f2ef5fb..244da1a62f 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -62,6 +62,7 @@
;;; Copyright © 2024 Christina O'Donnell <cdo@mutix.org>
;;; Copyright © 2025 Ashvith Shetty <ashvithshetty10@gmail.com>
;;; Copyright © 2025 Ashish SHUKLA <ashish.is@lostca.se>
+;;; Copyright © 2025 willow xyz <willow@phantoma.online>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3924,3 +3925,23 @@ (define-public font-cica
In addition, Nerd Fonts, Noto Emoji, Icons for Devs, and some adjustment forked
from the Ricty generator are converted and adjusted.")
(license license:silofl1.1)))
+
+(define-public font-new-heterodox-mono
+ (package
+ (name "font-new-heterodox-mono")
+ (version "0.0.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hckiang/font-new-heterodox-mono")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17bz0fdcfq0k3aahq6b79szihz2d5c55lqggpx9wkp17sd5azr76"))))
+ (build-system font-build-system)
+ ;; (outputs '("out" "ttf" "otf"))
+ (home-page "https://github.com/hckiang/font-new-heterodox-mono")
+ (synopsis "A Didone-esque Monospaced Typeface based on Alexey Kryukov's Old Standard TT.")
+ (description "New Heterodox Mono is a Didone-esque Monospaced Typeface based on Alexey Kryukov's Old Standard TT. It features a non-\"standard\" stylized serif design not normally found in mainstream \"programming fonts.\"")
+ (license license:silofl1.1)))
base-commit: c788962baeeb6bf021b30c9ad774d472f592fdb5
--
2.48.1