[PATCH] Added font-new-heterodox-mono

  • Open
  • quality assurance status badge
Details
3 participants
  • Andrew Wong
  • willow xyz
  • Andrew Wong
Owner
unassigned
Submitted by
willow xyz
Severity
normal
W
W
willow xyz wrote on 30 Jan 21:51 +0100
(address . guix-patches@gnu.org)(name . willow xyz)(address . willow@phantoma.online)
20250130205142.18087-1-willow@phantoma.online
Hi, Guix,
I've never submitted a package to the project before, so hopefully everything here checks out. Let me know if anything more is required to get this merged.

---
gnu/packages/fonts.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index c32f2ef5fb..244da1a62f 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -62,6 +62,7 @@
;;; Copyright © 2024 Christina O'Donnell <cdo@mutix.org>
;;; Copyright © 2025 Ashvith Shetty <ashvithshetty10@gmail.com>
;;; Copyright © 2025 Ashish SHUKLA <ashish.is@lostca.se>
+;;; Copyright © 2025 willow xyz <willow@phantoma.online>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3924,3 +3925,23 @@ (define-public font-cica
In addition, Nerd Fonts, Noto Emoji, Icons for Devs, and some adjustment forked
from the Ricty generator are converted and adjusted.")
(license license:silofl1.1)))
+
+(define-public font-new-heterodox-mono
+ (package
+ (name "font-new-heterodox-mono")
+ (version "0.0.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hckiang/font-new-heterodox-mono")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17bz0fdcfq0k3aahq6b79szihz2d5c55lqggpx9wkp17sd5azr76"))))
+ (build-system font-build-system)
+ ;; (outputs '("out" "ttf" "otf"))
+ (home-page "https://github.com/hckiang/font-new-heterodox-mono")
+ (synopsis "A Didone-esque Monospaced Typeface based on Alexey Kryukov's Old Standard TT.")
+ (description "New Heterodox Mono is a Didone-esque Monospaced Typeface based on Alexey Kryukov's Old Standard TT. It features a non-\"standard\" stylized serif design not normally found in mainstream \"programming fonts.\"")
+ (license license:silofl1.1)))

base-commit: c788962baeeb6bf021b30c9ad774d472f592fdb5
--
2.48.1
A
A
Andrew Wong wrote 6 days ago
(address . 75957@debbugs.gnu.org)
1d5a5c3b-6aa8-4892-8c31-a46472b8242f@icloud.com
Hello! This patch is perfect except for its styling. Remove any loose
comments, hard-wrap strings(guix will automatically re-wrap them), and
remember that synopses shouldn't end with a period. I would recommend
using `guix lint` and `guix style` to guide you, as well as the
`Contributing' section of the guix manual and the 'Packaging' section of
the guix cookbook.
A
A
Andrew Wong wrote 6 days ago
(address . 75957@debbugs.gnu.org)
6e93efdd-1cb6-451f-a1cd-a6f3c288f427@gmail.com
Oh, also, don't forget to write a proper commit message! Use 'git log'
in a guix checkout to get some examples--if you're an emacs user, there
are also templates in the repo.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75957@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75957
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch