[PATCH] gnu: Add yggtray.

  • Done
  • quality assurance status badge
Details
2 participants
  • Artyom V. Poptsov
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal
A
A
Artyom V. Poptsov wrote on 30 Jan 19:42 +0100
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
fd094d25d018d78fb8435a2a1dbac19f45465d91.1738262545.git.poptsov.artyom@gmail.com
* gnu/packages/networking.scm (yggtray): New variable.

Change-Id: I031f3db0bb9927ff23bb7994d655978c9abcaa55
---
gnu/packages/networking.scm | 40 ++++++++++++++++++++++++++++++++++++-
1 file changed, 39 insertions(+), 1 deletion(-)

Toggle diff (69 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 970a502b59..baa8f5ef67 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -60,7 +60,7 @@
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
-;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2023, 2024, 2025 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2024 Tomas Volf <~@wolfsden.cz>
;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
;;; Copyright © 2024 Alexey Abramov <levenson@mmer.org>
@@ -112,6 +112,7 @@ (define-module (gnu packages networking)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages code)
#:use-module (gnu packages compression)
#:use-module (gnu packages cpp)
@@ -4752,6 +4753,43 @@ (define-public yggdrasil
;; which apply to the Application, with which you must still comply
license:lgpl3)))
+(define-public yggtray
+ (package
+ (name "yggtray")
+ (version "0.1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/the-nexi/yggtray")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0cl30da6s3zgvrbccrma9p3j870dsrzjcacdgn4wpvpjiab8b4p4"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f ;No tests.
+ #:modules '((guix build cmake-build-system)
+ (guix build qt-utils)
+ (guix build utils))
+ #:imported-modules `(,@%cmake-build-system-modules (guix build qt-utils))
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-qt
+ (lambda* (#:key inputs #:allow-other-keys)
+ (wrap-qt-program "yggtray"
+ #:output #$output
+ #:inputs inputs))))))
+ (native-inputs (list cmake-minimal doxygen))
+ (inputs (list bash-minimal qtbase-5 qtwayland-5 yggdrasil))
+ (home-page "https://github.com/the-nexi/yggtray")
+ (synopsis "Yggdrasil tray and control panel")
+ (description
+ "@code{yggtray} is an @url{https://yggdrasil-network.github.io/, Yggdrasil} tray
+and control panel. It allows the user to configure, run and control the Yggdrasil
+daemon.")
+ (license license:gpl3+)))
+
(define-public nebula
(package
(name "nebula")

base-commit: c788962baeeb6bf021b30c9ad774d472f592fdb5
--
2.47.1
S
S
Sharlatan Hellseher wrote on 31 Jan 17:01 +0100
(address . 75951@debbugs.gnu.org)
CAO+9K5r6kJjrCzbazLPnP8iro6dCycUb8fdo9qyr-Ft4fiJZ8Q@mail.gmail.com
Hi,

Package looks nicely crafted.
Licence is ok and author of the source uses guix.scm
as well, good sign.

There is many page if it may be built as well in next round.

LGFM!

Please, commit.

Oleg
Attachment: file
A
A
Artyom V. Poptsov wrote on 31 Jan 19:31 +0100
(address . 75951-done@debbugs.gnu.org)
87r04ikf87.fsf@gmail.com
Merged to the "master" branch as
d48da2d21610f9cf5f76cd846703b12beedb1fd5

- avp

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQJNBAEBCgA3FiEEAf2F9Bp7f4IFgwalk16+BzbchX4FAmedFusZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRCTXr4HNtyFftLYD/9Loyb1VXhrX8yRF9fcwZLW
UiV6vH4GEeUBOJY4b4RPsoKDhqUAR7rIMvPswUIVB0pAy0zG+v7eagdORAkVmlzA
tTjERSWgIUSJwM4ukYa/A4FQ8ixG/mGrQPBmRzY3JI2nx9kmiE79RpgCdd8uwpCW
4I5Q9rI1kVpmrZnTAvC2Ic2E8KphJ5xw5VBiwaqVE6hO7Woa2iy01iZ3rthcbSHI
PqSBayNTXqfElKP1PRw7nhiIxNe+9kuY2c8nk9YO7lIHRQRBL3QMNjHpjD7rUF/k
+kWGhJAaP1KZXZM/sLx6GehCQfi5D4s4ej9MM+6eq/5UJOqnH4Lydk5eq5nr27ps
64mD6vPjjdR4tjrDJPuQvODXzmVh1inQJrBcP46RxIS3vEo5rJg8MKhXJMinxiuI
m2IpUKrcN1U1q0feOrMXWahgrzA0BE1FKyQHT0G7UqDqiRGg+dfsw2BFe6bwzUpD
SMKAW8UGCR+eq9DwNXMXI3VLyFxEzjk0uuHKTXMPOFVzUGfbRsF12MOreVzuMBz/
Xfbjf+gSE4XOBjqF2KutaZY4deqKn+TIxur+CV/JSnuCBGpnTN0YfznZ+CQwPjJj
RmKVw5AEol719bMOoPDoKLx8Y4jFo3XZp1WEWzhHhX00VSOqk5pZ7TGQM2GTvzMY
56v7s8013nMBkg/T4LQrWw==
=DCLp
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75951@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75951
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch