go@1.17.13 builds failing on aarch64-linux

  • Done
  • quality assurance status badge
Details
2 participants
  • Ian Eure
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Ian Eure
Severity
normal
I
I
Ian Eure wrote on 29 Jan 19:19 +0100
(address . bug-guix@gnu.org)
877c6dwiw9.fsf@retrospec.tv
Noticed on my aarch64-linux VM today that golang builds are
failing:

$ guix build go
<snip>
starting phase `build'
make.bash: line 159:
/gnu/store/45vng74anlglfd30v678a1lkbb34pjpv-go-1.4-bootstrap-20171003/bin/go:
cannot execute binary file: Exec format error
$ guix shell file -- file
/gnu/store/45vng74anlglfd30v678a1lkbb34pjpv-go-1.4-bootstrap-20171003/bin/go
<snip>
/gnu/store/45vng74anlglfd30v678a1lkbb34pjpv-go-1.4-bootstrap-20171003/bin/go:
ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV),
statically linked, stripped
$ uname -a
Linux vakum 6.11.11-gnu #1 SMP PREEMPT_DYNAMIC 1 aarch64
GNU/Linux
$ guix describe
Generation 7 Jan 29 2025 08:50:46 (current)
guix ac103c2
branch: master
commit: ac103c2eab1a169ca18c88fd0b0d03c7d2e02c9d

This was working in the previous generation, which was commit
680d01aeefaec383da44c3b6920c8a42f41613e9. I don’t see any changes
to go-1.4 or go-1.17 in there, but there are some go-build-system
change, which might be related.

-- Ian
S
S
Sharlatan Hellseher wrote on 31 Jan 17:44 +0100
(address . 75932@debbugs.gnu.org)
CAO+9K5pQD6kN3u3inU9eeUXEwnVyeHj20D=wwuVHRQ6F+U3wOA@mail.gmail.com
Hi,

The issue may come from the fact that all tests started to run
as default is ./... .

I can check later on Monday.

Oleg
Attachment: file
S
S
Sharlatan Hellseher wrote 7 days ago
(address . 75932@debbugs.gnu.org)(name . Ian Eure)(address . ian@retrospec.tv)
CAO+9K5r2dNThyXuBRim7LQZin2aGvdccwYpKxCGP3rBgotq8SQ@mail.gmail.com
Hi,


Toggle quote (2 lines)
> cannot execute binary file: Exec format error

This looks like one binary built on one architecture is invoked on other.

May you share the steps please?

Oleg
Attachment: file
I
I
Ian Eure wrote 7 days ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 75932@debbugs.gnu.org)
8734gxfkga.fsf@retrospec.tv
Hi Sharlatan,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (8 lines)
> Hi,
>
>> cannot execute binary file: Exec format error
>
> This looks like one binary built on one architecture is invoked
> on other.
>

Yes. My original report includes the output of `file' on the
binary in question, which is a 32-bit ARM ELF executable.
Presumably this cannot be directly executed on a 64-bit ARM host.


Toggle quote (3 lines)
> May you share the steps please?
>

Running `guix build go' on an aarch64-linux machine reproduces
the issue. I included what I thought would be all the relevant
information in my original report, including a commit where this
worked, the commit where it’s broken, the machine type, and the
output of `file' on the binary that’s failing to run. If you need
more information, please let me know what specific things would be
helpful, and I’d be happy to provide it.

-- Ian
S
S
Sharlatan Hellseher wrote 5 days ago
go@1.17.13 builds failing on aarch64-linux
(address . 75932@debbugs.gnu.org)(address . ian@retrospec.tv)
87a5b3kz65.fsf@gmail.com
Hi Ian,

I tried to reproduce it with time-machine and your commit on
--system=aarch64-linux:

Toggle snippet (26 lines)
guix time-machine --commit=ac103c2eab1a169ca18c88fd0b0d03c7d2e02c9d -- build --system=aarch64-linux go
<...>
/gnu/store/3z743aawlgqxww7dhkaap7gwcxjsgviw-go-1.23.5
/gnu/store/72609ldby63jf84z7qr4f628imnghdd2-go-1.23.5-tests

guix time-machine --commit=ac103c2eab1a169ca18c88fd0b0d03c7d2e02c9d -- build --system=aarch64-linux go@1.4-bootstrap-20171003
<...>
/gnu/store/14jpr2l9qbin1bnf1dciyv1f0i3mi25g-go-1.4-bootstrap-20171003-doc
/gnu/store/szpnxss4sdk6q06cnqi5vvz3y1f5kb4s-go-1.4-bootstrap-20171003
/gnu/store/x3f04scmkdl4p32md1kvc3xnykz4lwhq-go-1.4-bootstrap-20171003-tests

guix time-machine --commit=ac103c2eab1a169ca18c88fd0b0d03c7d2e02c9d -- shell file -- file /gnu/store/szpnxss4sdk6q06cnqi5vvz3y1f5kb4s-go-1.4-bootstrap-20171003/bin/go
<...>
/gnu/store/szpnxss4sdk6q06cnqi5vvz3y1f5kb4s-go-1.4-bootstrap-20171003/bin/go:
ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), statically
linked, stripped

guix time-machine --commit=ac103c2eab1a169ca18c88fd0b0d03c7d2e02c9d -- shell file -- file /gnu/store/3z743aawlgqxww7dhkaap7gwcxjsgviw-go-1.23.5/bin/go
<...>
/gnu/store/3z743aawlgqxww7dhkaap7gwcxjsgviw-go-1.23.5/bin/go: ELF 64-bit
LSB executable, ARM aarch64, version 1 (SYSV), statically linked, Go
BuildID=0eCUv8J6ZCq7sgVVZxvd/PzySMddYip0GeTK6gXT2/fIgm9FAYEjVeYs-FPzTf/q1haDqtswLHqvG5hU8dG,
stripped


It built succefully on my end in Qemu as you may see. I've got x86_64 for the
host machine.

Is any chance you may provide a similar reproducer?

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmegsfIACgkQdtcnv/Ys
0rVbjQ//Qpl0vM7v22HnF3EHPVFX9IALz+2llyCjvHkstVl6s5j6s6vH/A/4kZnt
GgoOSh5qj6DIzZulmJqefVZyPoDk9PpNMdZZk6RZ8WpXYXw4nn9cxkK7wpfsqfHG
8NGp/jIVXOlOy6WPP9G9z01FrLaD7uli5HdvJFvvl03jvwo4peVzC2cf+q9OsdN8
+iHIZZTRBfigxzCpluJoHEDA+iEt4auciQE1i9exx8NJ138WHWz8RN8lSKfAccVL
o+V8sYW2DKFkd9as7PIuDCVZWd305YfqccVhCqFm7SX8MYt7vBWrdJUcMjOrSht7
Cnbpa7GnJD5KsxRiELjxaPu2Kyp1TXRq7RqVGm10m1zV9ejEis+FE1KzUUYzx2DC
Fu5Cuq+FWUvnoesgOMs8urX4GXxiewtk1KNydojzTPxesSX/+cn1CsPZNrZqCGch
cifYChDBZ5/N+ly7SYhQBAv9npr63uWeicneh/zvGeZqcmrsEnla5UWy7X2Q8cea
9E/WCvIewHvXWozEOai3A3mtDsHcLONzfA5ZHCNnuWZwYndsjxsrKlCklb5jptSa
rNGKVMGHiS0AMr17N+MVToPPYok4IwKXNODJF8NGKgEpw4SoRvgjtMQ05gb+xfZj
TDioSY8CDJE0CoVXeV3E7ku4yKGQh6wL9kvGn1tS8V2FitnXwFU=
=A8jQ
-----END PGP SIGNATURE-----

I
I
Ian Eure wrote 3 hours ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 75932@debbugs.gnu.org)
87r048o3mi.fsf@retrospec.tv
close 75932
thanks

Hi Sharlatan,

I rebooted my VM and am no longer able to reproduce the issue,
even though I hadn’t pulled any newer revisions. Not sure what
was going on with this, might be a reproducability bug.

-- Ian

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (44 lines)
> Hi Ian,
>
> I tried to reproduce it with time-machine and your commit on
> --system=aarch64-linux:
>
> --8<---------------cut
> here---------------start------------->8---
> guix time-machine
> --commit=ac103c2eab1a169ca18c88fd0b0d03c7d2e02c9d -- build
> --system=aarch64-linux go
> <...>
> /gnu/store/3z743aawlgqxww7dhkaap7gwcxjsgviw-go-1.23.5
> /gnu/store/72609ldby63jf84z7qr4f628imnghdd2-go-1.23.5-tests
>
> guix time-machine
> --commit=ac103c2eab1a169ca18c88fd0b0d03c7d2e02c9d -- build
> --system=aarch64-linux go@1.4-bootstrap-20171003
> <...>
> /gnu/store/14jpr2l9qbin1bnf1dciyv1f0i3mi25g-go-1.4-bootstrap-20171003-doc
> /gnu/store/szpnxss4sdk6q06cnqi5vvz3y1f5kb4s-go-1.4-bootstrap-20171003
> /gnu/store/x3f04scmkdl4p32md1kvc3xnykz4lwhq-go-1.4-bootstrap-20171003-tests
>
> guix time-machine
> --commit=ac103c2eab1a169ca18c88fd0b0d03c7d2e02c9d -- shell file
> -- file
> /gnu/store/szpnxss4sdk6q06cnqi5vvz3y1f5kb4s-go-1.4-bootstrap-20171003/bin/go
> <...>
> /gnu/store/szpnxss4sdk6q06cnqi5vvz3y1f5kb4s-go-1.4-bootstrap-20171003/bin/go:
> ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV),
> statically
> linked, stripped
>
> guix time-machine
> --commit=ac103c2eab1a169ca18c88fd0b0d03c7d2e02c9d -- shell file
> -- file
> /gnu/store/3z743aawlgqxww7dhkaap7gwcxjsgviw-go-1.23.5/bin/go
> <...>
> /gnu/store/3z743aawlgqxww7dhkaap7gwcxjsgviw-go-1.23.5/bin/go:
> ELF 64-bit
> LSB executable, ARM aarch64, version 1 (SYSV), statically
> linked, Go
> BuildID=0eCUv8J6ZCq7sgVVZxvd/PzySMddYip0GeTK6gXT2/fIgm9FAYEjVeYs-FPzTf/q1haDqtswLHqvG5hU8dG,
> stripped
>
S
S
Sharlatan Hellseher wrote 22 minutes ago
go@1.17.13 builds failing on aarch64-linux
(address . 75932-done@debbugs.gnu.org)
CAO+9K5o9i2MB2ro5N12s5Q-duaefK_XFwddBBdAjU9N+cLODOw@mail.gmail.com

Attachment: file
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75932@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75932
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch