[PATCH] gnu: LLVM, Clang, libomp, lld: Update to 19.1.7.

  • Open
  • quality assurance status badge
Details
One participant
  • Zheng Junjie
Owner
unassigned
Submitted by
Zheng Junjie
Severity
normal
Z
Z
Zheng Junjie wrote 3 days ago
(address . guix-patches@gnu.org)
86ce43a01af26a14439b71f50fdd5cb86d7b9b1e.1737975609.git.zhengjunjie@iscas.ac.cn
* gnu/packages/llvm.scm (llvm-19, clang-19, libomp-19, lld-19): Update to 19.1.7.

Change-Id: I9adc9762a19da487c9a70bb9cf089ff08de4da84
---
gnu/packages/llvm.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index a81a9ab59e0..1f4136eb535 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -26,7 +26,7 @@
;;; Copyright © 2022 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
-;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023-2025 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -567,7 +567,7 @@ (define %llvm-monorepo-hashes
("16.0.6" . "0jxmapg7shwkl88m4mqgfjv4ziqdmnppxhjz6vz51ycp2x4nmjky")
("17.0.6" . "1a7rq3rgw5vxm8y39fyzr4kv7w97lli4a0c1qrkchwk8p0n07hgh")
("18.1.8" . "1l9wm0g9jrpdf309kxjx7xrzf13h81kz8bbp0md14nrz38qll9la")
- ("19.1.4" . "0y5kavrx13ylpzhci520hm7fgnzyj46mbz7dw3z9h5xi0py5lbda")))
+ ("19.1.7" . "18hkfhsm88bh3vnj21q7f118vrcnf7z6q1ylnwbknyb3yvk0343i")))
(define %llvm-patches
'(("14.0.6" . ("clang-14.0-libc-search-path.patch"
@@ -581,7 +581,7 @@ (define %llvm-patches
"clang-17.0-link-dsymutil-latomic.patch"))
("18.1.8" . ("clang-18.0-libc-search-path.patch"
"clang-17.0-link-dsymutil-latomic.patch"))
- ("19.1.4" . ("clang-18.0-libc-search-path.patch"
+ ("19.1.7" . ("clang-18.0-libc-search-path.patch"
"clang-17.0-link-dsymutil-latomic.patch"))))
(define (llvm-monorepo version)
@@ -1574,7 +1574,7 @@ (define-public clang-toolchain-18
(make-clang-toolchain clang-18 libomp-18))
(define-public llvm-19
- (make-llvm "19.1.4"))
+ (make-llvm "19.1.7"))
(define-public clang-runtime-19
(clang-runtime-from-llvm llvm-19))
@@ -1589,7 +1589,7 @@ (define-public clang-19
(package-version llvm-19)))
(sha256
(base32
- "19jgfdiwjx36d42219s6kdanwiapjdj49nnv8pn3vp74pgn0p7g0")))))
+ "1rqv769nvr07a9n1sgwbq5rm411x31kyq3ngls800m90z25hh2s3")))))
(define-public libomp-19
(package

base-commit: 77603927fba0edc2c4d9de122aa132b968a051e5
prerequisite-patch-id: 8b9b4517c90accd829b6aaa85971dd2cc4c86b4a
prerequisite-patch-id: 01243fc601f39eaeee602c28d900993cdab4b06c
prerequisite-patch-id: ba31c88c0d25165631b7650daa6cfc41e0d4675c
prerequisite-patch-id: a88c745a2faf849e57ab19cbe7c8f59323365cc9
prerequisite-patch-id: f31347c9a884b756912aad935db0c0ec52874250
prerequisite-patch-id: 446c38f952daae88c49e18ef184d4b4f4646463e
--
2.47.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75895@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75895
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch