Tomas Nordin wrote 2 months ago
(address . bug-guile@gnu.org)
Hello Guile!
As expected, the following raises an exception:
(append 'a '(b) '()) =>
ice-9/boot-9.scm:1676:22: In procedure raise-exception:
In procedure append: Wrong type argument in position 1 (expecting empty list): a
And so does this:
(append '(a) 'b '()) =>
ice-9/boot-9.scm:1676:22: In procedure raise-exception:
In procedure append: Wrong type argument in position 1 (expecting empty list): b
Note that the a-thing is the first and the b-thing the second argument
in both calls. 'a is at fault in the first and 'b is at fault in the
second call.
But, in both cases the faulty argument is reported to be in position 1.
I would expect maybe position 2 to be complained about from the second
call.
Also, I wonder why we are "(expecting empty list)" in place of the
non-list things?
I made the above observations, if it's a bug or not, I don't know.
(version) => "3.0.9.140-d8df3-dirty"
Have a great Sunday
--
Tomas