Josep Bigorra wrote 2 months ago
(address . guix-patches@gnu.org)
Hi all I am working on making a subset of Guix setup which is
accessible to all users, as part of the SSS project:
For this, I want to use sfwbar (https://github.com/LBCrion/sfwbar),
which is a nice Wayland taskbar, focused on floating window
compositors, like labwc. I think a lot of people will benefit from
having this package in Guix.
I have made a start, and the build phase succeeds, but am at a loss at
what is going wrong, could I get a hand?
The project uses meson to build so should make it easier for Guix.
I get an error like: RUNPATH validation failed and the
validate-runpath phase fails.
I am attaching the build logs and the PoC package definition,
Best,
Joe
(define-public swfbar
(package
(name "sfwbar")
(version "v1.0_beta16")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/LBCrion/sfwbar.git")
(commit "v1.0_beta16")))
(sha256
(base32 "1jgd33fn5x213dg4fry35qg16yqg3c71a2psfwl6fsz5fp1iphcc"))))
(inputs (list pkg-config (specification->package "gtk+@3.24.41") json-c gtk-layer-shell))
(build-system meson-build-system)
(synopsis "Flexible Wayland taskbar focused on stacking layout compositors.")
(description
"SFWBar (S* Floating Window Bar) is a flexible taskbar application for Wayland compositors, designed with a stacking layout in mind. Originally developed for Sway, SFWBar will work with any Wayland compositor supporting layer shell protocol, the taskbar and window switcher functionality shall work with any compositor supporting foreign top-level protocol, but the pager, and window placement functionality require sway (or at least i3 IPC support).")
(home-page "https://github.com/LBCrion/sfwbar")
(license license:gpl3+)))