[PATCH] gnu: Add pa-notify

  • Open
  • quality assurance status badge
Details
2 participants
  • Junker
  • Noé Lopez
Owner
unassigned
Submitted by
Junker
Severity
normal
J
J
Junker wrote on 24 Jan 23:04 +0100
(address . guix-patches@gnu.org)
30ed629ca0b5a21dba9380c458abd83f85583dc4.1737756103.git.dk@junkeria.club
Change-Id: I1afdff7e7f26f8b0468c993adc855b23677d4c06
---
gnu/packages/audio.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 76b16bc0fd..1f0978cbe7 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2024 mio <stigma@disroot.org>
;;; Copyright © 2024 Nikita Domnitskii <nikita@domnitskii.me>
;;; Copyright © 2024 Roman Scherer <roman@burningswell.com>
+;;; Copyright © 2025 Junker <dk@junkeria.club>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3598,6 +3599,31 @@ (define-public alure
streaming.")
(license license:expat)))
+(define-public pa-notify
+ (package
+ (name "pa-notify")
+ (version "1.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ikrivosheev/pa-notify")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04wq0bdnb3r27l5wlf8c1ijq18ffywqmdv584l6hbi3i5k0sm7nz"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ; no check target
+ (inputs (list glib
+ libnotify
+ pulseaudio))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/ikrivosheev/pa-notify")
+ (synopsis "PulseAudio or PipeWire volume notification")
+ (description "This package provides PulseAudio or PipeWire volume
+notification daemon")
+ (license license:expat)))
+
(define-public patchage
(package
(name "patchage")

base-commit: ea7a6fa8c66ef3cfd0ccdec6c0a7a3e7ab3dfc9c
prerequisite-patch-id: 88a949b9b0889acaebde2c5843fecda95c3e2c50
--
2.47.1
J
J
Junker wrote on 31 Jan 00:30 +0100
[PATCH v2] gnu: Add pa-notify.
(address . 75816@debbugs.gnu.org)
fb945f0298b8d2489201f2b0b5519bbe9572c535.1738279731.git.dk@junkeria.club
* gnu/packages/audio.scm (pa-notify): New variable.

Change-Id: Ib738b80e545958347101066f1e33b518869992bd
---
gnu/packages/audio.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 76b16bc0fd..1f0978cbe7 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2024 mio <stigma@disroot.org>
;;; Copyright © 2024 Nikita Domnitskii <nikita@domnitskii.me>
;;; Copyright © 2024 Roman Scherer <roman@burningswell.com>
+;;; Copyright © 2025 Junker <dk@junkeria.club>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3598,6 +3599,31 @@ (define-public alure
streaming.")
(license license:expat)))
+(define-public pa-notify
+ (package
+ (name "pa-notify")
+ (version "1.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ikrivosheev/pa-notify")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04wq0bdnb3r27l5wlf8c1ijq18ffywqmdv584l6hbi3i5k0sm7nz"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ; no check target
+ (inputs (list glib
+ libnotify
+ pulseaudio))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/ikrivosheev/pa-notify")
+ (synopsis "PulseAudio or PipeWire volume notification")
+ (description "This package provides PulseAudio or PipeWire volume
+notification daemon")
+ (license license:expat)))
+
(define-public patchage
(package
(name "patchage")

base-commit: ea7a6fa8c66ef3cfd0ccdec6c0a7a3e7ab3dfc9c
--
2.48.1
N
N
Noé Lopez wrote 3 days ago
Re: [PATCH] gnu: Add pa-notify
(address . 75816@debbugs.gnu.org)(name . Junker)(address . dk@junkeria.club)
87wme1wgh2.fsf@xn--no-cja.eu
Hi Junker,

Thanks for the patch! It looks great overall, builds and works on my
machine.

Just two comments:

Toggle quote (39 lines)
> * gnu/packages/audio.scm (pa-notify): New variable.
>
> Change-Id: Ib738b80e545958347101066f1e33b518869992bd
> ---
> gnu/packages/audio.scm | 26 ++++++++++++++++++++++++++
> 1 file changed, 26 insertions(+)
>
> diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
> index 76b16bc0fd..1f0978cbe7 100644
> --- a/gnu/packages/audio.scm
> +++ b/gnu/packages/audio.scm
> @@ -50,6 +50,7 @@
> ;;; Copyright © 2024 mio <stigma@disroot.org>
> ;;; Copyright © 2024 Nikita Domnitskii <nikita@domnitskii.me>
> ;;; Copyright © 2024 Roman Scherer <roman@burningswell.com>
> +;;; Copyright © 2025 Junker <dk@junkeria.club>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -3598,6 +3599,31 @@ (define-public alure
> streaming.")
> (license license:expat)))
>
> +(define-public pa-notify
> + (package
> + (name "pa-notify")
> + (version "1.5.0")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/ikrivosheev/pa-notify")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "04wq0bdnb3r27l5wlf8c1ijq18ffywqmdv584l6hbi3i5k0sm7nz"))))
> + (build-system cmake-build-system)
> + (arguments '(#:tests? #f)) ; no check target

There should be no space between the semicolon and the comment when it
is aside like this.

Toggle quote (9 lines)
> + (inputs (list glib
> + libnotify
> + pulseaudio))
> + (native-inputs (list pkg-config))
> + (home-page "https://github.com/ikrivosheev/pa-notify")
> + (synopsis "PulseAudio or PipeWire volume notification")
> + (description "This package provides PulseAudio or PipeWire volume
> +notification daemon")

The description should end with a dot, and have a more complete
description of what the package offers. For example it could be:

pa-notify is a daemon that send a notification about the current volume
of PulseAudio or PipeWire using libnotify.

Toggle quote (10 lines)
> + (license license:expat)))
> +
> (define-public patchage
> (package
> (name "patchage")
>
> base-commit: ea7a6fa8c66ef3cfd0ccdec6c0a7a3e7ab3dfc9c
> --
> 2.48.1

Could you send a third version?

Thanks,
Noé
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75816@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75816
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch