[PATCH] gnu: Add cl-fuzzy-match

  • Done
  • quality assurance status badge
Details
2 participants
  • Junker
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
Junker
Severity
normal

Debbugs page

Junker wrote 2 months ago
(address . guix-patches@gnu.org)
383ffae4d5c848a2e80ff649056b9a226bad61e3.1737754017.git.dk@junkeria.club
Change-Id: I5927d0ce1c737885e2447cd73b1f3d2e8c59e5a3
---
gnu/packages/lisp-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index f00f0d30e2..7a5db300e5 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5953,6 +5953,38 @@ (define-public cl-ftp
(define-public ecl-cl-ftp
(sbcl-package->ecl-package sbcl-cl-ftp))
+(define-public sbcl-fuzzy-match
+ (let ((commit "e46ca41ef4641461f7be006782e3cfdcf73ba98a")
+ (revision "1"))
+ (package
+ (name "sbcl-fuzzy-match")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vindarel/fuzzy-match")
+ (commit commit)))
+ (file-name (git-file-name "cl-fuzzy-match" version))
+ (sha256
+ (base32 "1lawndmzkl6f9sviy7ngn2s3xkc4akp8l505kvpslaz6qq0ayyqv"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs (list sbcl-cl-str
+ sbcl-mk-string-metrics))
+ (home-page "htstps://github.com/Lautaro-Garcia/cl-notify")
+ (synopsis "Common Lisp library for fuzzy matching candidates from an
+input string")
+ (description
+ "From a string input and a list of candidates, return the most relevant
+candidates first")
+ (license license:expat))))
+
+(define-public cl-fuzzy-match
+ (sbcl-package->cl-source-package sbcl-fuzzy-match))
+
+(define-public ecl-fuzzy-match
+ (sbcl-package->ecl-package sbcl-fuzzy-match))
+
(define-public sbcl-cl-gamepad
(let ((commit "d5b99fbaa2e39294d23061699e8f1e761eda7205")
(revision "3"))

base-commit: ea7a6fa8c66ef3cfd0ccdec6c0a7a3e7ab3dfc9c
--
2.47.1
Junker wrote 1 months ago
[PATCH v2] gnu: Add cl-fuzzy-match
(address . 75815@debbugs.gnu.org)
a7449111a63f571394c8adf68573963edd9c8603.1738148838.git.dk@junkeria.club
Fixed homege URL.

Change-Id: I7b9ec909e56cff315b53d42862967fbaaef3f6bc
---
gnu/packages/lisp-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index f00f0d30e2..631f52de18 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5953,6 +5953,32 @@ (define-public cl-ftp
(define-public ecl-cl-ftp
(sbcl-package->ecl-package sbcl-cl-ftp))
+(define-public sbcl-fuzzy-match
+ (let ((commit "e46ca41ef4641461f7be006782e3cfdcf73ba98a")
+ (revision "1"))
+ (package
+ (name "sbcl-fuzzy-match")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vindarel/fuzzy-match")
+ (commit commit)))
+ (file-name (git-file-name "cl-fuzzy-match" version))
+ (sha256
+ (base32 "1lawndmzkl6f9sviy7ngn2s3xkc4akp8l505kvpslaz6qq0ayyqv"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs (list sbcl-cl-str
+ sbcl-mk-string-metrics))
+ (home-page "https://github.com/vindarel/fuzzy-match")
+ (synopsis "Common Lisp library for fuzzy matching candidates from an
+input string")
+ (description
+ "From a string input and a list of candidates, return the most relevant
+candidates first")
+ (license license:expat))))
+
(define-public sbcl-cl-gamepad
(let ((commit "d5b99fbaa2e39294d23061699e8f1e761eda7205")
(revision "3"))

base-commit: ea7a6fa8c66ef3cfd0ccdec6c0a7a3e7ab3dfc9c
--
2.47.1
Junker wrote 1 months ago
[PATCH v3] gnu: Add cl-fuzzy-match.
(address . 75815@debbugs.gnu.org)
67c894ac7b81338e3169d41ca4e1e93d4511464f.1738328138.git.dk@junkeria.club
* gnu/packages/lisp-xyz.scm (cl-fuzzy-match,
ecl-fuzzy-match, sbcl-fuzzy-match): New variables.

Change-Id: I65be6ab95bfec08e69bd4bf9658b140af3ea2025
---
gnu/packages/lisp-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index f00f0d30e2..ef0a30133e 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5953,6 +5953,38 @@ (define-public cl-ftp
(define-public ecl-cl-ftp
(sbcl-package->ecl-package sbcl-cl-ftp))
+(define-public sbcl-fuzzy-match
+ (let ((commit "e46ca41ef4641461f7be006782e3cfdcf73ba98a")
+ (revision "1"))
+ (package
+ (name "sbcl-fuzzy-match")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vindarel/fuzzy-match")
+ (commit commit)))
+ (file-name (git-file-name "cl-fuzzy-match" version))
+ (sha256
+ (base32 "1lawndmzkl6f9sviy7ngn2s3xkc4akp8l505kvpslaz6qq0ayyqv"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs (list sbcl-cl-str
+ sbcl-mk-string-metrics))
+ (home-page "https://github.com/vindarel/fuzzy-match")
+ (synopsis "Common Lisp library for fuzzy matching candidates from an
+input string")
+ (description
+ "From a string input and a list of candidates, return the most relevant
+candidates first")
+ (license license:expat))))
+
+(define-public cl-fuzzy-match
+ (sbcl-package->cl-source-package sbcl-fuzzy-match))
+
+(define-public ecl-fuzzy-match
+ (sbcl-package->ecl-package sbcl-fuzzy-match))
+
(define-public sbcl-cl-gamepad
(let ((commit "d5b99fbaa2e39294d23061699e8f1e761eda7205")
(revision "3"))

base-commit: ea7a6fa8c66ef3cfd0ccdec6c0a7a3e7ab3dfc9c
--
2.48.1
Guillaume Le Vaillant wrote 1 months ago
(name . Junker)(address . dk@junkeria.club)(address . 75815-done@debbugs.gnu.org)
87frkrfa24.fsf@kitej
Patch applied as 431f2ad7308532e9f70b6bdea5d129abf3110c1d.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZ6TAUw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/ObAD+P9sYxl1eGCHOvbaDZE6aRgjx6m5I8AfluTLN
q5O+XHcA/RUWsleWiPjO8l83iflu9eoL6bTw3KxWhycIHf0jTFyx
=sjH+
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 75815@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75815
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help