[PATCH core-packages-team] gnu: libseccomp: Update to 2.6.0.

  • Done
  • quality assurance status badge
Details
One participant
  • Zheng Junjie
Owner
unassigned
Submitted by
Zheng Junjie
Severity
normal

Debbugs page

Zheng Junjie wrote 2 months ago
(address . guix-patches@gnu.org)
f3ceaf83930f4402b1650e3bab0bac85f56cef3d.1737700288.git.zhengjunjie@iscas.ac.cn
* gnu/packages/linux.scm (libseccomp): Update to 2.6.0.
[source]: Switch to git-fetch.
[arguments]: Use G-expressions.
[native-inputs]: Add autoconf, automake, and libtool.

Change-Id: I19302252578c6791937ec073d24607e19277f49a
---
gnu/packages/linux.scm | 30 ++++++++++++++++--------------
1 file changed, 16 insertions(+), 14 deletions(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1f62c63f08..5a6c41a426 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7753,26 +7753,28 @@ (define-public mtd-utils
(define-public libseccomp
(package
(name "libseccomp")
- (version "2.5.4")
+ (version "2.6.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/seccomp/libseccomp/"
- "releases/download/v" version
- "/libseccomp-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/seccomp/libseccomp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1nyb3lspc5bsirpsx89vah3n54pmwlgxrwsfaxl01kq50i004afq"))))
+ "189yh66aj3z3jvns739qbj504f3mcl3w44pxxizw877pbj3kal11"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--disable-static")
- #:phases (modify-phases %standard-phases
- (add-before 'check 'skip-load-test
- (lambda _
- ;; This test does a native system call and fails when
- ;; run under QEMU user-mode emulation. Just skip it.
- (delete-file "tests/52-basic-load.tests"))))))
+ (list
+ #:configure-flags #~(list "--disable-static")
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'check 'skip-load-test
+ (lambda _
+ ;; This test does a native system call and fails when
+ ;; run under QEMU user-mode emulation. Just skip it.
+ (delete-file "tests/52-basic-load.tests"))))))
(native-inputs
- (list gperf which))
+ (list autoconf automake gperf libtool which))
(synopsis "Interface to Linux's seccomp syscall filtering mechanism")
(description "The libseccomp library provides an easy to use, platform
independent, interface to the Linux Kernel's syscall filtering mechanism. The

base-commit: 3cf48f590c53651e0073a90cf2a5d51098c667af
--
2.47.1
Z572 wrote 1 weeks ago
(address . 75797-done@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)(name . Leo Famulari)(address . leo@famulari.name)
87mse2kucr.fsf@iscas.ac.cn
Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:

Toggle quote (59 lines)
> * gnu/packages/linux.scm (libseccomp): Update to 2.6.0.
> [source]: Switch to git-fetch.
> [arguments]: Use G-expressions.
> [native-inputs]: Add autoconf, automake, and libtool.
>
> Change-Id: I19302252578c6791937ec073d24607e19277f49a
> ---
> gnu/packages/linux.scm | 30 ++++++++++++++++--------------
> 1 file changed, 16 insertions(+), 14 deletions(-)
>
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index 1f62c63f08..5a6c41a426 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -7753,26 +7753,28 @@ (define-public mtd-utils
> (define-public libseccomp
> (package
> (name "libseccomp")
> - (version "2.5.4")
> + (version "2.6.0")
> (source (origin
> - (method url-fetch)
> - (uri (string-append "https://github.com/seccomp/libseccomp/"
> - "releases/download/v" version
> - "/libseccomp-" version ".tar.gz"))
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/seccomp/libseccomp")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> (sha256
> (base32
> - "1nyb3lspc5bsirpsx89vah3n54pmwlgxrwsfaxl01kq50i004afq"))))
> + "189yh66aj3z3jvns739qbj504f3mcl3w44pxxizw877pbj3kal11"))))
> (build-system gnu-build-system)
> (arguments
> - '(#:configure-flags '("--disable-static")
> - #:phases (modify-phases %standard-phases
> - (add-before 'check 'skip-load-test
> - (lambda _
> - ;; This test does a native system call and fails when
> - ;; run under QEMU user-mode emulation. Just skip it.
> - (delete-file "tests/52-basic-load.tests"))))))
> + (list
> + #:configure-flags #~(list "--disable-static")
> + #:phases #~(modify-phases %standard-phases
> + (add-before 'check 'skip-load-test
> + (lambda _
> + ;; This test does a native system call and fails when
> + ;; run under QEMU user-mode emulation. Just skip it.
> + (delete-file "tests/52-basic-load.tests"))))))
> (native-inputs
> - (list gperf which))
> + (list autoconf automake gperf libtool which))
> (synopsis "Interface to Linux's seccomp syscall filtering mechanism")
> (description "The libseccomp library provides an easy to use, platform
> independent, interface to the Linux Kernel's syscall filtering mechanism. The
>
> base-commit: 3cf48f590c53651e0073a90cf2a5d51098c667af
pushed to core-packages-team. closing.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmfFylQACgkQO1qpk+Gi
3/DEjQ/+JCzs4KFx/YH5C9DHfckaCnTh2ZuR1ICFjBR+GU9NP6fgUvureuGJeVEX
QE7agoENEyljyYGh54snRMi8E3hDYgvw3lMiLE24RKrvvmYTQpj/pOeNzvNU90QD
O+8ohtTGgNIV+v8GqOLqyA/pXieiK5Jp76jf8xCjbpzHbkdq2C4uPp+XREyAvFEH
pV5SWHUKtdwIrJxMhdA6lsM28ePipIqIsBZSrb0NryPGDiX4CJ4JEjCvzrjsrv+L
8rYOV4PE/7VVuNepTR+cFqMrFI3QCmorPWBGMZYLuD8ET3du6q01MPj2W5Qm9xiD
PT6gIx0kSDlOYnDIVGtkURxEW6YC/Z3oP/7whyfgdFjcm6iDNcm70QUBat5R8HfK
eLVe1lczQJkhCFtwog6n83+CGFNFHK07MhhIqNF7u5pgP02OZOumkK3K4syPv+gD
nkOZEI7culcR7PVv1dKKmGUH0hzzay+SV+/H7X8TXHGRuSlN6ZMRGkgNITD4Dp1v
RBFvHcpMbU9OfLiM8pot0AbORgE/cmWQq7ESrU89EhXn/7W5VdPxVZ8E6gxQS9/V
PyYxD/XJeVzn9u20G4ypC4lt+EBUqU545KCIFtrLa68mGx9Aqbe75HVk3FN9V7oD
OQcQr8y2IEx4/A9g//+uL0i+8Li6Qg9WaG1MZjXcrlPM4sdKL9E=
=AXVg
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75797@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75797
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help