Reduce unused native-inputs for grub-efi and grub-minimal

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 2 months ago
(address . guix-patches@gnu.org)
87wmelubkf.fsf@wireframe
The attached patch removes the native-inputs on qemu-minimal for both
grub-efi and grub-minimal, neither of which actually use qemu-minimal it
because tests are disabled.

It is possible the removal of "qemu" was sufficient when using labels
but the switch away from labels may have left grub-efi and grub-minimal
with a fairly large dependency chain due to qemu-minimal, despite not
really using it.

I did not test all reverse dependents yet, but both grub-efi and
grub-minimal still build.

Dropping qemu-minimal from native-inputs really helps on architectures
with poor substitute availability, such as aarch64!

Since Efraim and Ludo were both authors of the relevent commits fixing
and/or (re)introducing this issue, I reach out for your wisdom, or at
least your thoughts!

Efraim also happens to be on the embedded team, which technically covers
gnu/packages/bootloaders.scm, although grub being an embedded thing
seems a bit of a stretch, given it is a commonly used bootloader on a
largely dominant mostly not embedded platform. I guess it is kind of an
embedded project unto itself? sort of? hrmpf.


live well,
vagrant
From c71df9ccf0ab9713a1fd9fd7070ed151c7588120 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Thu, 23 Jan 2025 00:56:40 -0800
Subject: [PATCH] gnu: grub-minimal, grub-efi: Reduce unused native-inputs.

"qemu" was removed in e9c1ea84fcf4a7f3da9aea9fbfe6136c75643c07 in the code
though the commit message claims to have removed "qemu-minimal". If that
worked, it may have been broken by switching away from labels in
b9c38f26f120e3e12b3bfbf29c6248a08fe1a62c.

* gnu/packages/bootloaders.scm (grub-minimal)[native-inputs]: Remove
qemu-minimal.
(grub-efi)[native-inputs]: Remove qemu-minimal.
---
gnu/packages/bootloaders.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index b5cfacca4b..4dab7bd0b7 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -323,7 +323,7 @@ (define-public grub-minimal
(delete "lvm2" "mdadm" "fuse" "console-setup")))
(native-inputs
(modify-inputs (package-native-inputs grub)
- (delete "help2man" "texinfo" "parted" "qemu" "xorriso")))
+ (delete "help2man" "texinfo" "parted" "qemu" "qemu-minimal" "xorriso")))
(arguments
(substitute-keyword-arguments (package-arguments grub)
((#:tests? _ #t) #f)
@@ -413,7 +413,7 @@ (define-public grub-efi
(native-inputs
;; The tests are skipped in this package so we remove some test dependencies.
(modify-inputs (package-native-inputs grub)
- (delete "parted" "qemu" "xorriso")))
+ (delete "parted" "qemu" "qemu-minimal" "xorriso")))
(arguments
;; TODO: Tests need a UEFI firmware for qemu. There is one at
;; https://github.com/tianocore/edk2/tree/master/OvmfPkg .

base-commit: cc678d0e4d67073943e75053c5e450c4df700b42
--
2.39.5
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZ5IK8AAKCRDcUY/If5cW
qsGZAP9dhSKEoRMTWN4vDQjw9y3aeI96ABmERKXcvhzFcR6SxgEAhNdXnjw0KCoT
VBOebBGJJ+fJGyxgU/9gFHbmhxrtfwg=
=qyy/
-----END PGP SIGNATURE-----

Vagrant Cascadian wrote 2 months ago
(address . 75781@debbugs.gnu.org)
87tt9ptk1q.fsf@wireframe
On 2025-01-23, Vagrant Cascadian wrote:
Toggle quote (3 lines)
> The attached patch removes the native-inputs on qemu-minimal for both
> grub-efi and grub-minimal, neither of which actually use qemu-minimal it
> because tests are disabled.
...
Toggle quote (3 lines)
> I did not test all reverse dependents yet, but both grub-efi and
> grub-minimal still build.

And I still have not tested reverse dependents, because... there are no
dependents!

Though grub-efi is presumably widely used on actual systems and I have
only tested a single aarch64 system...


live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZ5KWQQAKCRDcUY/If5cW
qkk8AP9V8HyL8v44d5jGTIMqb+8Ns6qsp0Ig+bccZrlYYcoZRQEA5l0MWb25V8CR
GnH8L8FnDbqoOHXJkERhIRq5eLG48AY=
=70ba
-----END PGP SIGNATURE-----

Efraim Flashner wrote 1 months ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)
Z6TKIK0tRGLg-7sO@3900XT
On Thu, Jan 23, 2025 at 11:19:29AM -0800, Vagrant Cascadian wrote:
Toggle quote (14 lines)
> On 2025-01-23, Vagrant Cascadian wrote:
> > The attached patch removes the native-inputs on qemu-minimal for both
> > grub-efi and grub-minimal, neither of which actually use qemu-minimal it
> > because tests are disabled.
> ...
> > I did not test all reverse dependents yet, but both grub-efi and
> > grub-minimal still build.
>
> And I still have not tested reverse dependents, because... there are no
> dependents!
>
> Though grub-efi is presumably widely used on actual systems and I have
> only tested a single aarch64 system...

I'd like to eventually figure out running the tests, but I assume I'd do
it on x86_64 only either due to test support or machine speed. No
reason to keep it as an input for "eventually".

LGTM!


--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmekyiAACgkQQarn3Mo9
g1HYJQ//Q8yjd8hSq2RfMi0Mxz+0CZwmQnNsQ/ThH/Z4TvDdKr8kLTvv0zS16ypS
oXYyasj1XO2Po7hK+nst/3XqIGxCTivWVX5yIun/qadiF0Lr6lsqF1bbDZ584ePP
qZP0AGWdtcqF1M/hUdqnuB61qQZKCEO5Ccsp3J2v3GQVYutbqR+aZhhTUv7diIkK
ZtOfitdH80xVqiLpHEMUJNARcQV7aRXEXt/FcBAgIE7jEvP8K/hWKd4UHy2Kdcp1
3HzSjtdiHnlPzBk1T6ngrWrdfy501pn2DPCLRd+MKBkndMyUoqi1hAatTTr2/Qec
9LiT+4SQTa0lfh5AW2RnexJ3hcUMm/3rou7GGjHYCixvYt2X34tTXEFMb4s96RLe
IsxI3lifcR3zVh7UJp+f0Mpj/OSMlDVKPNT/stKiFnBRule8QYPGc+HG9zA+WAzs
qPZRbs16GpnjbYsiyatC/mdJnR9ZYTGb0Gcs/kzhNzdGqgvCdTg3jusyLRVvj6BN
lQlyMssk1M5fvtslbZfGPz35BtmQyYvD+fdYfq5yK1JcO9kL4QHXlK07+C4F5fsu
+q4kCtvaDQP1xAnpMW2hnDZC7+YwNO6JNmk5VTXAMy0t8wuiz2d3qU6y47GomPcR
EYUSNyVWTBxrtPLOa8Qn5Q+kXmSoqqNSLgrmYyZMqZjR/cJPjSM=
=CL3V
-----END PGP SIGNATURE-----


Vagrant Cascadian wrote 4 weeks ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)
87y0yc9qlh.fsf@wireframe
On 2025-02-06, Efraim Flashner wrote:
Toggle quote (19 lines)
> On Thu, Jan 23, 2025 at 11:19:29AM -0800, Vagrant Cascadian wrote:
>> On 2025-01-23, Vagrant Cascadian wrote:
>> > The attached patch removes the native-inputs on qemu-minimal for both
>> > grub-efi and grub-minimal, neither of which actually use qemu-minimal it
>> > because tests are disabled.
>> ...
>> > I did not test all reverse dependents yet, but both grub-efi and
>> > grub-minimal still build.
>>
>> And I still have not tested reverse dependents, because... there are no
>> dependents!
>>
>> Though grub-efi is presumably widely used on actual systems and I have
>> only tested a single aarch64 system...
>
> I'd like to eventually figure out running the tests, but I assume I'd
> do it on x86_64 only either due to test support or machine speed. No
> reason to keep it as an input for "eventually".

Sound reasonable to me!

Toggle quote (2 lines)
> LGTM!

Great, pushed as:

d3201247713f4de6d78b899ef6d9014fa9dfc542 gnu: grub-minimal, grub-efi: Reduce unused native-inputs.


live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZ6uyGgAKCRDcUY/If5cW
qiogAP4zFV/l6kXIS+q+OIp4cfw5wF5MEaKMcDDZa7d0NvUOXgEA5hPt7naEZRke
yWIVMtzQcjZk8J+OfIG+RXDNiixAVwo=
=RKpG
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75781@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75781
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help