[PATCH] gnu: Add r-phytools.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 months ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
9ba8e9eb988b67d495e168ae4f54bf85ea3b73ff.1737536954.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-phytools): New variable.

Change-Id: Ie4fa9f40febf3b114a3da38b9cdf668e8ac415ca
---
gnu/packages/cran.scm | 45 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 936f3cf593..7f822be32a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -38153,6 +38153,51 @@ (define-public r-phylogram
across a wide array of bioinformatic R packages.")
(license license:gpl3)))
+(define-public r-phytools
+ (package
+ (name "r-phytools")
+ (version "2.4-4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "phytools" version))
+ (sha256
+ (base32 "1i25dlikdx9av5653ra2709sjm9fc3fsis1yfsb7zagivi408ph9"))))
+ (properties `((upstream-name . "phytools")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ape
+ r-clustergeneration
+ r-coda
+ r-combinat
+ r-deoptim
+ r-doparallel
+ r-expm
+ r-foreach
+ r-maps
+ r-mass
+ r-mnormt
+ r-nlme
+ r-numderiv
+ r-optimparallel
+ r-phangorn
+ r-scatterplot3d))
+ (home-page "https://github.com/liamrevell/phytools")
+ (synopsis "Phylogenetic tools for comparative biology")
+ (description
+ "This package offers extensive tools for phylogenetic analysis.
+It focuses on phylogenetic comparative biology but also includes methods for
+visualizing, analyzing, manipulating, reading, writing, and inferring phylogenetic
+trees. Functions for comparative biology include ancestral state reconstruction,
+model fitting, and phylogeny and trait data simulation. A broad range of plotting
+methods includes mapping trait evolution on trees, projecting trees into phenotype
+space or geographic maps, and visualizing correlated speciation between trees.
+Additional functions allow for reading, writing, analyzing, inferring, simulating,
+and manipulating phylogenetic trees and comparative data. Examples include computing
+consensus trees, simulating trees and data under various models, and attaching species
+or clades to a tree either randomly or non-randomly. This package provides numerous tools
+for tree manipulations and analyses that are valuable for phylogenetic research.")
+ (license license:gpl2+)))
+
(define-public r-kmer
(package
(name "r-kmer")

base-commit: 309ad9fcdacf732691f0220c4122757d9940b97d
--
2.43.0
Ricardo Wurmus wrote 2 months ago
(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
87sepbawlh.fsf@elephly.net
Navid Afkhami <navid.afkhami@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-phytools): New variable.

Applied, thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 75750@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75750
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help