Alexis Simon wrote 2 months ago
(address . guix-patches@gnu.org)(name . Alexis Simon)(address . alexis.simon@runbox.com)
* gnu/packages/bioinformatics.scm (r-sigfit): New variable.
Change-Id: I9d63975d3512cf8583e7ec22f450bb4963c9ff2f
---
gnu/packages/bioinformatics.scm | 36 +++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
Toggle diff (51 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c98f6022bf..899606b195 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1526,6 +1526,42 @@ (define-public r-saige
tests in large cohorts and biobanks (SAIGE-GENE+).")
(license license:gpl2+))))
+(define-public r-sigfit
+ (package
+ (name "r-sigfit")
+ (version "2.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kgori/sigfit")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16r6m8p90rnb4hxl86fz3kbals3626232i8fj0zhhd23p89z3w4v"))))
+ (properties `((upstream-name . "sigfit")))
+ (build-system r-build-system)
+ (native-inputs (list r-codetools))
+ (propagated-inputs (list r-rcpp
+ r-rstan
+ r-rstantools
+ r-coda
+ r-clue
+ r-knitr
+ r-rmarkdown
+ r-bh
+ r-rcppeigen
+ r-stanheaders))
+ (home-page "https://github.com/kgori/sigfit")
+ (synopsis "Flexible Bayesian inference of mutational signatures")
+ (description
+ "R package to estimate signatures of mutational processes and their
+activities on mutation count data. Starting from a set of single-nucleotide
+variants (SNVs), it allows both estimation of the exposure of samples to
+predefined mutational signatures (including whether the signatures are
+present at all), and identification of signatures de novo from the mutation counts.")
+ (license license:gpl3)))
+
(define-public r-singlet
(let ((commit "765a6c45081807a1522f0e8983e2417822a36f36")
(revision "1"))
base-commit: cf34ba66cf614358dfac925212d6a9074e318d80
--
2.45.2