[PATCH] gnu: picom: Update to v12.5

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Fuglesteg Dale
  • Z572
Owner
unassigned
Submitted by
Andreas Fuglesteg Dale
Severity
normal

Debbugs page

Andreas Fuglesteg Dale wrote 2 months ago
(address . guix-patches@gnu.org)(name . Andreas Fuglesteg Dale)(address . andreasfdale@gmail.com)
410040a32f53135d0ac19ad8d993ea436beefe59.1737385471.git.andreasfdale@gmail.com
Change-Id: I8bbc55240845b509736fba031bcc26a80ae26b5e
---
gnu/packages/compton.scm | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/compton.scm b/gnu/packages/compton.scm
index 00bea96..0022992 100644
--- a/gnu/packages/compton.scm
+++ b/gnu/packages/compton.scm
@@ -41,7 +41,8 @@ (define-module (gnu packages compton)
#:use-module (gnu packages textutils)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
- #:use-module (gnu packages xorg))
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages ruby))
(define-public compton
(let ((upstream-version "0.1_beta2"))
@@ -113,7 +114,7 @@ (define-public compton
(define-public picom
(package
(name "picom")
- (version "11.2")
+ (version "12.5")
(source
(origin
(method git-fetch)
@@ -122,7 +123,7 @@ (define-public picom
(commit (string-append "v" version))))
(sha256
(base32
- "0swmpw6lj0aiwypdfkzsy38jwsm9wfcn7i5klrqfn2klrwinv27f"))
+ "1skkchrlir9si9ljawg0xcgpfnd2macw7ny5vhx5f5zk7b7iphhz"))
(file-name (string-append "picom-" version))))
(build-system meson-build-system)
(inputs
@@ -142,7 +143,7 @@ (define-public picom
xcb-util-image
xprop))
(native-inputs
- (list asciidoc pkg-config xorgproto))
+ (list pkg-config xorgproto ruby-asciidoctor))
(arguments
(list #:build-type "release"
#:configure-flags #~'("-Dwith_docs=true")

base-commit: 87045f0982bd7aebb07b380cbf322651227546f4
--
2.47.1
Z572 wrote 2 months ago
(name . Andreas Fuglesteg Dale)(address . andreasfdale@gmail.com)(address . 75722-done@debbugs.gnu.org)
87frlb16v0.fsf@iscas.ac.cn
Andreas Fuglesteg Dale <andreasfdale@gmail.com> writes:

Toggle quote (48 lines)
> Change-Id: I8bbc55240845b509736fba031bcc26a80ae26b5e
> ---
> gnu/packages/compton.scm | 9 +++++----
> 1 file changed, 5 insertions(+), 4 deletions(-)
>
> diff --git a/gnu/packages/compton.scm b/gnu/packages/compton.scm
> index 00bea96..0022992 100644
> --- a/gnu/packages/compton.scm
> +++ b/gnu/packages/compton.scm
> @@ -41,7 +41,8 @@ (define-module (gnu packages compton)
> #:use-module (gnu packages textutils)
> #:use-module (gnu packages xdisorg)
> #:use-module (gnu packages xml)
> - #:use-module (gnu packages xorg))
> + #:use-module (gnu packages xorg)
> + #:use-module (gnu packages ruby))
>
> (define-public compton
> (let ((upstream-version "0.1_beta2"))
> @@ -113,7 +114,7 @@ (define-public compton
> (define-public picom
> (package
> (name "picom")
> - (version "11.2")
> + (version "12.5")
> (source
> (origin
> (method git-fetch)
> @@ -122,7 +123,7 @@ (define-public picom
> (commit (string-append "v" version))))
> (sha256
> (base32
> - "0swmpw6lj0aiwypdfkzsy38jwsm9wfcn7i5klrqfn2klrwinv27f"))
> + "1skkchrlir9si9ljawg0xcgpfnd2macw7ny5vhx5f5zk7b7iphhz"))
> (file-name (string-append "picom-" version))))
> (build-system meson-build-system)
> (inputs
> @@ -142,7 +143,7 @@ (define-public picom
> xcb-util-image
> xprop))
> (native-inputs
> - (list asciidoc pkg-config xorgproto))
> + (list pkg-config xorgproto ruby-asciidoctor))
> (arguments
> (list #:build-type "release"
> #:configure-flags #~'("-Dwith_docs=true")
>
> base-commit: 87045f0982bd7aebb07b380cbf322651227546f4
Commit message should likes:

```
gnu: picom: Update to 12.5.

* gnu/packages/compton.scm (picom): Update to 12.5.
[native-inputs]: Add ruby-asciidoctor. Remove asciidoc.

```

Adjust and pushed, closing.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmeQyAMACgkQO1qpk+Gi
3/D06g/+O9lsBf7SCkk23eShDhQc2cETNU3Dtp06trX9vssQjz+3m6t1LURXMduC
Ps8/vZkcLY9aBtxsQ2NV+BVxFyAGXPKyRt+wkXR52mxsWO5B7arIMak1pYwrs4rV
bZi2RHmSCcvkn014DtRwn/emo1uet3SEqDWsOMK8QybGTeLhBcMx+qE+SayvtJ6L
MTf3OpVD5cUMeEtzm5iyiSoidwnFpXfXlxzU2T/NFAyZi2w+I6gtlffqGt5cX4wg
Dq/TQuj66kP6DX/vjNSr+kZr8ikKbZ3I3AbGV5sBozTu/e8s/RDfAeXuYhizwWhM
sdxZlLZbF9uIs6OHEhwnIw8We83vJNm49mYIV/L3yOqnPS/NspsNkq2oDAc4k44+
Xb6SU+FfROGW5504BmEvO3/JhoReOFH+IXwZOwLGwKcO7dDB8qipT3gW1gWTDweY
OU86g5uFdO2bSeII5ipuLY621v1M4j7r6wYfFmvwlEkKuaN/pzFtA1YUlVw8ReCx
KSZyXAXyMqIY6XUOjJIvbv9G8KbbabGbaWjTsEQiVYQJzBunReK+r8B+NvGqgV93
aJvsOyvcszR4cj7OrAnfQxSW/RB0d7YG4kzrBDG8noTKtWmRV+kmZPoePEpXtK9d
4cFp4hlRdcUKWYjWipuyhU7Hf3vd9RXt2Y3bMBe3gvREUsH9N1E=
=zs3+
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 75722@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75722
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help