[PATCH v3 09/11] gnu: Add libretro-database.

  • Done
  • quality assurance status badge
Details
One participant
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 20 Jan 15:28 +0100
(address . guix-patches@gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
5ba49ba233647240e4fced5a1b6d17f539103556.1737383313.git.maxim.cournoyer@gmail.com
* gnu/packages/emulators.scm (libretro-database): New variable.

Change-Id: I97b10abf9b2984cf2a622517b3c794474e98a3d0
---
gnu/packages/emulators.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 39c43803e5..aaf8803ee9 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1805,6 +1805,44 @@ (define-public libretro-core-info
(define-public retroarch-core-info
(deprecated-package "retroarch-core-info" libretro-core-info))
+(define-public libretro-database
+ (package
+ (name "libretro-database")
+ (version "1.20.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libretro/libretro-database")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "086a9grpd1irsdns2zx3hlna72bbrmsfra4r498wi4ia9zf8nb0p"))))
+ (build-system gnu-build-system)
+ (arguments (list #:tests? #f
+ #:make-flags #~(list (string-append "PREFIX=" #$output))))
+ (home-page "https://github.com/libretro/libretro-database/")
+ (synopsis "Cheat codes and content data files for RetroArch")
+ (description "RetroArch incorporates a ROM scanning system to
+automatically produce playlists. Each ROM that is scanned by the playlist
+generator is checked against a database of ROMs that are known to be good
+copies. The various directories contain:
+@table @code
+@item cht
+Cheat codes for various games
+@item cursors
+Methods for querying the playlists
+@item dat
+Customized DAT files, maintained by the libretro team
+@item metadat
+Different metadata and third-party DATs available to the system
+@item rdb
+The compiled RetroArch database files
+@item scripts
+Various scripts that are used to maintain the database files.
+@end table")
+ (license license:cc-by-sa4.0)))
+
(define-public retroarch-joypad-autoconfig
(package
(name "retroarch-joypad-autoconfig")
--
2.47.1
M
M
Maxim Cournoyer wrote on 23 Jan 13:12 +0100
control message for bug #75700
(address . control@debbugs.gnu.org)
87ikq5iv99.fsf@gmail.com
tags 75700 notabug
close 75700
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75700@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75700
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch