[PATCH v3 01/11] gnu: Add soundtouch-1/integer-samples.

  • Done
  • quality assurance status badge
Details
One participant
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 20 Jan 15:28 +0100
(address . guix-patches@gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
7a983f303aba15d35ec687bcba4de4fee572899b.1737383313.git.maxim.cournoyer@gmail.com
* gnu/packages/audio.scm (soundtouch-1/integer-samples): New variable.

Change-Id: Iea6e1313f2c7189ded9abf100f07ed530793f9f0
---
gnu/packages/audio.scm | 26 +++++++++++++++++++++++++-
1 file changed, 25 insertions(+), 1 deletion(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 712337dda8..1c4f3176ee 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2016–2023 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2020, 2024 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 okapi <okapi@firemail.cc>
-;;; Copyright © 2018, 2020, 2022, 2023, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2018, 2020, 2022-2025 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2018, 2019, 2022 Marius Bakke <marius@gnu.org>
@@ -4355,6 +4355,30 @@ (define-public soundtouch
control functionality, or just for playing around with the sound effects.")
(license license:lgpl2.1+)))
+(define-public soundtouch-1/integer-samples
+ (package
+ (inherit soundtouch)
+ (name "soundtouch")
+ (version "1.9.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/soundtouch/soundtouch.git")
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ir961w5gz86cm6yivr1ypi6n2y52vn319gy2gvdkkbbz5wyjkrq"))))
+ (arguments
+ ;; Dolphin expects the samples to be of the integer type.
+ (list #:configure-flags #~(list "--enable-integer-samples")
+ #:phases #~(modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ ;; Avoid the bootstrap script, which has a broken
+ ;; shebang.
+ (invoke "autoreconf" "-vif"))))))))
+
(define-public stargate-soundtouch
;; Stargate's fork of soundtouch.
(let ((commit "464f474c0be5d7e0970909dd30593012e4621468")

base-commit: 2565da3bac6b345e64096d19794bcf41a4b50e37
--
2.47.1
M
M
Maxim Cournoyer wrote on 23 Jan 13:11 +0100
control message for bug #75692
(address . control@debbugs.gnu.org)
87tt9pivax.fsf@gmail.com
tags 75692 notabug
close 75692
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75692@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75692
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch