Navid Afkhami wrote 2 months ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
* gnu/packages/cran.scm (r-deoptim): New variable.
Change-Id: I0db4f2aa6707ffa99c2e57f616689dcd3a296236
---
gnu/packages/cran.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7489954875..a45d2a5f07 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5643,6 +5643,28 @@ (define-public r-deming
regression and Passing-Bablock regression functions.")
(license license:lgpl2.0+)))
+(define-public r-deoptim
+ (package
+ (name "r-deoptim")
+ (version "2.2-8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "DEoptim" version))
+ (sha256
+ (base32 "0k7mvf7j8y1sqv8zpiwkw4xcmgki37drkxjijrsmmhkfybfan7k3"))))
+ (properties `((upstream-name . "DEoptim")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-parallelly))
+ (home-page "https://github.com/ArdiaD/DEoptim")
+ (synopsis "Global optimization by differential evolution")
+ (description
+ "This package implements the Differential Evolution algorithm.
+This Algorithm is used for the global optimization of a real-valued
+function of a real-valued parameter vector. The implementation of
+DifferentialEvolution in DEoptim interfaces with C code forefficiency.")
+ (license license:gpl2+)))
+
(define-public r-depmixs4
(package
(name "r-depmixs4")
base-commit: c985075db3e6682d8a5a231c01c770aa5a147f72
--
2.43.0